]> git.pld-linux.org Git - packages/drupal.git/commitdiff
- updated source/patches for 6.16; untested
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 4 May 2010 15:34:36 +0000 (15:34 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    drupal-cron.patch -> 1.7
    drupal-themedir2.patch -> 1.3
    drupal-topdir.patch -> 1.6
    drupal.spec -> 1.82

drupal-cron.patch
drupal-themedir2.patch [deleted file]
drupal-topdir.patch
drupal.spec

index 8b90534d91a7d7e10b5aa064e9c09607f6d9dc1f..3341281eb4190bae5c1887fc16c638e64f06e3b1 100644 (file)
@@ -20,42 +20,16 @@ diff -uNdr drupal-5.7.old/cron.php drupal-5.7/cron.php
  include_once './includes/bootstrap.inc';
  drupal_bootstrap(DRUPAL_BOOTSTRAP_FULL);
  drupal_cron_run();
-diff -uNdr drupal-5.7.old/includes/bootstrap.inc drupal-5.7/includes/bootstrap.inc
---- drupal-5.7.old/includes/bootstrap.inc      2008-01-10 23:14:24.000000000 +0100
-+++ drupal-5.7/includes/bootstrap.inc  2008-02-16 16:02:23.000000000 +0100
-@@ -201,7 +201,7 @@
-   $confdir = 'sites';
-   $uri = explode('/', $_SERVER['SCRIPT_NAME'] ? $_SERVER['SCRIPT_NAME'] : $_SERVER['SCRIPT_FILENAME']);
--  $server = explode('.', implode('.', array_reverse(explode(':', rtrim($_SERVER['HTTP_HOST'], '.')))));
-+  $server = explode('.', implode('.', array_reverse(explode(':', rtrim(@$_SERVER['HTTP_HOST'], '.')))));
-   for ($i = count($uri) - 1; $i > 0; $i--) {
-     for ($j = count($server); $j > 0; $j--) {
-       $dir = implode('.', array_slice($server, -$j)) . implode('.', array_slice($uri, 0, $i));
-@@ -240,7 +240,7 @@
-   global $db_url, $db_prefix, $cookie_domain, $conf, $installed_profile;
-   $conf = array();
--  include_once './'. conf_path() .'/settings.php';
-+  include_once conf_path() .'/settings.php';
-   if (isset($base_url)) {
-     // Parse fixed base URL from settings.php.
-@@ -258,7 +258,7 @@
-     // As $_SERVER['HTTP_HOST'] is user input, ensure it only contains
-     // characters allowed in hostnames.
--    $base_url = $base_root .= '://'. preg_replace('/[^a-z0-9-:._]/i', '', $_SERVER['HTTP_HOST']);
-+    $base_url = $base_root .= '://'. preg_replace('/[^a-z0-9-:._]/i', '', @$_SERVER['HTTP_HOST']);
-     // $_SERVER['SCRIPT_NAME'] can, in contrast to $_SERVER['PHP_SELF'], not
-     // be modified by a visitor.
-@@ -886,7 +886,7 @@
-     case DRUPAL_BOOTSTRAP_ACCESS:
-       // Deny access to hosts which were banned - t() is not yet available.
--      if (drupal_is_denied('host', $_SERVER['REMOTE_ADDR'])) {
-+      if (drupal_is_denied('host', @$_SERVER['REMOTE_ADDR'])) {
-         header('HTTP/1.1 403 Forbidden');
-         print 'Sorry, '. $_SERVER['REMOTE_ADDR']. ' has been banned.';
-         exit();
+--- drupal-6.16/includes/bootstrap.inc~        2010-05-04 18:27:27.000000000 +0300
++++ drupal-6.16/includes/bootstrap.inc 2010-05-04 18:31:49.802495730 +0300
+@@ -318,8 +318,8 @@
+     $_SERVER['HTTP_HOST'] = '';
+   }
+-  if (file_exists('./'. conf_path() .'/settings.php')) {
+-    include_once './'. conf_path() .'/settings.php';
++  if (file_exists(conf_path() .'/settings.php')) {
++    include_once conf_path() .'/settings.php';
+   }
+   // Ignore the placeholder url from default.settings.php.
diff --git a/drupal-themedir2.patch b/drupal-themedir2.patch
deleted file mode 100644 (file)
index d9c6f8e..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- drupal-5.0/includes/theme.inc~     2007-01-26 13:09:14.801730081 +0200
-+++ drupal-5.0/includes/theme.inc      2007-01-26 13:09:52.242575644 +0200
-@@ -65,6 +65,6 @@
-     // File is a template/theme
-     // Load its CSS, if it exists
--    if (file_exists($stylesheet = dirname($themes[$theme]->filename) .'/style.css')) {
-+    if (file_exists('htdocs/' . ($stylesheet = dirname($themes[$theme]->filename) .'/style.css'))) {
-       drupal_add_css($stylesheet, 'theme');
-     }
-   }
index b14dd20a6c5cf3565dee475333311722561f6877..6239d857e137e24b5c869e22c727db4e67e7af74 100644 (file)
  include_once './includes/bootstrap.inc';
  drupal_bootstrap(DRUPAL_BOOTSTRAP_FULL);
  include_once './includes/xmlrpc.inc';
---- drupal-5.7/update.php.old  2007-04-08 02:54:04.000000000 +0200
-+++ drupal-5.7/update.php      2008-02-17 21:15:36.000000000 +0100
-@@ -765,6 +765,7 @@
+--- drupal-6.16/update.php~    2010-05-04 18:32:33.000000000 +0300
++++ drupal-6.16/update.php     2010-05-04 18:32:53.539378793 +0300
+@@ -563,6 +563,7 @@
  // Our custom error handler is not yet installed, so we just suppress them.
  ini_set('display_errors', FALSE);
  
 +chdir('..');
- include_once './includes/bootstrap.inc';
- update_fix_system_table();
+ require_once './includes/bootstrap.inc';
  
+ // We only load DRUPAL_BOOTSTRAP_CONFIGURATION for the update requirements
index 153ca2ddb47cec693a4bbc2ea1ebe11a3ef01041..bb49455e1a58a394bcacd4f0cbfc4e78449b415d 100644 (file)
@@ -1,24 +1,21 @@
-# TODO
-# - why not drupal 6.0?
 Summary:       Open source content management platform
 Summary(pl.UTF-8):     Platforma do zarządzania treścią o otwartych źródłach
 Name:          drupal
-Version:       5.7
-Release:       0.4
+Version:       6.16
+Release:       0.1
 License:       GPL
 Group:         Applications/WWW
-Source0:       http://ftp.osuosl.org/pub/drupal/files/projects/%{name}-%{version}.tar.gz
-# Source0-md5: c7d9911ad1001c790bbdfe6fd4cdfc89
+Source0:       http://ftp.drupal.org/files/projects/%{name}-%{version}.tar.gz
+# Source0-md5: bb27c1f90680b86df2c535b2d52e8021
 Source1:       %{name}.conf
 Source2:       %{name}.cron
 Source3:       %{name}.PLD
 Patch0:                %{name}-cron.patch
 Patch1:                %{name}-sitesdir.patch
 Patch2:                %{name}-topdir.patch
-Patch3:                %{name}-themedir2.patch
 #Patchx:       %{name}-replication.patch
 #Patchx:       %{name}-emptypass.patch
-URL:           http://drupal.org/
+URL:           http://www.drupal.org/
 BuildRequires: rpmbuild(macros) >= 1.264
 BuildRequires: sed >= 4.0
 Requires:      %{name}(DB_Driver) = %{version}-%{release}
@@ -164,7 +161,6 @@ nazywane rozproszonym uwierzytelnianiem.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 # cleanup backups after patching
 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
This page took 0.0943 seconds and 4 git commands to generate.