]> git.pld-linux.org Git - packages/drupal.git/blob - drupal.spec
c1322eb5f16da1c8b12bf15a0d425fd4b38316b0
[packages/drupal.git] / drupal.spec
1 Summary:        Open source content management platform
2 Summary(pl):    Platforma do zarz±dzania tre¶ci± o otwartych ¼ród³ach
3 Name:           drupal
4 Version:        4.6.3
5 Release:        0.23
6 License:        GPL
7 Group:          Applications/WWW
8 Source0:        http://drupal.org/files/projects/%{name}-%{version}.tar.gz
9 # Source0-md5:  f436973f02aa2cea15ef1ca90223082b
10 Source1:        %{name}.conf
11 Source2:        %{name}.cron
12 Source3:        %{name}.PLD
13 Patch3:         %{name}-replication.patch
14 Patch5:         %{name}-sitesdir.patch
15 Patch6:         %{name}-topdir.patch
16 Patch7:         %{name}-themedir2.patch
17 Patch8:         %{name}-emptypass.patch
18 Patch9:         %{name}-cron.patch
19 URL:            http://drupal.org/
20 BuildRequires:  rpmbuild(macros) >= 1.194
21 BuildRequires:  sed >= 4.0
22 Requires:       apache >= 1.3.33-3
23 Requires:       apache(mod_dir)
24 Requires:       apache(mod_access)
25 Requires:       apache(mod_expires)
26 Requires:       apache(mod_rewrite)
27 Requires:       apache(mod_alias)
28 Requires:       php >= 3:4.3.3
29 Requires:       php-mysql
30 Requires:       php-pcre
31 #Requires:      php-pgsql
32 Requires:       php-xml
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _appdir         %{_datadir}/%{name}
37 %define         _sysconfdir     /etc/%{name}
38
39 %description
40 Drupal is software that allows an individual or a community of users
41 to easily publish, manage and organize a great variety of content on a
42 website. Tens of thousands of people and organizations have used
43 Drupal to set up scores of different kinds of web sites, including
44 - community web portals and discussion sites
45 - corporate web sites/intranet portals
46 - personal web sites
47 - afficionado sites
48 - e-commerce applications
49 - resource directories
50
51 Drupal includes features to enable
52 - content management systems
53 - blogs
54 - collaborative authoring environments
55 - forums
56 - newsletters
57 - picture galleries
58 - file uploads and download
59
60 and much more.
61
62 %description -l pl
63 Drupal to oprogramowanie pozwalaj±ce osobie lub spo³eczno¶ci
64 u¿ytkowników na ³atwe publikowanie, zarz±dzanie i organizowanie ró¿nej
65 tre¶ci na stronie WWW. Dziesi±tki tysiêcy ludzi i organizacji u¿ywali
66 Drupala do ustawiania wyników ró¿nych rodzajów stron WWW, w tym:
67 - portale WWW i strony dyskusyjne spo³eczno¶ci
68 - korporacyjne strony WWW/portale intranetowe
69 - osobiste strony WWW
70 - strony mi³o¶ników
71 - aplikacje e-commerce
72 - s³owniki zasobów
73
74 Drupal zawiera zasoby umo¿liwiaj±ce tworzenie:
75 - systemów zarz±dzania tre¶ci±
76 - blogów
77 - ¶rodowisk pracy grupowej
78 - forów
79 - nowin
80 - galerii zdjêæ
81 - wrzucania i ¶ci±gania plików
82
83 i wiele wiêcej.
84
85 %package cron
86 Summary:        Drupal cron
87 Summary(pl):    Us³uga cron dla Drupala
88 Group:          Applications/WWW
89 Requires:       %{name} = %{version}-%{release}
90 Requires:       crondaemon
91 Requires:       php-cli >= 3:4.3.3
92
93 %description cron
94 This package contains script which invokes cron hooks for Drupal.
95
96 %description cron -l pl
97 Ten pakiet zawiera skrypt wywo³uj±cy uchwyty crona dla Drupala.
98
99 %package xmlrpc
100 Summary:        XMLRPC server for Drupal
101 Summary(pl):    Serwer XMLRPC dla Drupala
102 Group:          Applications/WWW
103 Requires:       %{name} = %{version}-%{release}
104
105 %description xmlrpc
106 XMLRPC server for Drupal allows other Drupals authorize with your
107 Drupal's user creditentials, this is called Distributed Authentication
108 in Drupal world.
109
110 %description xmlrpc -l pl
111 Serwer XMLRPC dla Drupala pozwala innym Drupalom autoryzowaæ siê z
112 danymi uwierzytelniaj±cymi u¿ytkownika danego Drupala - jest to
113 nazywane rozproszonym uwierzytelnianiem.
114
115 %prep
116 %setup -q
117 %patch3 -p1
118 %patch5 -p1
119 %patch6 -p1
120 %patch7 -p1
121 %patch8 -p1
122 %patch9 -p1
123
124 find -name '*~' | xargs -r rm -v
125 cp %{SOURCE3} README.PLD
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/cron.d,/var/{cache,lib}/%{name}} \
130         $RPM_BUILD_ROOT%{_appdir}/{po,modules/po,htdocs/modules}
131
132 cp -a *.ico index.php $RPM_BUILD_ROOT%{_appdir}/htdocs
133 cp -a misc $RPM_BUILD_ROOT%{_appdir}/htdocs
134 cp -a xmlrpc.php $RPM_BUILD_ROOT%{_appdir}/htdocs
135
136 cp -a cron.php $RPM_BUILD_ROOT%{_appdir}
137 cp -a modules/* $RPM_BUILD_ROOT%{_appdir}/modules
138 cp -a includes scripts $RPM_BUILD_ROOT%{_appdir}
139 cp -a sites $RPM_BUILD_ROOT%{_sysconfdir}
140
141 ln -s /var/lib/%{name} $RPM_BUILD_ROOT%{_appdir}/files
142
143 # install themes
144 cp -a themes $RPM_BUILD_ROOT%{_appdir}/htdocs
145 # move .xtmpl/.theme out of htdocs
146 (cd $RPM_BUILD_ROOT%{_appdir}/htdocs && tar cf - --remove-files themes/*/*.{xtmpl,theme}) | tar -xf - -C $RPM_BUILD_ROOT%{_appdir}
147 mv $RPM_BUILD_ROOT%{_appdir}/{htdocs/,}themes/engines
148 # make screenshot.png available in appdir
149 for a in $RPM_BUILD_ROOT%{_appdir}/htdocs/themes/*; do
150         t=$(basename $a)
151         ln -s ../../htdocs/themes/$t/screenshot.png $RPM_BUILD_ROOT%{_appdir}/themes/$t
152 done
153
154 # a hack
155 s=themes/chameleon/marvin
156 ln -s ../../htdocs/$s $RPM_BUILD_ROOT%{_appdir}/$s
157
158 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
159 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post
165 if [ "$1" = 1 ]; then
166 %banner -e %{name} <<EOF
167 If this is your first install of Drupal, you need to create drupal database:
168 mysqladmin create drupal
169
170 and import initial schema:
171 zcat %{_docdir}/%{name}-%{version}/database/database.mysql.gz | mysql drupal
172
173 Also read INSTALL from documentation!
174
175 EOF
176 fi
177
178 %triggerin -- apache1 >= 1.3.33-2
179 %apache_config_install -v 1 -c %{_sysconfdir}/apache.conf
180
181 %triggerun -- apache1 >= 1.3.33-2
182 %apache_config_uninstall -v 1
183
184 %triggerin -- apache >= 2.0.0
185 %apache_config_install -v 2 -c %{_sysconfdir}/apache.conf
186
187 %triggerun -- apache >= 2.0.0
188 %apache_config_uninstall -v 2
189
190 %files
191 %defattr(644,root,root,755)
192 %doc *.txt database README.replication README.PLD
193
194 %attr(750,root,http) %dir %{_sysconfdir}
195 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
196
197 %attr(750,root,http) %dir %{_sysconfdir}/sites
198 %attr(750,root,http) %dir %{_sysconfdir}/sites/default
199 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sites/default/*
200
201 %dir %{_appdir}
202 %{_appdir}/includes
203 %{_appdir}/modules
204 %{_appdir}/scripts
205 %{_appdir}/themes
206 %{_appdir}/po
207 # symlink
208 %{_appdir}/files
209
210 %dir %{_appdir}/htdocs
211 %{_appdir}/htdocs/*.ico
212 %{_appdir}/htdocs/index.php
213 %{_appdir}/htdocs/misc
214 %{_appdir}/htdocs/themes
215 %{_appdir}/htdocs/modules
216
217 %dir %attr(775,root,http) /var/lib/%{name}
218 %dir %attr(775,root,http) /var/cache/%{name}
219
220 %files cron
221 %defattr(644,root,root,755)
222 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
223 %{_appdir}/cron.php
224
225 %files xmlrpc
226 %defattr(644,root,root,755)
227 %{_appdir}/htdocs/xmlrpc.php
This page took 0.081147 seconds and 2 git commands to generate.