]> git.pld-linux.org Git - packages/drupal-mod-tinymce.git/blob - drupal-mod-tinymce.spec
- works
[packages/drupal-mod-tinymce.git] / drupal-mod-tinymce.spec
1 %define         modname tinymce
2 Summary:        Drupal TinyMCE WYSIWYG Editor Module
3 Summary(pl):    Modu³ edytora WYSIWYG TinyMCE dla Drupala
4 Name:           drupal-mod-%{modname}
5 Version:        4.6.0
6 Release:        0.15
7 Epoch:          0
8 License:        GPL
9 Group:          Applications/WWW
10 Source0:        http://drupal.org/files/projects/%{modname}-%{version}.tar.gz
11 # Source0-md5:  dd7630860baf1f7f470d71c272d275eb
12 Source1:        %{name}.conf
13 URL:            http://drupal.org/project/tinymce
14 BuildRequires:  rpmbuild(macros) >= 1.194
15 BuildRequires:  sed >= 4.0
16 Requires:       drupal >= 4.6.0
17 Requires:       tinymce >= 1.44
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _sysconfdir     /etc/drupal
22 %define         _moddir         %{_datadir}/drupal/modules
23 %define         _htmldir        %{_datadir}/drupal/htdocs/modules
24 %define         _tinymceplugindir       %{_datadir}/tinymce/plugins
25
26 %description
27 Use the TinyMCE WYSIWYG editor for editing site content. A
28 collaborative project by richardb, mathias and jjeff.
29
30 Features include:
31 - Drupal image upload integration
32 - Dynamically turn off/on TinyMCE per textarea field
33 - Assign different tinymce profiles per role
34
35 %description -l pl
36 Ten modu³ pozwala u¿ywaæ edytora WYSIWYG TinyMCE do modyfikowania
37 tre¶ci stron. Jest to wspólny projekt, który stworzyli richardb,
38 mathias i jjeff.
39
40 Mo¿liwo¶ci obejmuj±:
41 - integracjê umieszczania obrazków w Drupalu
42 - dynamiczne wy³±czanie/w³±czanie TinyMCE dla pól textarea
43 - przypisywanie ró¿nych profili tinymce dla ról
44
45 %prep
46 %setup -q -n %{modname}
47 rm -f LICENSE.txt # pure GPL
48
49 # undos the source
50 find '(' -name '*.txt' ')' -print0 | xargs -0 sed -i -e 's,
51 $,,'
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_moddir},%{_htmldir}}
56 install -d $RPM_BUILD_ROOT%{_tinymceplugindir}
57
58 install *.module $RPM_BUILD_ROOT%{_moddir}
59 cp -a plugins/* $RPM_BUILD_ROOT%{_tinymceplugindir}
60 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache-%{modname}.conf
61
62 install -d $RPM_BUILD_ROOT%{_htmldir}/tinymce/jscripts
63 ln -s %{_datadir}/tinymce $RPM_BUILD_ROOT%{_htmldir}/tinymce/jscripts/tiny_mce
64 ln -s ../htdocs/modules/tinymce $RPM_BUILD_ROOT%{_moddir}/tinymce
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 if [ "$1" = 1 ]; then
71 %banner -e %{name} <<EOF
72 If this your first install of %{modname} module, load the database definition file:
73 zcat %{_docdir}/%{name}-%{version}/tinymce.mysql.gz | mysql drupal
74
75 EOF
76 fi
77
78 %files
79 %defattr(644,root,root,755)
80 %doc *.txt tinymce.{mysql,pgsql}
81 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
82 %{_moddir}/*.module
83 %{_moddir}/tinymce
84 %{_htmldir}/tinymce
85 %{_tinymceplugindir}/*
This page took 0.125729 seconds and 3 git commands to generate.