]> git.pld-linux.org Git - packages/drupal-mod-image.git/blob - drupal-mod-image.spec
- tabs in preamble
[packages/drupal-mod-image.git] / drupal-mod-image.spec
1 %define         modname image
2 Summary:        Drupal Image Module
3 Summary(pl.UTF-8):      Moduł Image dla Drupala
4 Name:           drupal-mod-%{modname}
5 Version:        4.6.0
6 Release:        0.24
7 License:        GPL
8 Group:          Applications/WWW
9 Source0:        http://drupal.org/files/projects/%{modname}-%{version}.tar.gz
10 # Source0-md5:  8b5c011a83fad3cac38a4d670e117f4c
11 URL:            http://drupal.org/project/image
12 BuildRequires:  rpmbuild(macros) >= 1.194
13 Requires:       ImageMagick
14 Requires:       ImageMagick-coder-jpeg
15 Requires:       ImageMagick-coder-jpeg2
16 Requires:       ImageMagick-coder-png
17 Requires:       ImageMagick-coder-tiff
18 Requires:       drupal >= 4.6.0
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _drupaldir      %{_datadir}/drupal
23 %define         _moddir         %{_drupaldir}/modules
24 %define         _incdir         %{_drupaldir}/includes
25 %define         _htdocs         %{_drupaldir}/htdocs
26 %define         _podir          %{_drupaldir}/po/%{modname}
27 %define         _filesdir       /var/lib/drupal
28 %define         _htmlmoddir     %{_htdocs}/modules
29
30 %description
31 This module allow users with proper permissions to upload images into
32 Drupal. Thumbnails are created automatically.
33
34 Images could be posted individually to the front page, included in
35 stories or grouped in galleries.
36
37 %description -l pl.UTF-8
38 Ten moduł pozwala użytkownikom z odpowiednimi prawami umieszczać
39 obrazki w Drupalu. Miniaturki tworzone są automatycznie.
40
41 Obrazki mogą być wysyłane pojedynczo na stronę główną, włączane do
42 artykułów albo grupowane w galeriach.
43
44 %prep
45 %setup -q -n %{modname}
46 rm -f LICENSE.txt # pure GPL
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_moddir},%{_podir},%{_htmlmoddir},%{_incdir},%{_filesdir}/images/temp}
51
52 install *.module $RPM_BUILD_ROOT%{_moddir}
53 install *.inc $RPM_BUILD_ROOT%{_incdir}
54 install *.css $RPM_BUILD_ROOT%{_htmlmoddir}
55 cp -a po/*.po $RPM_BUILD_ROOT%{_podir}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 if [ "$1" = 1 ]; then
62 %banner -e %{name} <<EOF
63 If you want to use localization, then you need to upload .po files
64 from %{_podir} via drupal locatization admin.
65
66 EOF
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc *.txt po/*.pot *.php
72 %{_moddir}/*.module
73 %{_incdir}/*.inc
74 %{_podir}
75 %{_htmlmoddir}/*.css
76 %dir %attr(775,root,http) %{_filesdir}/images
77 %dir %attr(775,root,http) %{_filesdir}/images/temp
This page took 0.070335 seconds and 3 git commands to generate.