]> git.pld-linux.org Git - packages/drupal-mod-bookmarks.git/blob - drupal-mod-bookmarks.spec
- new Drupal module
[packages/drupal-mod-bookmarks.git] / drupal-mod-bookmarks.spec
1 %define         modname bookmarks
2 Summary:        Drupal Bookmarks Module
3 Name:           drupal-mod-%{modname}
4 Version:        4.6.0
5 Release:        0.2
6 License:        GPL v2
7 Group:          Applications/WWW
8 Source0:        http://drupal.org/files/projects/%{modname}-%{version}.tar.gz
9 # Source0-md5:  4373ba31537b9625af825cd86a65c39b
10 URL:            http://drupal.org/project/bookmarks
11 BuildRequires:  rpmbuild(macros) >= 1.194
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _drupaldir      %{_datadir}/drupal
16 %define         _moddir         %{_drupaldir}/modules
17 %define         _htdocs         %{_drupaldir}/htdocs
18 %define         _htmlmoddir     %{_htdocs}/modules/%{modname}
19 %define         _podir          %{_drupaldir}/po/%{modname}
20
21 %description
22 Gives users with the 'access bookmark' permission their own private
23 bookmark block, allowing them to add any URL to the list. There is
24 also a quicklink feature that makes it a breeze to add the currently
25 viewed page to your site.
26
27 %prep
28 %setup -q -n %{modname}
29 rm -f LICENSE.txt # GPL v2
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_moddir},%{_podir},%{_htmlmoddir}}
34
35 install *.module $RPM_BUILD_ROOT%{_moddir}
36 cp -a po/*.po $RPM_BUILD_ROOT%{_podir}
37 cp -a *.gif $RPM_BUILD_ROOT%{_htmlmoddir}
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %post
43 if [ "$1" = 1 ]; then
44 %banner -e %{name} <<EOF
45 If you want to use localization, then you need to upload .po files
46 from %{_podir} via drupal locatization admin.
47
48 To create Bookmarks MySQL database tables import:
49 zcat %{_docdir}/%{name}-%{version}/%{modname}.mysql.gz | mysql drupal
50
51 EOF
52 fi
53
54 %files
55 %defattr(644,root,root,755)
56 %doc *.txt bookmarks.mysql
57 %{_moddir}/*.module
58 %{_podir}
59 %{_htmlmoddir}
This page took 0.057395 seconds and 3 git commands to generate.