]> git.pld-linux.org Git - packages/dropbox.git/blobdiff - dropbox.spec
up to 3.20.1
[packages/dropbox.git] / dropbox.spec
index 83554070085105c21126b526fdbabee83046cceb..6cc6d45ee1b93e641cb86acd6b74289408962096 100644 (file)
@@ -9,15 +9,15 @@
 #   http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
 Summary:       Sync and backup files between computers
 Name:          dropbox
-Version:       2.10.52
+Version:       3.20.1
 Release:       1
 License:       Proprietary
 Group:         Daemons
 Source0:       http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
-# NoSource0-md5:       e573ed3b2dad210d2a4769e483051729
+# NoSource0-md5:       16771129c254907d29e64c779773493a
 NoSource:      0
 Source1:       http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
-# NoSource1-md5:       e23a1d44e287a265ae9d57a0b2d6188c
+# NoSource1-md5:       3cc42ea6d41a1d9d3f13eaa0917ee510
 NoSource:      1
 URL:           http://www.dropbox.com/
 BuildRequires: rpmbuild(macros) >= 1.566
@@ -32,8 +32,11 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # generate no Provides from private modules
 %define                _noautoprovfiles        %{_libdir}/%{name}
 
+# libicu-42, but pld th already has 54
+%define                icu_libs        libicudata.so.42 libicui18n.so.42 libicuuc.so.42
+
 # provided by package itself, but autodeps disabled
-%define                _noautoreq              libwx_.*.so librsync.so.1 libffi.so.6
+%define                _noautoreq              libwx_.*.so %{icu_libs} libffi.so.6 librsync.so.1
 
 # a zip and executable at the same time
 %define                _noautostrip    .*/library.zip\\|.*/dropbox
@@ -42,7 +45,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _enable_debug_packages  0
 
 # prelinked library, it is missing some cairo symbols
-%define                skip_post_check_so      libwx_gtk2ud_core-2.8.so.0
+#define                skip_post_check_so      libwx_gtk2ud_core-2.8.so.0
 
 %description
 Dropbox is software that syncs your files online and across your
@@ -77,13 +80,10 @@ mv dropbox-lnx.*-%{version}/* .
 #%{__rm} -r distribute-0.6.26-py2.7.egg
 
 # libraries to be taken from system
-# for a in *.so*; do ls -ld /lib/$a /usr/lib/$a; done 2>/dev/null
-%{__rm} libpng12.so.0 libbz2.so.1.0 libpopt.so.0
-
-# make into symlink, looks cleaner than hardlink:
-# we can attach executable attrs to binary and leave no attrs for symlink in
-# %files section.
-ln -sf dropbox library.zip
+# for a in *.so*; do ls -ld /lib64/$a %{_libdir}/$a; done 2>/dev/null
+%{__rm} libpopt.so.0 libdrm.so.2 libGL.so.1
+#%{__rm} libffi.so.6 librsync.so.1
+#%{__rm} libQt5{Core,DBus,Gui,Network,OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets,Widgets}.so.5
 
 # fun, let's delete non-linux files from archive
 unzip -l library.zip | \
@@ -92,6 +92,11 @@ unzip -l library.zip | \
        awk '{print $NF}' > lib.delete
 zip library.zip -d $(cat lib.delete)
 
+# make into symlink, looks cleaner than hardlink:
+# we can attach executable attrs to binary and leave no attrs for symlink in
+# %files section.
+ln -sf dropbox library.zip
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_bindir}
@@ -119,17 +124,33 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/library.zip
 
 %{_libdir}/%{name}/cffi-*-py*.egg
-%{_libdir}/%{name}/distribute-*-py*.egg
 %{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
-%{_libdir}/%{name}/mock-*-py*.egg
-%{_libdir}/%{name}/pycparser-*-py*.egg-info
-%{_libdir}/%{name}/requests-*-py*.egg
+%{_libdir}/%{name}/psutil-*-py*.egg
+%{_libdir}/%{name}/setuptools-*-py*.egg
+%{_libdir}/%{name}/tornado-*-py*.egg
+
+# need +x bits for .so files
+%defattr(-,root,root,-)
+%{_libdir}/%{name}/cryptography-*-py*-linux-*.egg
 
-%exclude %{_libdir}/%{name}/libwx_gtk2*.so.*
+# GUI parts
+%exclude %{_libdir}/%{name}/PyQt5.*.so
+%exclude %{_libdir}/%{name}/libQt5*.so.5
+%exclude %{_libdir}/%{name}/libX11-xcb.so.1
+%exclude %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
 
 %files gui
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/libwx_gtk2*.so.*
+%attr(755,root,root) %{_libdir}/%{name}/wmctrl
+%attr(755,root,root) %{_libdir}/%{name}/PyQt5.*.so
+%attr(755,root,root) %{_libdir}/%{name}/libQt5*.so.5
+%attr(755,root,root) %{_libdir}/%{name}/libX11-xcb.so.1
+%attr(755,root,root) %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
+%dir %{_libdir}/%{name}/plugins
+%dir %{_libdir}/%{name}/plugins/platforms
+%attr(755,root,root) %{_libdir}/%{name}/plugins/platforms/libqxcb.so
+%{_libdir}/%{name}/qt.conf
 %dir %{_libdir}/%{name}/images
 %{_libdir}/%{name}/images/emblems
 %{_libdir}/%{name}/images/hicolor
+%{_libdir}/%{name}/resources
This page took 0.091834 seconds and 4 git commands to generate.