]> git.pld-linux.org Git - packages/dropbox.git/blobdiff - dropbox.spec
34.4.20
[packages/dropbox.git] / dropbox.spec
index b4dfddc343214118d28ee0ff01f75cddd4f7754e..423a6be3a005b3c3de5f2456d9e1908be240bc70 100644 (file)
@@ -9,15 +9,16 @@
 #   http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
 Summary:       Sync and backup files between computers
 Name:          dropbox
-Version:       2.10.3
+# https://www.dropboxforum.com/hc/en-us/community/posts/206682016-New-Versioning-Scheme
+Version:       34.4.20
 Release:       1
 License:       Proprietary
 Group:         Daemons
 Source0:       http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
-# NoSource0-md5:       4ab5cd2ba514e46eee6208af650ceb73
+# NoSource0-md5:       4489bdc214fd553a1128ec441705eedd
 NoSource:      0
 Source1:       http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
-# NoSource1-md5:       2e44b9d1038768929425712cc0f448fd
+# NoSource1-md5:       65dcb4c49a6808f2495912b4cc84a7ce
 NoSource:      1
 URL:           http://www.dropbox.com/
 BuildRequires: rpmbuild(macros) >= 1.566
@@ -32,8 +33,11 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # generate no Provides from private modules
 %define                _noautoprovfiles        %{_libdir}/%{name}
 
+# libicu-42, but pld th already has 54
+%define                icu_libs        libicudata.so.42 libicui18n.so.42 libicuuc.so.42
+
 # provided by package itself, but autodeps disabled
-%define                _noautoreq              libwx_.*.so librsync.so.1 libffi.so.6
+%define                _noautoreq              libwx_.*.so %{icu_libs} libffi.so.6 librsync.so.1
 
 # a zip and executable at the same time
 %define                _noautostrip    .*/library.zip\\|.*/dropbox
@@ -42,7 +46,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _enable_debug_packages  0
 
 # prelinked library, it is missing some cairo symbols
-%define                skip_post_check_so      libwx_gtk2ud_core-2.8.so.0
+#define                skip_post_check_so      libwx_gtk2ud_core-2.8.so.0
 
 %description
 Dropbox is software that syncs your files online and across your
@@ -77,21 +81,30 @@ mv dropbox-lnx.*-%{version}/* .
 #%{__rm} -r distribute-0.6.26-py2.7.egg
 
 # libraries to be taken from system
-# for a in *.so*; do ls -ld /lib/$a /usr/lib/$a; done 2>/dev/null
-%{__rm} libpng12.so.0 libbz2.so.1.0 libpopt.so.0
+# for a in *.so*; do ls -ld /lib64/$a /us?/lib64/$a; done 2>/dev/null
+%{__rm} libpopt.so.0 libdrm.so.2 libGL.so.1
+%{__rm} libffi.so.6
+%{__rm} libX11-xcb.so.1
+%{__rm} libQt5{Core,DBus,Gui,Network,OpenGL,PrintSupport,Qml,Quick,Sql,WebKit,WebKitWidgets,Widgets,XcbQpa}.so.5
+%{__rm} qt.conf
+%{__rm} -r plugins
 
-# make into symlink, looks cleaner than hardlink:
-# we can attach executable attrs to binary and leave no attrs for symlink in
-# %files section.
-ln -sf dropbox library.zip
+# keep librsync, won't finish syncing if not using upstream copy
+test -f librsync.so.1
 
 # fun, let's delete non-linux files from archive
 unzip -l library.zip | \
-       grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac).py|pynt|pymac|ui/cocoa|unittest' | \
-       grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework).py' | \
+       grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac)\.py|pymac|ui/cocoa|unittest' | \
+       grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework)\.py' | \
+       grep -vE 'dropbox/mac/(version|__init__).py' | \
        awk '{print $NF}' > lib.delete
 zip library.zip -d $(cat lib.delete)
 
+# make into symlink, looks cleaner than hardlink:
+# we can attach executable attrs to binary and leave no attrs for symlink in
+# %files section.
+ln -sf dropbox library.zip
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_bindir}
@@ -118,17 +131,21 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/dropboxd
 %{_libdir}/%{name}/library.zip
 
-%{_libdir}/%{name}/cffi-*-py*.egg
-%{_libdir}/%{name}/distribute-*-py*.egg
+# need +x bits for .so files
+%defattr(-,root,root,-)
 %{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
-%{_libdir}/%{name}/mock-*-py*.egg
-%{_libdir}/%{name}/pycparser-*-py*.egg-info
+%{_libdir}/%{name}/setuptools-*-py*.egg
 
-%exclude %{_libdir}/%{name}/libwx_gtk2*.so.*
+# GUI parts
+%exclude %{_libdir}/%{name}/PyQt5.*.so
+%exclude %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
 
 %files gui
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/libwx_gtk2*.so.*
+%attr(755,root,root) %{_libdir}/%{name}/wmctrl
+%attr(755,root,root) %{_libdir}/%{name}/PyQt5.*.so
+%attr(755,root,root) %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
 %dir %{_libdir}/%{name}/images
 %{_libdir}/%{name}/images/emblems
 %{_libdir}/%{name}/images/hicolor
+%{_libdir}/%{name}/resources
This page took 0.104788 seconds and 4 git commands to generate.