]> git.pld-linux.org Git - packages/dropbox.git/blobdiff - dropbox.spec
cleanup more foreign py libraries
[packages/dropbox.git] / dropbox.spec
index cfdbc417f14b48c7fa75f5c338b71e30ac11a7b3..1d60ab30885144bd2a561795c807429f4eeca3f0 100644 (file)
@@ -1,3 +1,6 @@
+# TODO
+# - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
+#   glen     25034 19.9  1.5 1496132 81256 pts/46  Sl+  11:02   1:02 /home/glen/.dropbox-dist/dropbox /newerversion
 # NOTES:
 # - Upstream Dropbox Support (https://www.dropbox.com/ticket)
 # - Release Notes (check new versions here): https://www.dropbox.com/release_notes
 # NOTES:
 # - Upstream Dropbox Support (https://www.dropbox.com/ticket)
 # - Release Notes (check new versions here): https://www.dropbox.com/release_notes
@@ -6,20 +9,21 @@
 #   http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
 Summary:       Sync and backup files between computers
 Name:          dropbox
 #   http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
 Summary:       Sync and backup files between computers
 Name:          dropbox
-Version:       1.6.10
+Version:       2.6.33
 Release:       1
 License:       Proprietary
 Group:         Daemons
 Release:       1
 License:       Proprietary
 Group:         Daemons
-URL:           http://www.dropbox.com/
 Source0:       http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
 Source0:       http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
-# NoSource0-md5:       0fd9f23adfeece9f48a02ccabdfae92e
+# NoSource0-md5:       4155a85791150a40f97cff68ca2e0668
 NoSource:      0
 Source1:       http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
 NoSource:      0
 Source1:       http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
-# NoSource1-md5:       888435a5431d546576c2c4d659eb566c
+# NoSource1-md5:       72e52d33ab69f15be40247dd42c33d92
 NoSource:      1
 NoSource:      1
+URL:           http://www.dropbox.com/
 BuildRequires: rpmbuild(macros) >= 1.566
 BuildRequires: sed >= 4.0
 BuildRequires: tar >= 1:1.15.1
 BuildRequires: rpmbuild(macros) >= 1.566
 BuildRequires: sed >= 4.0
 BuildRequires: tar >= 1:1.15.1
+BuildRequires: zip
 Conflicts:     nautilus-dropbox < 0.6.3-2
 ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Conflicts:     nautilus-dropbox < 0.6.3-2
 ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -28,7 +32,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoprovfiles        %{_libdir}/%{name}
 
 # provided by package itself, but autodeps disabled
 %define                _noautoprovfiles        %{_libdir}/%{name}
 
 # provided by package itself, but autodeps disabled
-%define                _noautoreq              libcrypto.so libssl.so libwx_.*.so librsync.so.1 libpng12.so
+%define                _noautoreq              libwx_.*.so librsync.so.1 libffi.so.6
 
 # a zip and executable at the same time
 %define                _noautostrip    .*/library.zip\\|.*/dropbox
 
 # a zip and executable at the same time
 %define                _noautostrip    .*/library.zip\\|.*/dropbox
@@ -49,6 +53,14 @@ installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
 your files are stored on Dropbox's secure servers, you can also access
 them from any computer or mobile device using the Dropbox website.
 
 your files are stored on Dropbox's secure servers, you can also access
 them from any computer or mobile device using the Dropbox website.
 
+%package gui
+Summary:       Gtk+2 GUI of Dropbox
+Group:         X11/Applications
+Requires:      %{name} = %{version}-%{release}
+
+%description gui
+Gtk+2 Systray of Dropbox Daemon status.
+
 %prep
 %setup -qcT
 %ifarch %{ix86}
 %prep
 %setup -qcT
 %ifarch %{ix86}
@@ -59,7 +71,8 @@ them from any computer or mobile device using the Dropbox website.
 %endif
 
 # no need to package this
 %endif
 
 # no need to package this
-%{__rm} -r distribute-0.6.26-py2.7.egg
+# altho system python is also 2.7, don't know how to enforce using it system libs
+#%{__rm} -r distribute-0.6.26-py2.7.egg
 
 # libraries to be taken from system
 # for a in *.so*; do ls -ld /lib/$a /usr/lib/$a; done 2>/dev/null
 
 # libraries to be taken from system
 # for a in *.so*; do ls -ld /lib/$a /usr/lib/$a; done 2>/dev/null
@@ -71,8 +84,10 @@ them from any computer or mobile device using the Dropbox website.
 ln -sf dropbox library.zip
 
 # fun, let's delete non-linux files from archive
 ln -sf dropbox library.zip
 
 # fun, let's delete non-linux files from archive
-unzip -l library.zip | grep -E 'arch/(mac|win32)|pynt|ui/cocoa|unittest' | awk '{print $NF}' > lib.delete
-# TODO: also pymac could be cleaned if pymac.constants is not imported
+unzip -l library.zip | \
+       grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac).py|pynt|pymac|ui/cocoa|unittest' | \
+       grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework).py' | \
+       awk '{print $NF}' > lib.delete
 zip library.zip -d $(cat lib.delete)
 
 %install
 zip library.zip -d $(cat lib.delete)
 
 %install
@@ -101,6 +116,17 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/dropboxd
 %{_libdir}/%{name}/library.zip
 
 %attr(755,root,root) %{_libdir}/%{name}/dropboxd
 %{_libdir}/%{name}/library.zip
 
+%{_libdir}/%{name}/cffi-*-py*.egg
+%{_libdir}/%{name}/distribute-*-py*.egg
+%{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
+%{_libdir}/%{name}/mock-*-py*.egg
+%{_libdir}/%{name}/pycparser-*-py*.egg-info
+
+%exclude %{_libdir}/%{name}/libwx_gtk2*.so.*
+
+%files gui
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/libwx_gtk2*.so.*
 %dir %{_libdir}/%{name}/images
 %{_libdir}/%{name}/images/emblems
 %{_libdir}/%{name}/images/hicolor
 %dir %{_libdir}/%{name}/images
 %{_libdir}/%{name}/images/emblems
 %{_libdir}/%{name}/images/hicolor
This page took 0.118999 seconds and 4 git commands to generate.