]> git.pld-linux.org Git - packages/dropbox.git/blob - dropbox.spec
b758d8967ae1c7e2f4eb6b3824c6ca6dfa777011
[packages/dropbox.git] / dropbox.spec
1 # TODO
2 # - avoid dropboxd relaunching itself with newer version if there's update available (disable auto updating):
3 #   glen     25034 19.9  1.5 1496132 81256 pts/46  Sl+  11:02   1:02 /home/glen/.dropbox-dist/dropbox /newerversion
4 # NOTES:
5 # - Upstream Dropbox Support (https://www.dropbox.com/ticket)
6 # - Release Notes (check new versions here): https://www.dropbox.com/release_notes
7 # - Download instructions (click the download link to find current version):
8 #   http://www.dropbox.com/downloading?os=lnx
9 #   http://wiki.dropbox.com/TipsAndTricks/TextBasedLinuxInstall
10 Summary:        Sync and backup files between computers
11 Name:           dropbox
12 Version:        3.0.3
13 Release:        0.3
14 License:        Proprietary
15 Group:          Daemons
16 Source0:        http://dl-web.dropbox.com/u/17/%{name}-lnx.x86-%{version}.tar.gz
17 # NoSource0-md5:        b8ae37ef387496ebae10d8ad6c0664e1
18 NoSource:       0
19 Source1:        http://dl-web.dropbox.com/u/17/%{name}-lnx.x86_64-%{version}.tar.gz
20 # NoSource1-md5:        72c2a2a20b3916a2aeede0f0ab93dd08
21 NoSource:       1
22 URL:            http://www.dropbox.com/
23 BuildRequires:  rpmbuild(macros) >= 1.566
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  tar >= 1:1.15.1
26 BuildRequires:  unzip
27 BuildRequires:  zip
28 Conflicts:      nautilus-dropbox < 0.6.3-2
29 ExclusiveArch:  %{ix86} %{x8664}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 # generate no Provides from private modules
33 %define         _noautoprovfiles        %{_libdir}/%{name}
34
35 # libicu-42, but pld th already has 54
36 %define         icu_libs        libicudata.so.42 libicui18n.so.42 libicuuc.so.42
37
38 # provided by package itself, but autodeps disabled
39 %define         _noautoreq              libwx_.*.so librsync.so.1 libffi.so.6 %{icu_libs}
40
41 # a zip and executable at the same time
42 %define         _noautostrip    .*/library.zip\\|.*/dropbox
43
44 # debuginfo wouldn't be useful
45 %define         _enable_debug_packages  0
46
47 # prelinked library, it is missing some cairo symbols
48 #define         skip_post_check_so      libwx_gtk2ud_core-2.8.so.0
49
50 %description
51 Dropbox is software that syncs your files online and across your
52 computers.
53
54 Put your files into your Dropbox on one computer, and they'll be
55 instantly available on any of your other computers that you've
56 installed Dropbox on (Windows, Mac, and Linux too!) Because a copy of
57 your files are stored on Dropbox's secure servers, you can also access
58 them from any computer or mobile device using the Dropbox website.
59
60 %package gui
61 Summary:        Gtk+2 GUI of Dropbox
62 Group:          X11/Applications
63 Requires:       %{name} = %{version}-%{release}
64
65 %description gui
66 Gtk+2 Systray of Dropbox Daemon status.
67
68 %prep
69 %setup -qcT
70 %ifarch %{ix86}
71 %{__tar} --strip-components=1 -xzf %{SOURCE0}
72 %endif
73 %ifarch %{x8664}
74 %{__tar} --strip-components=1 -xzf %{SOURCE1}
75 %endif
76 mv dropbox-lnx.*-%{version}/* .
77
78 # no need to package this
79 # altho system python is also 2.7, don't know how to enforce using it system libs
80 #%{__rm} -r distribute-0.6.26-py2.7.egg
81
82 # libraries to be taken from system
83 # for a in *.so*; do ls -ld /lib/$a /usr/lib/$a; done 2>/dev/null
84 %{__rm} libpopt.so.0
85
86 # make into symlink, looks cleaner than hardlink:
87 # we can attach executable attrs to binary and leave no attrs for symlink in
88 # %files section.
89 ln -sf dropbox library.zip
90
91 # fun, let's delete non-linux files from archive
92 unzip -l library.zip | \
93         grep -E '(arch|dropbox)/(mac|win32)|_(win32|mac).py|pymac|ui/cocoa|unittest' | \
94         grep -vE 'pymac/(__init__|constants|types|lazydll|lazyframework).py' | \
95         awk '{print $NF}' > lib.delete
96 zip library.zip -d $(cat lib.delete)
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT%{_bindir}
101 ln -s %{_libdir}/%{name}/dropboxd $RPM_BUILD_ROOT%{_bindir}/dropboxd
102
103 # install everything else
104 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}
105 cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib.delete
107
108 # in doc
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/{ACKNOWLEDGEMENTS,VERSION,README}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %files
115 %defattr(644,root,root,755)
116 %doc ACKNOWLEDGEMENTS VERSION README
117 %attr(755,root,root) %{_bindir}/dropboxd
118 %dir %{_libdir}/%{name}
119 %attr(755,root,root) %{_libdir}/%{name}/*.so*
120 %attr(755,root,root) %{_libdir}/%{name}/dropbox
121 %attr(755,root,root) %{_libdir}/%{name}/dropboxd
122 %{_libdir}/%{name}/library.zip
123
124 %{_libdir}/%{name}/cffi-*-py*.egg
125 %{_libdir}/%{name}/distribute-*-py*.egg
126 %{_libdir}/%{name}/dropbox_sqlite_ext-*-py*.egg
127 %{_libdir}/%{name}/mock-*-py*.egg
128 %{_libdir}/%{name}/pycparser-*-py*.egg-info
129 %{_libdir}/%{name}/requests-*-py*.egg
130
131 # GUI parts
132 %exclude %{_libdir}/%{name}/PyQt5.*.so
133 %exclude %{_libdir}/%{name}/libQt5*.so.5
134 %exclude %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
135
136 %files gui
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/%{name}/PyQt5.*.so
139 %attr(755,root,root) %{_libdir}/%{name}/libQt5*.so.5
140 %attr(755,root,root) %{_libdir}/%{name}/dbus.mainloop.pyqt5.so
141 %dir %{_libdir}/%{name}/plugins
142 %dir %{_libdir}/%{name}/plugins/platforms
143 %attr(755,root,root) %{_libdir}/%{name}/plugins/platforms/libqxcb.so
144 %{_libdir}/%{name}/qt.conf
145 %dir %{_libdir}/%{name}/images
146 %{_libdir}/%{name}/images/emblems
147 %{_libdir}/%{name}/images/hicolor
This page took 0.031185 seconds and 2 git commands to generate.