]> git.pld-linux.org Git - packages/dpx.git/commitdiff
- new auto/th/dpx-0_5-0_svn4_1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 20 Nov 2011 09:42:40 +0000 (09:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dpx-shared.patch -> 1.1
    dpx.spec -> 1.1

dpx-shared.patch [new file with mode: 0644]
dpx.spec [new file with mode: 0644]

diff --git a/dpx-shared.patch b/dpx-shared.patch
new file mode 100644 (file)
index 0000000..83ca077
--- /dev/null
@@ -0,0 +1,30 @@
+--- dpx/libdpx/Makefile.am.orig        2011-11-20 09:55:33.000000000 +0100
++++ dpx/libdpx/Makefile.am     2011-11-20 10:30:43.337652371 +0100
+@@ -1,7 +1,7 @@
+-lib_LIBRARIES = libdpx.a
++lib_LTLIBRARIES = libdpx.la
+-libdpx_a_SOURCES = Codec.cpp \
++libdpx_la_SOURCES = Codec.cpp \
+                    DPX.cpp \
+                    DPXHeader.cpp \
+                    ElementReadStream.cpp \
+--- dpx/tools/dpxheader/Makefile.am.orig       2011-11-20 09:55:33.000000000 +0100
++++ dpx/tools/dpxheader/Makefile.am    2011-11-20 10:36:28.250997251 +0100
+@@ -1,5 +1,5 @@
+-LIBDPX = $(top_builddir)/libdpx/libdpx.a
++LIBDPX = $(top_builddir)/libdpx/libdpx.la
+ INCLUDES = -I$(top_builddir)/libdpx
+--- dpx/tools/dpx2tiff/Makefile.am.orig        2011-11-20 09:55:33.000000000 +0100
++++ dpx/tools/dpx2tiff/Makefile.am     2011-11-20 10:36:37.380997558 +0100
+@@ -1,5 +1,5 @@
+-LIBDPX = $(top_builddir)/libdpx/libdpx.a
++LIBDPX = $(top_builddir)/libdpx/libdpx.la
+ INCLUDES = -I$(top_builddir)/libdpx
diff --git a/dpx.spec b/dpx.spec
new file mode 100644 (file)
index 0000000..812b7ab
--- /dev/null
+++ b/dpx.spec
@@ -0,0 +1,113 @@
+Summary:       SMPTE DPX v2 Image Format reader/writer library
+Summary(pl.UTF-8):     Biblioteka do odczytu/zapisu obrazów w formacie SMPTE DPX v2
+Name:          dpx
+Version:       0.5
+%define        subver  svn4
+Release:       0.%{subver}.1
+License:       BSD
+Group:         Libraries
+# svn checkout http://dpx.googlecode.com/svn/trunk/ dpx
+Source0:       %{name}-%{subver}.tar.xz
+# Source0-md5: a6bf177cb29eaaefb5208f3dcf486658
+Patch0:                %{name}-shared.patch
+URL:           http://code.google.com/p/dpx/
+BuildRequires: autoconf >= 2.61
+BuildRequires: automake
+BuildRequires: libstdc++-devel
+BuildRequires: libtiff-devel
+BuildRequires: libtool >= 2:1.5
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+SMPTE DPX v2 Image Format reader/writer library written in portable
+C++.
+
+%description -l pl.UTF-8
+Biblioteka do odczytu/zapisu obrazów w formacie SMPTE DPX v2, napisana
+w przenośnym C++.
+
+%package devel
+Summary:       Header files for DPX library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki DPX
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      libstdc++-devel
+
+%description devel
+Header files for DPX library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki DPX.
+
+%package static
+Summary:       Static DPX library
+Summary(pl.UTF-8):     Statyczna biblioteka DPX
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static DPX library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka DPX.
+
+%package apidocs
+Summary:       DPX API documentation
+Summary(pl.UTF-8):     Dokumentacja API biblioteki DPX
+Group:         Documentation
+
+%description apidocs
+API and internal documentation for DPX library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki DPX.
+
+%prep
+%setup -q -n %{name}
+%patch0 -p1
+
+%build
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__automake}
+%configure \
+       --enable-shared
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS COPYING NEWS README
+%attr(755,root,root) %{_bindir}/dpx2tiff
+%attr(755,root,root) %{_bindir}/dpxheader
+%attr(755,root,root) %{_libdir}/libdpx.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdpx.so.0
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libdpx.so
+%{_libdir}/libdpx.la
+%{_includedir}/DPX*.h
+
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libdpx.a
+
+%files apidocs
+%defattr(644,root,root,755)
+%doc doc/html/*.{css,html,png}
This page took 0.151065 seconds and 4 git commands to generate.