]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
cd43f16a15cd4e899267cbebae7a8a3e5170ae0d
[packages/dpkg.git] / dpkg.spec
1 Summary:        Package maintenance system for Debian Linux
2 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
3 Name:           dpkg
4 Version:        1.15.8.10
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications/File
8 Source0:        ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.bz2
9 # Source0-md5:  bce745c7083ace01da1df6cdcad35f9a
10 URL:            http://packages.debian.org/search?keywords=dpkg
11 BuildRequires:  bzip2-devel
12 BuildRequires:  gettext-devel >= 0.18
13 BuildRequires:  libselinux-devel
14 BuildRequires:  perl-tools-pod
15 BuildRequires:  zlib-devel
16 Requires:       perl-base
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This package contains the programs to handle deb packages known from
21 Debian.
22
23 %description -l pl.UTF-8
24 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
25 Debiana.
26
27 %package -n libdpkg-devel
28 Summary:        dpkg library and header files
29 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
30 Group:          Development/Libraries
31
32 %description -n libdpkg-devel
33 dpkg library and header files.
34
35 %description -n libdpkg-devel -l pl.UTF-8
36 Biblioteka i pliki nagłówkowe dpkg.
37
38 %prep
39 %setup -q
40
41 %build
42 %configure \
43         --disable-silent-rules \
44         --enable-shared \
45         --without-dselect \
46         --without-install-info \
47         --without-start-stop-daemon \
48         --with-zlib \
49         --with-bz2 \
50         --with-selinux \
51         --with-admindir=/var/lib/%{name}
52
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
62
63 # dpkg for main part, dpkg-dev for perl-based build script
64 # don't use --all-name to avoid e.g. dselect inclusion
65 %find_lang dpkg
66 %find_lang dpkg-dev
67 cat dpkg-dev.lang >>dpkg.lang
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files -f dpkg.lang
73 %defattr(644,root,root,755)
74 %doc AUTHORS ChangeLog README THANKS TODO
75 %attr(755,root,root) %{_bindir}/dpkg*
76 %attr(755,root,root) %{_bindir}/update-alternatives
77 %dir %{_sysconfdir}/alternatives
78 %dir %{_sysconfdir}/dpkg
79 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
80
81 %dir %{_libdir}/dpkg
82 %dir %{_libdir}/dpkg/parsechangelog
83 %attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
84 %dir %{_datadir}/dpkg
85 %{_datadir}/dpkg/cputable
86 %{_datadir}/dpkg/ostable
87 %{_datadir}/dpkg/triplettable
88
89 %{perl_vendorlib}/Dpkg.pm
90 %{perl_vendorlib}/Dpkg
91
92 %dir /var/lib/dpkg
93 %dir /var/lib/dpkg/alternatives
94 %dir /var/lib/dpkg/info
95 %dir /var/lib/dpkg/parts
96 %dir /var/lib/dpkg/updates
97
98 %{_mandir}/man1/dpkg*.1*
99 %{_mandir}/man3/Dpkg::*.3*
100 %{_mandir}/man5/deb*.5*
101 %{_mandir}/man5/dpkg.cfg.5*
102 %{_mandir}/man8/dpkg-*.8*
103 %{_mandir}/man8/update-alternatives.8*
104 %lang(de) %{_mandir}/de/man1/dpkg*.1*
105 %lang(de) %{_mandir}/de/man5/deb*.5*
106 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
107 %lang(de) %{_mandir}/de/man8/dpkg-*.8*
108 %lang(de) %{_mandir}/de/man8/update-alternatives.8*
109 %lang(es) %{_mandir}/es/man1/dpkg*.1*
110 %lang(es) %{_mandir}/es/man5/deb*.5*
111 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
112 %lang(es) %{_mandir}/es/man8/dpkg-*.8*
113 %lang(es) %{_mandir}/es/man8/update-alternatives.8*
114 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
115 %lang(fr) %{_mandir}/fr/man5/deb*.5*
116 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
117 %lang(fr) %{_mandir}/fr/man8/dpkg-*.8*
118 %lang(fr) %{_mandir}/fr/man8/update-alternatives.8*
119 %lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
120 %lang(ja) %{_mandir}/ja/man5/deb-old.5*
121 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
122 %lang(pl) %{_mandir}/pl/man5/deb*.5*
123 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
124 %lang(pl) %{_mandir}/pl/man8/dpkg-*.8*
125 %lang(pl) %{_mandir}/pl/man8/update-alternatives.8*
126 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
127 %lang(sv) %{_mandir}/sv/man5/deb*.5*
128 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
129 %lang(sv) %{_mandir}/sv/man8/dpkg-*.8*
130 %lang(sv) %{_mandir}/sv/man8/update-alternatives.8*
131
132 %files -n libdpkg-devel
133 %defattr(644,root,root,755)
134 %{_libdir}/libdpkg.a
135 %{_includedir}/dpkg
136 %{_pkgconfigdir}/libdpkg.pc
This page took 0.134324 seconds and 2 git commands to generate.