]> git.pld-linux.org Git - packages/dpkg.git/blob - dpkg.spec
2ac27fd658d36c0f6fd3d97bcbe063ff1dc409ef
[packages/dpkg.git] / dpkg.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Package maintenance system for Debian Linux
3 Summary(pl.UTF-8):      Program do obsługi pakietów Debiana
4 Name:           dpkg
5 Version:        1.17.25
6 Release:        1
7 License:        GPL v2+
8 Group:          Applications/File
9 Source0:        ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
10 # Source0-md5:  e48fcfdb2162e77d72c2a83432d537ca
11 Patch0:         %{name}-md5.patch
12 URL:            http://packages.debian.org/search?keywords=dpkg
13 BuildRequires:  bzip2-devel
14 BuildRequires:  gettext-tools >= 0.18.2
15 BuildRequires:  libselinux-devel
16 BuildRequires:  perl-tools-pod
17 BuildRequires:  pkgconfig
18 BuildRequires:  rpmbuild(macros) >= 1.654
19 BuildRequires:  rpm-perlprov
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRequires:  xz-devel
23 BuildRequires:  zlib-devel
24 Requires:       perl-base
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # blacklist false positives
28 %define         _noautoreq_perl         extra file in Tie::ExtraHash
29
30 %description
31 This package contains the programs to handle deb packages known from
32 Debian.
33
34 %description -l pl.UTF-8
35 Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
36 Debiana.
37
38 %package -n libdpkg-devel
39 Summary:        dpkg library and header files
40 Summary(pl.UTF-8):      Biblioteka i pliki nagłówkowe dpkg
41 Group:          Development/Libraries
42 Requires:       bzip2-devel
43 Requires:       xz-devel
44 Requires:       zlib-devel
45
46 %description -n libdpkg-devel
47 dpkg library and header files.
48
49 %description -n libdpkg-devel -l pl.UTF-8
50 Biblioteka i pliki nagłówkowe dpkg.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 %build
57 %configure \
58         PO4A="true" \
59         --disable-dselect \
60         --disable-silent-rules \
61         --disable-start-stop-daemon \
62         --with-admindir=/var/lib/%{name}
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
73
74 # obsoleted by pkg-config
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
76
77 # dpkg for main part, dpkg-dev for perl-based build script
78 # don't use --all-name to avoid e.g. dselect inclusion
79 %find_lang dpkg
80 %find_lang dpkg-dev
81 cat dpkg-dev.lang >>dpkg.lang
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files -f dpkg.lang
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog README THANKS TODO
89 %attr(755,root,root) %{_bindir}/dpkg*
90 %attr(755,root,root) %{_bindir}/update-alternatives
91 %dir %{_sysconfdir}/alternatives
92 %dir %{_sysconfdir}/dpkg
93 %dir %{_sysconfdir}/dpkg/dpkg.cfg.d
94
95 %dir %{_libdir}/dpkg
96 %dir %{_libdir}/dpkg/parsechangelog
97 %attr(755,root,root) %{_libdir}/dpkg/parsechangelog/debian
98 %dir %{_datadir}/dpkg
99 %{_datadir}/dpkg/abitable
100 %{_datadir}/dpkg/cputable
101 %{_datadir}/dpkg/ostable
102 %{_datadir}/dpkg/triplettable
103 %{_datadir}/dpkg/*.mk
104
105 %{perl_vendorlib}/Dpkg.pm
106 %{perl_vendorlib}/Dpkg
107
108 %dir /var/lib/dpkg
109 %dir /var/lib/dpkg/alternatives
110 %dir /var/lib/dpkg/info
111 %dir /var/lib/dpkg/parts
112 %dir /var/lib/dpkg/updates
113
114 %{_mandir}/man1/dpkg*.1*
115 %{_mandir}/man3/Dpkg.3*
116 %{_mandir}/man3/Dpkg::*.3*
117 %{_mandir}/man5/deb*.5*
118 %{_mandir}/man5/dpkg.cfg.5*
119 %{_mandir}/man8/dpkg-*.8*
120 %{_mandir}/man8/update-alternatives.8*
121 %lang(de) %{_mandir}/de/man1/dpkg*.1*
122 %lang(de) %{_mandir}/de/man5/deb*.5*
123 %lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
124 %lang(de) %{_mandir}/de/man8/dpkg-*.8*
125 %lang(de) %{_mandir}/de/man8/update-alternatives.8*
126 %lang(es) %{_mandir}/es/man1/dpkg*.1*
127 %lang(es) %{_mandir}/es/man5/deb*.5*
128 %lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
129 %lang(es) %{_mandir}/es/man8/dpkg-*.8*
130 %lang(es) %{_mandir}/es/man8/update-alternatives.8*
131 %lang(fr) %{_mandir}/fr/man1/dpkg*.1*
132 %lang(fr) %{_mandir}/fr/man5/deb*.5*
133 %lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
134 %lang(fr) %{_mandir}/fr/man8/dpkg-*.8*
135 %lang(fr) %{_mandir}/fr/man8/update-alternatives.8*
136 %lang(hu) %{_mandir}/hu/man5/dpkg.cfg.5*
137 %lang(it) %{_mandir}/it/man1/dpkg*.1*
138 %lang(it) %{_mandir}/it/man5/deb*.5*
139 %lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
140 %lang(it) %{_mandir}/it/man8/dpkg-*.8*
141 %lang(it) %{_mandir}/it/man8/update-alternatives.8*
142 %lang(ja) %{_mandir}/ja/man1/dpkg*.1*
143 %lang(ja) %{_mandir}/ja/man5/deb*.5*
144 %lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
145 %lang(ja) %{_mandir}/ja/man8/dpkg*.8*
146 %lang(ja) %{_mandir}/ja/man8/update-alternatives.8*
147 %lang(pl) %{_mandir}/pl/man1/dpkg*.1*
148 %lang(pl) %{_mandir}/pl/man5/deb*.5*
149 %lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
150 %lang(pl) %{_mandir}/pl/man8/dpkg-*.8*
151 %lang(pl) %{_mandir}/pl/man8/update-alternatives.8*
152 %lang(sv) %{_mandir}/sv/man1/dpkg*.1*
153 %lang(sv) %{_mandir}/sv/man5/deb*.5*
154 %lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
155 %lang(sv) %{_mandir}/sv/man8/dpkg-*.8*
156 %lang(sv) %{_mandir}/sv/man8/update-alternatives.8*
157
158 %files -n libdpkg-devel
159 %defattr(644,root,root,755)
160 %{_libdir}/libdpkg.a
161 %{_includedir}/dpkg
162 %{_pkgconfigdir}/libdpkg.pc
This page took 0.072611 seconds and 2 git commands to generate.