]> git.pld-linux.org Git - packages/dpkg.git/blame_incremental - dpkg.spec
- updated to 1.22.6
[packages/dpkg.git] / dpkg.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with alternatives # build alternatives package
4
5%include /usr/lib/rpm/macros.perl
6Summary: Package maintenance system for Debian Linux
7Summary(pl.UTF-8): Program do obsługi pakietów Debiana
8Name: dpkg
9Version: 1.18.10
10Release: 1
11License: GPL v2+
12Group: Applications/File
13Source0: ftp://ftp.debian.org/debian/pool/main/d/dpkg/%{name}_%{version}.tar.xz
14# Source0-md5: ccff17730c0964428fc186ded2f2f401
15Patch0: %{name}-md5.patch
16URL: http://packages.debian.org/search?keywords=dpkg
17BuildRequires: bzip2-devel
18BuildRequires: gettext-tools >= 0.19
19BuildRequires: libselinux-devel
20BuildRequires: perl-tools-pod
21BuildRequires: pkgconfig
22BuildRequires: rpm-perlprov
23BuildRequires: rpmbuild(macros) >= 1.654
24BuildRequires: tar >= 1:1.22
25BuildRequires: xz
26BuildRequires: xz-devel
27BuildRequires: zlib-devel
28Requires: perl-base
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31# blacklist false positives
32%define _noautoreq_perl extra file in Tie::ExtraHash
33
34%description
35This package contains the programs to handle deb packages known from
36Debian.
37
38%description -l pl.UTF-8
39Ten pakiet zawiera narzędzia do obsługi pakietów deb znanych z
40Debiana.
41
42%package -n libdpkg-devel
43Summary: dpkg library and header files
44Summary(pl.UTF-8): Biblioteka i pliki nagłówkowe dpkg
45Group: Development/Libraries
46Requires: bzip2-devel
47Requires: xz-devel
48Requires: zlib-devel
49
50%description -n libdpkg-devel
51dpkg library and header files.
52
53%description -n libdpkg-devel -l pl.UTF-8
54Biblioteka i pliki nagłówkowe dpkg.
55
56%package alternatives
57Summary: Maintain symbolic links determining default commands
58Summary(pl.UTF-8): Utrzymywanie dowiązań symbolicznych określających domyślne polecenia
59Group: Applications/System
60Requires: %{name} = %{version}-%{release}
61
62%description alternatives
63alternatives creates, removes, maintains and displays information
64about the symbolic links comprising the alternatives system. The
65alternatives system is a reimplementation of the Debian alternatives
66system.
67
68%description alternatives -l pl.UTF-8
69alternatives tworzy, usuwa, utrzymuje i wyświetla informacje o
70dowiązaniach symbolicznych obejmujących system alternatyw. System
71alternatyw to reimplementacja systemu alternatyw ("alternatives") z
72Debiana.
73
74%prep
75%setup -q
76%patch0 -p1
77
78%build
79# "ac_cv_header_md5_h=no" to disable error on md5.h from libmd5
80# (dpkg expects this header from FreeBSD-compatible libmd, having different API)
81%configure \
82 ac_cv_header_md5_h=no \
83 PO4A="true" \
84 --disable-dselect \
85 %{!?with_alternatives:--disable-update-alternatives} \
86 --disable-silent-rules \
87 --disable-start-stop-daemon \
88 --with-admindir=/var/lib/%{name}
89
90%{__make}
91
92%install
93rm -rf $RPM_BUILD_ROOT
94%{__make} install \
95 DESTDIR=$RPM_BUILD_ROOT
96
97%if %{with alternatives}
98%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/alternatives/README
99%endif
100
101# obsoleted by pkg-config
102%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdpkg.la
103
104# dpkg for main part, dpkg-dev for perl-based build script
105# don't use --all-name to avoid e.g. dselect inclusion
106%find_lang dpkg
107%find_lang dpkg-dev
108cat dpkg-dev.lang >>dpkg.lang
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files -f dpkg.lang
114%defattr(644,root,root,755)
115%doc AUTHORS ChangeLog README THANKS TODO
116%attr(755,root,root) %{_bindir}/dpkg*
117%dir %{_sysconfdir}/dpkg
118%dir %{_sysconfdir}/dpkg/dpkg.cfg.d
119
120%dir %{_datadir}/dpkg
121%{_datadir}/dpkg/abitable
122%{_datadir}/dpkg/cputable
123%{_datadir}/dpkg/ostable
124%{_datadir}/dpkg/triplettable
125%{_datadir}/dpkg/*.mk
126
127%{perl_vendorlib}/Dpkg.pm
128%{perl_vendorlib}/Dpkg
129
130%dir /var/lib/dpkg
131%dir /var/lib/dpkg/info
132%dir /var/lib/dpkg/parts
133%dir /var/lib/dpkg/updates
134
135%{_mandir}/man1/dpkg*.1*
136%{_mandir}/man3/Dpkg.3*
137%{_mandir}/man3/Dpkg::*.3*
138%{_mandir}/man5/deb*.5*
139%{_mandir}/man5/dpkg.cfg.5*
140%{_mandir}/man5/dsc.5*
141%lang(de) %{_mandir}/de/man1/dpkg*.1*
142%lang(de) %{_mandir}/de/man5/deb*.5*
143%lang(de) %{_mandir}/de/man5/dpkg.cfg.5*
144%lang(de) %{_mandir}/de/man5/dsc.5*
145%lang(es) %{_mandir}/es/man1/dpkg*.1*
146%lang(es) %{_mandir}/es/man5/deb*.5*
147%lang(es) %{_mandir}/es/man5/dpkg.cfg.5*
148%lang(fr) %{_mandir}/fr/man1/dpkg*.1*
149%lang(fr) %{_mandir}/fr/man5/deb*.5*
150%lang(fr) %{_mandir}/fr/man5/dpkg.cfg.5*
151%lang(it) %{_mandir}/it/man1/dpkg*.1*
152%lang(it) %{_mandir}/it/man5/deb*.5*
153%lang(it) %{_mandir}/it/man5/dpkg.cfg.5*
154%lang(ja) %{_mandir}/ja/man1/dpkg*.1*
155%lang(ja) %{_mandir}/ja/man5/deb*.5*
156%lang(ja) %{_mandir}/ja/man5/dpkg.cfg.5*
157%lang(nl) %{_mandir}/nl/man1/dpkg*.1*
158%lang(nl) %{_mandir}/nl/man5/deb*.5*
159%lang(nl) %{_mandir}/nl/man5/dpkg.cfg.5*
160%lang(pl) %{_mandir}/pl/man1/dpkg*.1*
161%lang(pl) %{_mandir}/pl/man5/deb*.5*
162%lang(pl) %{_mandir}/pl/man5/dpkg.cfg.5*
163%lang(sv) %{_mandir}/sv/man1/dpkg*.1*
164%lang(sv) %{_mandir}/sv/man5/deb*.5*
165%lang(sv) %{_mandir}/sv/man5/dpkg.cfg.5*
166
167%files -n libdpkg-devel
168%defattr(644,root,root,755)
169%{_libdir}/libdpkg.a
170%{_includedir}/dpkg
171%{_pkgconfigdir}/libdpkg.pc
172
173%if %{with alternatives}
174%files alternatives
175%defattr(644,root,root,755)
176%dir %{_sysconfdir}/alternatives
177%attr(755,root,root) %{_bindir}/update-alternatives
178%{_mandir}/man1/update-alternatives.1*
179%lang(de) %{_mandir}/de/man1/update-alternatives.1*
180%lang(es) %{_mandir}/es/man1/update-alternatives.1*
181%lang(fr) %{_mandir}/fr/man1/update-alternatives.1*
182%lang(it) %{_mandir}/it/man1/update-alternatives.1*
183%lang(ja) %{_mandir}/ja/man1/update-alternatives.1*
184%lang(pl) %{_mandir}/pl/man1/update-alternatives.1*
185%lang(sv) %{_mandir}/sv/man1/update-alternatives.1*
186%dir /var/lib/dpkg/alternatives
187%endif
This page took 0.094297 seconds and 4 git commands to generate.