]> git.pld-linux.org Git - packages/dovecot.git/commitdiff
Update to 2.3.16; OAUTH2 support
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 10 Aug 2021 07:32:25 +0000 (09:32 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 10 Aug 2021 07:32:25 +0000 (09:32 +0200)
dovecot.spec
fts.patch [new file with mode: 0644]

index 6d851b8735a34c86e4a72183d350c1933becd851..1ce2cbc15f0025fdfa52e0199d69726d315e2686 100644 (file)
 Summary:       IMAP and POP3 server written with security primarily in mind
 Summary(pl.UTF-8):     Serwer IMAP i POP3 pisany głównie z myślą o bezpieczeństwie
 Name:          dovecot
-Version:       2.3.15
+Version:       2.3.16
 Release:       1
 Epoch:         1
 License:       MIT (libraries), LGPL v2.1 (the rest)
 Group:         Networking/Daemons
 Source0:       http://dovecot.org/releases/2.3/%{name}-%{version}.tar.gz
-# Source0-md5: 82ad748dcff95c22235261953d3390fa
+# Source0-md5: 946dc6a89db0d11d0061f0d4447263dc
 Source1:       %{name}.pamd
 Source2:       %{name}.init
 Source3:       %{name}.sysconfig
@@ -26,6 +26,7 @@ Source4:      %{name}.tmpfiles
 Patch0:                %{name}-config.patch
 Patch1:                %{name}-rpath.patch
 Patch2:                %{name}-shebang.patch
+Patch3:                fts.patch
 URL:           http://dovecot.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -166,6 +167,7 @@ Pakiet programistyczny do tworzenia wtyczek dla Dovecota.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %{__sed} -i 's,/usr/lib/dovecot,%{_libdir}/dovecot,g' doc/example-config/*.conf doc/example-config/conf.d/*.conf
 
diff --git a/fts.patch b/fts.patch
new file mode 100644 (file)
index 0000000..19e87e8
--- /dev/null
+++ b/fts.patch
@@ -0,0 +1,24 @@
+commit 7784e710149c6834f2dab5453726f387597c52ad
+Author: Timo Sirainen <timo.sirainen@open-xchange.com>
+Date:   Mon Aug 9 13:01:12 2021 +0300
+
+    indexer: Fix crash if client disconnects while it's waiting for command reply
+    
+    This happened for example if IMAP SEARCH triggered long fts indexing and the
+    IMAP client disconnected while waiting for the reply.
+    
+    Broken by f62a25849358e40a08a2c47f5bcaa1613a31d076
+
+diff --git a/src/indexer/indexer-client.c b/src/indexer/indexer-client.c
+index c5aac8a3da..ab4710778a 100644
+--- a/src/indexer/indexer-client.c
++++ b/src/indexer/indexer-client.c
+@@ -139,7 +139,7 @@ void indexer_client_status_callback(int percentage, void *context)
+       struct indexer_client_request *ctx = context;
+       /* we are in deinit already, or the client has disconnected */
+-      if (ctx->client == NULL)
++      if (ctx->client->conn.output == NULL)
+               return;
+       T_BEGIN {
This page took 0.046292 seconds and 4 git commands to generate.