]> git.pld-linux.org Git - packages/dovecot.git/commitdiff
- rel 2; fix tests on 32 bit arch auto/th/dovecot-2.3.11.3-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 7 Dec 2020 13:56:58 +0000 (14:56 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 7 Dec 2020 13:56:58 +0000 (14:56 +0100)
dovecot.spec
tests.patch [new file with mode: 0644]

index 5de61d6308cd03646ce77937536e5cc49508df4b..50af188236a8bdaaa61817ee5bbb815e1251b701 100644 (file)
@@ -13,7 +13,7 @@ Summary:      IMAP and POP3 server written with security primarily in mind
 Summary(pl.UTF-8):     Serwer IMAP i POP3 pisany głównie z myślą o bezpieczeństwie
 Name:          dovecot
 Version:       2.3.11.3
-Release:       1
+Release:       2
 Epoch:         1
 License:       MIT (libraries), LGPL v2.1 (the rest)
 Group:         Networking/Daemons
@@ -26,6 +26,7 @@ Source4:      %{name}.tmpfiles
 Patch0:                %{name}-config.patch
 Patch1:                %{name}-rpath.patch
 Patch2:                %{name}-shebang.patch
+Patch3:                tests.patch
 URL:           http://dovecot.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -164,6 +165,7 @@ Pakiet programistyczny do tworzenia wtyczek dla Dovecota.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %{__sed} -i 's,/usr/lib/dovecot,%{_libdir}/dovecot,g' doc/example-config/*.conf doc/example-config/conf.d/*.conf
 
diff --git a/tests.patch b/tests.patch
new file mode 100644 (file)
index 0000000..9b515e8
--- /dev/null
@@ -0,0 +1,49 @@
+commit a744f282947907c794bd23838775b9124c90b11d
+Author: Aki Tuomi <aki.tuomi@open-xchange.com>
+Date:   Thu Aug 13 19:13:04 2020 +0300
+
+    auth: test-mech - Fix APOP challenge format
+
+diff --git a/src/auth/test-mech.c b/src/auth/test-mech.c
+index cf0537003..0a030a2be 100644
+--- a/src/auth/test-mech.c
++++ b/src/auth/test-mech.c
+@@ -196,8 +196,8 @@ test_mech_construct_apop_challenge(unsigned int connect_uid, unsigned long *len_
+ {
+       string_t *apop_challenge = t_str_new(128);
+-      str_printfa(apop_challenge,"<%lx.%u.%"PRIdTIME_T"", (unsigned long) getpid(),
+-                  connect_uid, process_start_time+10);
++      str_printfa(apop_challenge,"<%lx.%lx.%"PRIxTIME_T".", (unsigned long)getpid(),
++                  (unsigned long)connect_uid, process_start_time+10);
+       str_append_data(apop_challenge, "\0testuser\0responseoflen16-", 26);
+       *len_r = apop_challenge->used;
+       return apop_challenge->data;
+commit 68817df1ef029913e9fab9f4da75ba8150c65eb6
+Author: Aki Tuomi <aki.tuomi@open-xchange.com>
+Date:   Thu Aug 13 19:13:49 2020 +0300
+
+    auth: test-mech - Fix type mismatch
+
+diff --git a/src/auth/test-mech.c b/src/auth/test-mech.c
+index 0a030a2be..0a22ff46d 100644
+--- a/src/auth/test-mech.c
++++ b/src/auth/test-mech.c
+@@ -192,7 +192,7 @@ static void test_mech_handle_challenge(struct auth_request *request,
+ }
+ static inline const unsigned char *
+-test_mech_construct_apop_challenge(unsigned int connect_uid, unsigned long *len_r)
++test_mech_construct_apop_challenge(unsigned int connect_uid, size_t *len_r)
+ {
+       string_t *apop_challenge = t_str_new(128);
+@@ -323,7 +323,7 @@ static void test_mechs(void)
+               struct test_case *test_case = &tests[running_test];
+               const struct mech_module *mech = test_case->mech;
+               struct auth_request *request;
+-              const char *testname = t_strdup_printf("auth mech %s %d/%lu",
++              const char *testname = t_strdup_printf("auth mech %s %d/%zu",
+                                                      mech->mech_name,
+                                                      running_test+1,
+                                                      N_ELEMENTS(tests));
This page took 0.245832 seconds and 4 git commands to generate.