]> git.pld-linux.org Git - packages/dovecot-antispam.git/commitdiff
- rel 6 auto/th/dovecot-antispam-2_0-6
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 9 May 2012 10:07:09 +0000 (10:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- allow building with dovecot 2.1

Changed files:
    dovecot-2.1.patch -> 1.1
    dovecot-antispam.spec -> 1.7

dovecot-2.1.patch [new file with mode: 0644]
dovecot-antispam.spec

diff --git a/dovecot-2.1.patch b/dovecot-2.1.patch
new file mode 100644 (file)
index 0000000..dd52aaf
--- /dev/null
@@ -0,0 +1,34 @@
+--- dovecot-antispam-2.0/antispam-plugin.h~    2011-11-07 10:49:47.000000000 +0100
++++ dovecot-antispam-2.0/antispam-plugin.h     2012-05-09 11:50:32.432166565 +0200
+@@ -285,6 +285,31 @@
+ {
+       return dict_init(uri, DICT_DATA_TYPE_STRING, username, NULL);
+ }
++#elif DOVECOT_IS_EQ(2, 1)
++#define mempool_unref         pool_unref
++#define module_arg            struct module *
++#define ME(err)                       MAIL_ERROR_ ##err,
++
++static inline const char *const *
++get_mail_headers(struct mail *mail, const char *hdr)
++{
++      const char *const *ret;
++      if (mail_get_headers(mail, hdr, &ret))
++              return NULL;
++      return ret;
++}
++
++static inline struct ostream *
++o_stream_create_from_fd(int fd, pool_t pool ATTR_UNUSED)
++{
++      return o_stream_create_fd(fd, 0, TRUE);
++}
++
++static inline struct dict *
++string_dict_init(const char *uri, const char *username)
++{
++      return dict_init(uri, DICT_DATA_TYPE_STRING, username, NULL);
++}
+ #else
+ #error "Building against this dovecot version is not supported"
+ #endif
index 4fe547c070b2d890677e0a4ee7a01258d2f4c5a5..034ca6521d2a95c5d9b0c99f0ba2a67aa5050ba7 100644 (file)
@@ -2,11 +2,12 @@ Summary:      The dovecot antispam plugin
 Summary(pl.UTF-8):     Wtyczka antyspamowa dla dovecota
 Name:          dovecot-antispam
 Version:       2.0
-Release:       5
+Release:       6
 License:       GPL v2
 Group:         Daemons
 Source0:       http://johannes.sipsolutions.net/download/dovecot-antispam/%{name}-%{version}.tar.bz2
 # Source0-md5: 14547898759fbd93f2b98304520decc6
+Patch0:                dovecot-2.1.patch
 URL:           http://johannes.sipsolutions.net/Projects/dovecot-antispam
 BuildRequires: dovecot-devel >= 1:2.0
 %requires_eq_to        dovecot dovecot-devel
@@ -22,6 +23,8 @@ way it was moved).
 
 %prep
 %setup -q
+%patch0 -p1
+cp -a antispam-storage-2.0.c antispam-storage-2.1.c
 
 %build
 %{__make} \
This page took 0.105737 seconds and 4 git commands to generate.