]> git.pld-linux.org Git - packages/dotnet-ndesk-dbus-sharp.git/blob - dotnet-ndesk-dbus-sharp.spec
- EA where mono is supported
[packages/dotnet-ndesk-dbus-sharp.git] / dotnet-ndesk-dbus-sharp.spec
1 #
2 %include        /usr/lib/rpm/macros.mono
3 #
4 %define module  ndesk-dbus
5 Summary:        .NET library for using D-BUS message bus
6 Summary(pl.UTF-8):      Biblioteka .NET do używania magistrali przesyłania komunikatów D-BUS
7 Name:           dotnet-ndesk-dbus-sharp
8 Version:        0.6.0
9 Release:        3
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://www.ndesk.org/archive/dbus-sharp/%{module}-%{version}.tar.gz
13 # Source0-md5:  5157ba105c9ac491f6e900bc78d1791f
14 Patch0:         %{name}-monodir.patch
15 URL:            http://www.ndesk.org/DBusSharp
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  mono-csharp >= 1.1.13
19 BuildRequires:  pkgconfig
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 Obsoletes:      ndesk-dbus
22 # should be, but autoconf rejects
23 #BuildArch:     noarch
24 ExclusiveArch:  %{ix86} %{x8664} arm hppa ia64 ppc s390 s390x sparc
25 ExcludeArch:    i386
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This is a C# implementation of D-Bus. It's often referred to as
30 "Managed D-Bus" to avoid confusion with existing bindings (which wrap
31 libdbus).
32
33 D-Bus is an inter-process communication framework that lets
34 applications interface with the system event bus as well as allowing
35 them to talk to one another in a peer-to-peer configuration.
36
37 %description -l pl.UTF-8
38 To jest implementacja C# magistrali D-Bus. Jest często nazywana
39 "Managed D-Bus" dla odróżnienia od istniejących dowiązań
40 (obudowujących libdbus).
41
42 D-Bus to szkielet komunikacji międzyprocesowej pozwalający aplikacjom
43 porozumiewać się z systemową szyną zdarzeń, a także między sobą w
44 konfiguracji peer-to-peer.
45
46 %package devel
47 Summary:        Development files for ndesk D-BUS .NET library
48 Summary(pl.UTF-8):      Pliki programistyczne biblioteki .NET ndesk D-BUS
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Development files for ndesk D-BUS .NET library.
54
55 %description devel -l pl.UTF-8
56 Pliki programistyczne biblioteki .NET ndesk D-BUS.
57
58 %prep
59 %setup -q -n %{module}-%{version}
60 %patch0 -p1
61
62 %build
63 %{__aclocal}
64 %{__automake}
65 %{__autoconf}
66 %configure
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc AUTHORS COPYING README
81 %{_prefix}/lib/mono/gac/NDesk.DBus
82 # *.mdb to -debug?
83
84 %files devel
85 %defattr(644,root,root,755)
86 %{_prefix}/lib/mono/ndesk-dbus-1.0
87 %{_pkgconfigdir}/ndesk-dbus-1.0.pc
This page took 0.066176 seconds and 3 git commands to generate.