]> git.pld-linux.org Git - packages/dotnet-ipod-sharp.git/commitdiff
- fix registering with GAC
authorPatryk Zawadzki <patrys@room-303.com>
Tue, 26 Aug 2008 13:43:21 +0000 (13:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dotnet-ipod-sharp-gac.patch -> 1.1

dotnet-ipod-sharp-gac.patch [new file with mode: 0644]

diff --git a/dotnet-ipod-sharp-gac.patch b/dotnet-ipod-sharp-gac.patch
new file mode 100644 (file)
index 0000000..6ce3602
--- /dev/null
@@ -0,0 +1,25 @@
+--- ipod-sharp-0.8.0/src/Makefile.am~  2007-10-12 18:13:35.000000000 +0200
++++ ipod-sharp-0.8.0/src/Makefile.am   2008-08-26 15:26:03.972113837 +0200
+@@ -49,8 +49,8 @@
+ $(ASSEMBLY): $(ASSEMBLY_SOURCES) $(ASSEMBLY_RESOURCES)
+       $(MCS) $(MCS_FLAGS) -unsafe -keyfile:$(top_srcdir)/ipod-sharp.snk -target:library -out:$@ $(ASSEMBLY_SOURCES) $(ASSEMBLY_RESOURCES:%=-resource:%) -r:Mono.Posix -pkg:gtk-sharp-2.0 -r:ICSharpCode.SharpZipLib $(NDESK_DBUS_LIBS)
+-#install-data-hook:
+-#     $(GACUTIL) /i $(ASSEMBLY) /package $(PACKAGE) /gacdir $(libdir) /root $(DESTDIR)$(libdir)
++install-data-hook:
++      gacutil /i $(ASSEMBLY) /gacdir $(libdir) /root $(DESTDIR)$(libdir)
+ EXTRA_DIST =                  \
+       $(ASSEMBLY_SOURCES)     \
+--- ipod-sharp-0.8.0/ui/Makefile.am~   2007-10-17 23:27:20.000000000 +0200
++++ ipod-sharp-0.8.0/ui/Makefile.am    2008-08-26 15:34:23.956113840 +0200
+@@ -19,6 +19,9 @@
+ $(ASSEMBLY): $(ASSEMBLY_SOURCES) $(top_builddir)/src/ipod-sharp.dll
+       $(MCS) -unsafe -debug -keyfile:$(top_srcdir)/ipod-sharp.snk -target:library -out:$@ $(ASSEMBLY_SOURCES) -r:$(top_builddir)/src/ipod-sharp.dll -pkg:gtk-sharp-2.0 $(ASSEMBLY_RESOURCES)
++install-data-hook:
++      gacutil /i $(ASSEMBLY) /gacdir $(libdir) /root $(DESTDIR)$(libdir)
++
+ EXTRA_DIST =                  \
+       ipod.gif                \
+       $(ASSEMBLY_SOURCES)
This page took 0.07271 seconds and 4 git commands to generate.