]> git.pld-linux.org Git - packages/dotnet-gtk-sharp.git/commitdiff
- use mint if mono is not found
authorMarcin Krzyżanowski <marcin.krzyzanowski@hakore.com>
Fri, 11 Jun 2004 19:53:08 +0000 (19:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dotnet-gtk-sharp-mint.patch -> 1.1

dotnet-gtk-sharp-mint.patch [new file with mode: 0644]

diff --git a/dotnet-gtk-sharp-mint.patch b/dotnet-gtk-sharp-mint.patch
new file mode 100644 (file)
index 0000000..cd441d2
--- /dev/null
@@ -0,0 +1,53 @@
+diff -Nuard gtk-sharp-0.93.orig/configure.in gtk-sharp-0.93/configure.in
+--- gtk-sharp-0.93.orig/configure.in   2004-05-31 21:23:48.000000000 +0200
++++ gtk-sharp-0.93/configure.in        2004-06-11 21:37:56.027002048 +0200
+@@ -61,28 +61,38 @@
+ MONO_REQUIRED_VERSION=0.91.99
+ PKG_CHECK_MODULES(MONO_DEPENDENCY, mono >= $MONO_REQUIRED_VERSION, has_mono=true, has_mono=false)
++PKG_CHECK_MODULES(MINT_DEPENDENCY, mint >= $MONO_REQUIRED_VERSION, has_mint=true, has_mint=false)
+ if test "x$has_mono" = "xtrue"; then
+-if test `uname -s` = "Darwin"; then
++    if test `uname -s` = "Darwin"; then
+       AC_PATH_PROG(RUNTIME, mint, no)
+       AC_PATH_PROG(CSC, mcs, no)
+       LIB_PREFIX=
+       LIB_SUFFIX=.dylib
+-else
++    else
+       AC_PATH_PROG(RUNTIME, mono, no)
+       AC_PATH_PROG(CSC, mcs, no)
+       LIB_PREFIX=.so
+       LIB_SUFFIX=
+-fi
+-else
+-AC_PATH_PROG(CSC, csc.exe, no)
+-if test x$CSC = "xno"; then
+-      AC_MSG_ERROR([You need to install either mono or .Net])
++    fi
++    
+ else
+-RUNTIME=
+-LIB_PREFIX=
+-LIB_SUFFIX=.dylib
+-fi
++dnl use mint if mono is not found
++    if test "x$has_mint" = "xtrue"; then
++      AC_PATH_PROG(RUNTIME, mint, no)
++      AC_PATH_PROG(CSC, mcs, no)
++      LIB_PREFIX=
++      LIB_SUFFIX=.so
++    else
++      AC_PATH_PROG(CSC, csc.exe, no)
++      if test x$CSC = "xno"; then
++          AC_MSG_ERROR([You need to install either mono or .Net])
++      else
++          RUNTIME=
++          LIB_PREFIX=
++          LIB_SUFFIX=.dylib
++      fi
++    fi
+ fi
+ CS="C#"
This page took 0.13437 seconds and 4 git commands to generate.