]> git.pld-linux.org Git - packages/dotnet-gtk-sharp.git/blob - dotnet-gtk-sharp.spec
- R: mono
[packages/dotnet-gtk-sharp.git] / dotnet-gtk-sharp.spec
1 # TODO: split (at least gtk, gnome, gda, gnomedb)
2 #
3 # Conditional build:
4 %bcond_without  gda     # don't build gda binding
5 %bcond_without  gnome   # don't build GNOME (and dependent) bindings
6 #
7 %define         gtkhtml_soversion       %(/bin/ls %{_libdir}/libgtkhtml-3.6.so.* 2>/dev/null | /usr/bin/head -n 1 | /bin/awk '{ split($1,v,"."); print v[4]; }')
8 %define         gtkhtml_version         %(if [ -e /usr/bin/pkg-config ]; then /usr/bin/pkg-config --modversion libgtkhtml-3.6 2>/dev/null || echo 0; else echo 0; fi)
9 %include        /usr/lib/rpm/macros.perl
10 Summary:        .NET language bindings for GTK+ and GNOME
11 Summary(pl):    Wi±zania GTK+ oraz GNOME dla .NET
12 Name:           dotnet-gtk-sharp
13 Version:        1.0.6
14 Release:        3
15 License:        LGPL
16 Group:          Development/Libraries
17 Source0:        http://www.go-mono.com/archive/%{version}/gtk-sharp-%{version}.tar.gz
18 # Source0-md5:  2651d14fe77174ab20b8af53d150ee11
19 Patch0:         %{name}-gtkhtml31.patch
20 Patch1:         %{name}-destdir.patch
21 Patch2:         %{name}-mint.patch
22 #Patch3:                %{name}-disable-rsvg-sample.patch
23 Patch4:         %{name}-pc-libdir.patch
24 URL:            http://gtk-sharp.sf.net/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  gawk
28 BuildRequires:  libart_lgpl-devel >= 2.2.0
29 %{?with_gda:BuildRequires:      libgda-devel >= 1.0.0}
30 BuildRequires:  libglade2-devel >= 2.0.1
31 BuildRequires:  librsvg-devel >= 2.4.0
32 BuildRequires:  libtool
33 BuildRequires:  libxml2-devel
34 BuildRequires:  mono-csharp >= 1.0.2
35 BuildRequires:  ncurses-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpm-perlprov
38 %if %{with gnome}
39 BuildRequires:  gtkhtml-devel >= 3.6.1
40 BuildRequires:  libgnomecanvas-devel >= 2.4.0
41 %{?with_gda:BuildRequires:      libgnomedb-devel >= 1.0.0}
42 BuildRequires:  libgnomeprintui-devel >= 2.4.0
43 BuildRequires:  libgnomeui-devel >= 2.4.0
44 BuildRequires:  vte-devel >= 0.11.10
45 %endif
46 %{?with_gnome:Requires: gtkhtml = %{gtkhtml_version}}
47 Requires:       mono >= 1.0.2
48 Provides:       dotnet-gtk
49 Provides:       gtk-sharp
50 Obsoletes:      dotnet-gtk
51 Obsoletes:      gtk-sharp
52 ExcludeArch:    alpha
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 This package provides bindings for .NET to GTK+2 and GNOME2 libraries.
57
58 %description -l pl
59 Pakiet ten dostarcza wi±zania dla .NET do bibliotek z GTK+2 oraz
60 GNOME2.
61
62 %package devel
63 Summary:        Development part of GTK#
64 Summary(pl):    Czê¶æ dla programistów GTK#
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Provides:       dotnet-gtk-devel
68 Provides:       gtk-sharp-devel
69 Obsoletes:      dotnet-gtk-devel
70 Obsoletes:      gtk-sharp-devel
71
72 %description devel
73 Tools (C source parser and C# code generator) and documentation for
74 developing applications using GTK#.
75
76 %description devel -l pl
77 Narzêdzia (parser kodu C oraz generator kodu C#) i dokumentacja
78 potrzebne przy tworzeniu aplikacji korzystaj±cych z GTK#.
79
80 %package static
81 Summary:        Static gtk-sharp libraries
82 Summary(pl):    Biblioteki statyczne gtk-sharp
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85 Provides:       dotnet-gtk-static
86 Provides:       gtk-sharp-static
87 Obsoletes:      dotnet-gtk-static
88 Obsoletes:      gtk-sharp-static
89
90 %description static
91 Static gtk-sharp libraries.
92
93 %description static -l pl
94 Biblioteki statyczne gtk-sharp.
95
96 %prep
97 %setup -q -n gtk-sharp-%{version}
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101 #%patch3 -p1
102 %patch4 -p1
103
104 # workaround for variable name
105 echo 'm4_pattern_allow(PKG_PATH)' > acinclude.m4
106
107 %build
108 %{__libtoolize}
109 %{__aclocal}
110 %{__autoheader}
111 %{__automake}
112 %{__autoconf}
113 %configure \
114         GTKHTMLSOVERSION=%{gtkhtml_soversion}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT{%{perl_vendorlib},%{_examplesdir}/%{name}-%{version}}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 cp -a sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc README
135 %attr(755,root,root) %{_bindir}/gconfsharp-schemagen*
136 %attr(755,root,root) %{_libdir}/lib*sharpglue.so
137 %{_libdir}/lib*sharpglue.la
138 %{_libdir}/mono/gac/*
139
140 %files devel
141 %defattr(644,root,root,755)
142 %doc README.generator ChangeLog
143 %attr(755,root,root) %{_bindir}/gapi*
144 %{_datadir}/gapi
145 %{_examplesdir}/%{name}-%{version}
146 %{_pkgconfigdir}/*
147 %{_libdir}/mono/gtk-sharp
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/lib*sharpglue.a
This page took 0.034144 seconds and 4 git commands to generate.