]> git.pld-linux.org Git - packages/dotnet-gtk-sharp.git/blob - dotnet-gtk-sharp.spec
- 1.0.10
[packages/dotnet-gtk-sharp.git] / dotnet-gtk-sharp.spec
1 #
2 # Conditional build:
3 %bcond_without  gda     # don't build gda binding
4 %bcond_without  gnome   # don't build GNOME (and dependent) bindings
5 #
6 %define         gtkhtml_soversion       %(/bin/ls %{_libdir}/libgtkhtml-3.6.so.* 2>/dev/null | /usr/bin/head -n 1 | /bin/awk '{ split($1,v,"."); print v[4]; }')
7 %define         gtkhtml_version         %(if [ -e /usr/bin/pkg-config ]; then /usr/bin/pkg-config --modversion libgtkhtml-3.6 2>/dev/null || echo 0; else echo 0; fi)
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        .NET language bindings for GTK+ and GNOME
10 Summary(pl):    Wi±zania GTK+ oraz GNOME dla .NET
11 Name:           dotnet-gtk-sharp
12 Version:        1.0.10
13 Release:        1
14 License:        LGPL
15 Group:          Libraries
16 Source0:        http://go-mono.com/sources/gtk-sharp/gtk-sharp-%{version}.tar.gz
17 # Source0-md5:  e21fb3c5a39374f86ba70b926311a6d0
18 Patch0:         %{name}-gtkhtml31.patch
19 Patch1:         %{name}-destdir.patch
20 Patch2:         %{name}-mint.patch
21 Patch3:         %{name}-pc-libdir.patch
22 URL:            http://gtk-sharp.sf.net/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  gawk
26 BuildRequires:  libart_lgpl-devel >= 2.2.0
27 %{?with_gda:BuildRequires:      libgda-devel >= 1.0.0}
28 BuildRequires:  libglade2-devel >= 2.0.1
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel
31 BuildRequires:  mono-csharp >= 1.0.2
32 BuildRequires:  ncurses-devel
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpm-perlprov
35 %if %{with gnome}
36 BuildRequires:  gtkhtml-devel >= 3.6.2
37 BuildRequires:  libgnomecanvas-devel >= 2.4.0
38 %{?with_gda:BuildRequires:      libgnomedb-devel >= 1.0.0}
39 BuildRequires:  libgnomeprintui-devel >= 2.4.0
40 BuildRequires:  libgnomeui-devel >= 2.4.0
41 # depends on GNOME (vfs, printui) in PLD
42 BuildRequires:  librsvg-devel >= 2.4.0
43 BuildRequires:  vte-devel >= 0.11.10
44 %endif
45 Requires:       mono >= 1.0.2
46 Provides:       dotnet-gtk
47 Provides:       gtk-sharp
48 Obsoletes:      dotnet-gtk
49 Obsoletes:      gtk-sharp
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 This package provides bindings for .NET to GTK+2 and GNOME2 libraries.
54
55 %description -l pl
56 Pakiet ten dostarcza wi±zania dla .NET do bibliotek z GTK+2 oraz
57 GNOME2.
58
59 %package devel
60 Summary:        Development part of GTK#
61 Summary(pl):    Czê¶æ dla programistów GTK#
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Provides:       dotnet-gtk-devel
65 Provides:       gtk-sharp-devel
66 Obsoletes:      dotnet-gtk-devel
67 Obsoletes:      gtk-sharp-devel
68
69 %description devel
70 Tools (C source parser and C# code generator) and documentation for
71 developing applications using GTK#.
72
73 %description devel -l pl
74 Narzêdzia (parser kodu C oraz generator kodu C#) i dokumentacja
75 potrzebne przy tworzeniu aplikacji korzystaj±cych z GTK#.
76
77 %package static
78 Summary:        Static gtk-sharp libraries
79 Summary(pl):    Biblioteki statyczne gtk-sharp
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82 Provides:       dotnet-gtk-static
83 Provides:       gtk-sharp-static
84 Obsoletes:      dotnet-gtk-static
85 Obsoletes:      gtk-sharp-static
86
87 %description static
88 Static gtk-sharp libraries.
89
90 %description static -l pl
91 Biblioteki statyczne gtk-sharp.
92
93 %package gnome
94 Summary:        .NET language bindings for GNOME libraries
95 Summary(pl):    Wi±zania .NET dla bibliotek GNOME
96 Group:          Libraries
97 Requires:       %{name} = %{version}-%{release}
98 %{?with_gnome:Requires: gtkhtml = %{gtkhtml_version}}
99
100 %description gnome
101 .NET language bindings for GNOME libraries.
102
103 %description gnome -l pl
104 Wi±zania .NET dla bibliotek GNOME.
105
106 %package gnome-devel
107 Summary:        .NET language bindings for GNOME libraries - development files
108 Summary(pl):    Wi±zania .NET dla bibliotek GNOME - pliki programistyczne
109 Group:          Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111 Requires:       %{name}-gnome = %{version}-%{release}
112
113 %description gnome-devel
114 .NET language bindings for GNOME libraries - development files.
115
116 %description gnome-devel -l pl
117 Wi±zania .NET dla bibliotek GNOME - pliki programistyczne.
118
119 %package gnome-static
120 Summary:        .NET language bindings for GNOME libraries - static libraries
121 Summary(pl):    Wi±zania .NET dla bibliotek GNOME - static libraries
122 Group:          Libraries
123 Requires:       %{name}-gnome-devel = %{version}-%{release}
124
125 %description gnome-static
126 .NET language bindings for GNOME libraries - static libraries.
127
128 %description gnome-static -l pl
129 Wi±zania .NET dla bibliotek GNOME - static libraries.
130
131 %package gda
132 Summary:        .NET language bindings for GDA library
133 Summary(pl):    Wi±zania .NET dla biblioteki GDA
134 Group:          Libraries
135 Requires:       %{name} = %{version}-%{release}
136
137 %description gda
138 .NET language bindings for GDA library.
139
140 %description gda -l pl
141 Wi±zania .NET dla biblioteki GDA.
142
143 %package gda-devel
144 Summary:        .NET language bindings for GDA library - development files
145 Summary(pl):    Wi±zania .NET dla biblioteki GDA - pliki programistyczne
146 Group:          Libraries
147 Requires:       %{name}-devel = %{version}-%{release}
148 Requires:       %{name}-gda = %{version}-%{release}
149
150 %description gda-devel
151 .NET language bindings for GDA library - development files.
152
153 %description gda-devel -l pl
154 Wi±zania .NET dla biblioteki GDA - pliki programistyczne.
155
156 %package gnomedb
157 Summary:        .NET language bindings for GNOME-DB library
158 Summary(pl):    Wi±zania .NET dla biblioteki GNOME-DB
159 Group:          Libraries
160 Requires:       %{name}-gda = %{version}-%{release}
161 Requires:       %{name}-gnome = %{version}-%{release}
162
163 %description gnomedb
164 .NET language bindings for GNOME-DB library.
165
166 %description gnomedb -l pl
167 Wi±zania .NET dla biblioteki GNOME-DB.
168
169 %package gnomedb-devel
170 Summary:        .NET language bindings for GNOME-DB library - development files
171 Summary(pl):    Wi±zania .NET dla biblioteki GNOME-DB - pliki programistyczne
172 Group:          Libraries
173 Requires:       %{name}-gda-devel = %{version}-%{release}
174 Requires:       %{name}-gnome-devel = %{version}-%{release}
175 Requires:       %{name}-gnomedb = %{version}-%{release}
176
177 %description gnomedb-devel
178 .NET language bindings for GNOME-DB library - development files.
179
180 %description gnomedb-devel -l pl
181 Wi±zania .NET dla biblioteki GNOME-DB - pliki programistyczne.
182
183 %prep
184 %setup -q -n gtk-sharp-%{version}
185 %patch0 -p1
186 %patch1 -p1
187 %patch2 -p1
188 %patch3 -p1
189
190 # workaround for variable name
191 echo 'm4_pattern_allow(PKG_PATH)' > acinclude.m4
192
193 %build
194 %{__libtoolize}
195 %{__aclocal}
196 %{__autoheader}
197 %{__automake}
198 %{__autoconf}
199 %configure \
200         %{?with_gnome:GTKHTMLSOVERSION=%{gtkhtml_soversion}}
201 %{__make}
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
206
207 %{__make} install \
208         DESTDIR=$RPM_BUILD_ROOT
209
210 cp -a sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
211
212 %clean
213 rm -rf $RPM_BUILD_ROOT
214
215 %post   -p /sbin/ldconfig
216 %postun -p /sbin/ldconfig
217
218 %files
219 %defattr(644,root,root,755)
220 %doc README
221 %attr(755,root,root) %{_libdir}/libgdksharpglue.so
222 %attr(755,root,root) %{_libdir}/libgladesharpglue.so
223 %attr(755,root,root) %{_libdir}/libglibsharpglue.so
224 %attr(755,root,root) %{_libdir}/libgtksharpglue.so
225 %attr(755,root,root) %{_libdir}/libpangosharpglue.so
226 %{_libdir}/libgdksharpglue.la
227 %{_libdir}/libgladesharpglue.la
228 %{_libdir}/libglibsharpglue.la
229 %{_libdir}/libgtksharpglue.la
230 %{_libdir}/libpangosharpglue.la
231 %{_libdir}/mono/gac/art-sharp
232 %{_libdir}/mono/gac/atk-sharp
233 %{_libdir}/mono/gac/gdk-sharp
234 %{_libdir}/mono/gac/glade-sharp
235 %{_libdir}/mono/gac/glib-sharp
236 %{_libdir}/mono/gac/gtk-sharp
237 %{_libdir}/mono/gac/pango-sharp
238
239 %files devel
240 %defattr(644,root,root,755)
241 %doc README.generator ChangeLog
242 %attr(755,root,root) %{_bindir}/gapi*
243 %dir %{_libdir}/mono/gtk-sharp
244 %{_libdir}/mono/gtk-sharp/art-sharp.dll
245 %{_libdir}/mono/gtk-sharp/atk-sharp.dll
246 %{_libdir}/mono/gtk-sharp/gdk-sharp.dll
247 %{_libdir}/mono/gtk-sharp/glade-sharp.dll
248 %{_libdir}/mono/gtk-sharp/glib-sharp.dll
249 %{_libdir}/mono/gtk-sharp/gtk-sharp.dll
250 %{_libdir}/mono/gtk-sharp/pango-sharp.dll
251 %dir %{_datadir}/gapi
252 %{_datadir}/gapi/art-*.xml
253 %{_datadir}/gapi/atk-api.xml
254 %{_datadir}/gapi/gdk-*.xml
255 %{_datadir}/gapi/glade-api.xml
256 %{_datadir}/gapi/gtk-*.xml
257 %{_datadir}/gapi/pango-api.xml
258 %{_pkgconfigdir}/art-sharp.pc
259 %{_pkgconfigdir}/gapi.pc
260 %{_pkgconfigdir}/glade-sharp.pc
261 %{_pkgconfigdir}/gtk-sharp.pc
262 %{_examplesdir}/%{name}-%{version}
263
264 %files static
265 %defattr(644,root,root,755)
266 %{_libdir}/libgdksharpglue.a
267 %{_libdir}/libgladesharpglue.a
268 %{_libdir}/libglibsharpglue.a
269 %{_libdir}/libgtksharpglue.a
270 %{_libdir}/libpangosharpglue.a
271
272 %if %{with gnome}
273 %files gnome
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_bindir}/gconfsharp-schemagen*
276 %attr(755,root,root) %{_libdir}/libgnomesharpglue.so
277 %{_libdir}/libgnomesharpglue.la
278 %{_libdir}/mono/gac/gconf-sharp
279 %{_libdir}/mono/gac/gconf-sharp-peditors
280 %{_libdir}/mono/gac/gnome-sharp
281 %{_libdir}/mono/gac/gtkhtml-sharp
282 %{_libdir}/mono/gac/rsvg-sharp
283 %{_libdir}/mono/gac/vte-sharp
284
285 %files gnome-devel
286 %defattr(644,root,root,755)
287 %{_libdir}/mono/gtk-sharp/gconf-sharp.dll
288 %{_libdir}/mono/gtk-sharp/gconf-sharp-peditors.dll
289 %{_libdir}/mono/gtk-sharp/gnome-sharp.dll
290 %{_libdir}/mono/gtk-sharp/gtkhtml-sharp.dll
291 %{_libdir}/mono/gtk-sharp/rsvg-sharp.dll
292 %{_libdir}/mono/gtk-sharp/vte-sharp.dll
293 %{_datadir}/gapi/gnome-api.xml
294 %{_datadir}/gapi/gtkhtml-api.xml
295 %{_datadir}/gapi/rsvg-api.xml
296 %{_datadir}/gapi/vte-api.xml
297 %{_pkgconfigdir}/gconf-sharp.pc
298 %{_pkgconfigdir}/gnome-sharp.pc
299 %{_pkgconfigdir}/gtkhtml-sharp.pc
300 %{_pkgconfigdir}/rsvg-sharp.pc
301 %{_pkgconfigdir}/vte-sharp.pc
302
303 %files gnome-static
304 %defattr(644,root,root,755)
305 %{_libdir}/libgnomesharpglue.a
306 %endif
307
308 %if %{with gda}
309 %files gda
310 %defattr(644,root,root,755)
311 %{_libdir}/mono/gac/gda-sharp
312
313 %files gda-devel
314 %defattr(644,root,root,755)
315 %{_libdir}/mono/gtk-sharp/gda-sharp.dll
316 %{_datadir}/gapi/gda-api.xml
317 %{_pkgconfigdir}/gda-sharp.pc
318 %endif
319
320 %if %{with gnome} && %{with gda}
321 %files gnomedb
322 %defattr(644,root,root,755)
323 %{_libdir}/mono/gac/gnomedb-sharp
324
325 %files gnomedb-devel
326 %defattr(644,root,root,755)
327 %{_libdir}/mono/gtk-sharp/gnomedb-sharp.dll
328 %{_datadir}/gapi/gnomedb-api.xml
329 %{_pkgconfigdir}/gnomedb-sharp.pc
330 %endif
This page took 0.093958 seconds and 4 git commands to generate.