]> git.pld-linux.org Git - packages/dotnet-gtk-sharp.git/blob - dotnet-gtk-sharp.spec
- fixed head syntax
[packages/dotnet-gtk-sharp.git] / dotnet-gtk-sharp.spec
1 %define         gtkhtml_soversion       %(/bin/ls %{_libdir}/libgtkhtml-3.1.so.* | /usr/bin/head -n 1 | /usr/bin/awk '{ split($1,v,"."); print v[4]; }')
2 %define         gtkhtml_version         %(if [ -e /usr/bin/pkg-config ]; then /usr/bin/pkg-config --modversion libgtkhtml-3.1; else echo 0; fi)
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        .NET language bindings for Gtk+ and GNOME
5 Summary(pl):    Wi±zania Gtk+ oraz GNOME dla .NET
6 Name:           dotnet-gtk-sharp
7 Version:        1.0
8 Release:        6
9 License:        LGPL
10 Group:          Development/Libraries
11 Source0:        http://www.go-mono.com/archive/%{version}/gtk-sharp-%{version}.tar.gz
12 # Source0-md5:  6eab56e11c1e1245ec6af12312969399
13 Patch0:         %{name}-gtkhtml31.patch
14 Patch1:         %{name}-destdir.patch
15 Patch2:         %{name}-mint.patch
16 Patch3:         %{name}-disable-rsvg-sample.patch
17 Patch4:         %{name}-pc-libdir.patch
18 URL:            http://gtk-sharp.sf.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  pkgconfig
22 BuildRequires:  gtkhtml-devel >= 3.1.14
23 BuildRequires:  libart_lgpl-devel >= 2.2.0
24 BuildRequires:  libgda-devel >= 1.0.0
25 BuildRequires:  libglade2-devel >= 2.0.1
26 BuildRequires:  libgnomecanvas-devel >= 2.4.0
27 BuildRequires:  libgnomedb-devel >= 1.0.0
28 BuildRequires:  libgnomeprintui-devel >= 2.4.0
29 BuildRequires:  libgnomeui-devel >= 2.4.0
30 BuildRequires:  librsvg-devel >= 2.4.0
31 BuildRequires:  libtool
32 BuildRequires:  libxml2-devel
33 BuildRequires:  mono-csharp
34 BuildRequires:  mono-devel >= 1.0-3
35 BuildRequires:  ncurses-devel
36 BuildRequires:  rpm-perlprov
37 BuildRequires:  vte-devel >= 0.11.10
38 BuildRequires:  gawk
39 Requires:       gtkhtml = %{gtkhtml_version}
40 Provides:       dotnet-gtk
41 Provides:       gtk-sharp
42 Obsoletes:      dotnet-gtk
43 Obsoletes:      gtk-sharp
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46
47
48 %description
49 This package provides bindings for .NET to Gtk+2 and GNOME2 libraries.
50
51 %description -l pl
52 Pakiet ten dostarcza wi±zania dla .NET do bibliotek z Gtk+2 oraz
53 GNOME2.
54
55 %package devel
56 Summary:        Development part of GTK#
57 Summary(pl):    Czê¶æ dla programistów GTK#
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Provides:       dotnet-gtk-devel
61 Provides:       gtk-sharp-devel
62 Obsoletes:      dotnet-gtk-devel
63 Obsoletes:      gtk-sharp-devel
64
65 %description devel
66 Tools (C source parser and C# code generator) and documentation for
67 developing applications using GTK#.
68
69 %description devel -l pl
70 Narzêdzia (parser kodu C oraz generator kodu C#) i dokumentacja
71 potrzebne przy tworzeniu aplikacji korzystaj±cych z GTK#.
72
73 %package static
74 Summary:        Static gtk-sharp libraries
75 Summary(pl):    Biblioteki statyczne gtk-sharp
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78 Provides:       dotnet-gtk-static
79 Provides:       gtk-sharp-static
80 Obsoletes:      dotnet-gtk-static
81 Obsoletes:      gtk-sharp-static
82
83 %description static
84 Static gtk-sharp libraries.
85
86 %description static -l pl
87 Biblioteki statyczne gtk-sharp.
88
89 %prep
90 %setup -q -n gtk-sharp-%{version}
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94 %patch3 -p1
95 %patch4 -p1
96
97 %build
98 rm -rf autom4te.cache
99 %{__libtoolize}
100 %{__aclocal}
101 %{__autoheader}
102 %{__automake}
103 %{__autoconf}
104
105 %configure \
106         GTKHTMLSOVERSION=%{gtkhtml_soversion}
107     
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 install -d $RPM_BUILD_ROOT{%{perl_vendorlib},%{_examplesdir}/%{name}-%{version}}
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 cp -a sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files
126 %defattr(644,root,root,755)
127 %doc README
128 %attr(755,root,root) %{_bindir}/gconfsharp-schemagen*
129 %attr(755,root,root) %{_libdir}/lib*sharpglue.so
130 %{_libdir}/lib*sharpglue.la
131 %{_libdir}/mono/gac/*
132
133 %files devel
134 %defattr(644,root,root,755)
135 %doc README.generator ChangeLog
136 %attr(755,root,root) %{_bindir}/gapi*
137 %{_datadir}/gapi
138 %{_examplesdir}/%{name}-%{version}
139 %{_pkgconfigdir}/*
140 %{_libdir}/mono/gtk-sharp
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/lib*sharpglue.a
This page took 0.06464 seconds and 4 git commands to generate.