]> git.pld-linux.org Git - packages/dotnet-gtk-sharp.git/blob - dotnet-gtk-sharp.spec
- we got now gtkhtml 3.6.1 on head, release 2
[packages/dotnet-gtk-sharp.git] / dotnet-gtk-sharp.spec
1 %define         gtkhtml_soversion       %(/bin/ls %{_libdir}/libgtkhtml-3.6.so.* | /usr/bin/head -n 1 | /usr/bin/awk '{ split($1,v,"."); print v[4]; }')
2 %define         gtkhtml_version         %(if [ -e /usr/bin/pkg-config ]; then /usr/bin/pkg-config --modversion libgtkhtml-3.6; else echo 0; fi)
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        .NET language bindings for GTK+ and GNOME
5 Summary(pl):    Wi±zania GTK+ oraz GNOME dla .NET
6 Name:           dotnet-gtk-sharp
7 Version:        1.0.6
8 Release:        2
9 License:        LGPL
10 Group:          Development/Libraries
11 Source0:        http://www.go-mono.com/archive/%{version}/gtk-sharp-%{version}.tar.gz
12 # Source0-md5:  2651d14fe77174ab20b8af53d150ee11
13 Patch0:         %{name}-gtkhtml31.patch
14 Patch1:         %{name}-destdir.patch
15 Patch2:         %{name}-mint.patch
16 #Patch3:                %{name}-disable-rsvg-sample.patch
17 Patch4:         %{name}-pc-libdir.patch
18 URL:            http://gtk-sharp.sf.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gawk
22 BuildRequires:  gtkhtml-devel >= 3.6.0
23 BuildRequires:  libart_lgpl-devel >= 2.2.0
24 BuildRequires:  libgda-devel >= 1.0.0
25 BuildRequires:  libglade2-devel >= 2.0.1
26 BuildRequires:  libgnomecanvas-devel >= 2.4.0
27 BuildRequires:  libgnomedb-devel >= 1.0.0
28 BuildRequires:  libgnomeprintui-devel >= 2.4.0
29 BuildRequires:  libgnomeui-devel >= 2.4.0
30 BuildRequires:  librsvg-devel >= 2.4.0
31 BuildRequires:  libtool
32 BuildRequires:  libxml2-devel
33 BuildRequires:  mono-csharp >= 1.0.2
34 BuildRequires:  ncurses-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpm-perlprov
37 BuildRequires:  vte-devel >= 0.11.10
38 Requires:       gtkhtml = %{gtkhtml_version}
39 Provides:       dotnet-gtk
40 Provides:       gtk-sharp
41 Obsoletes:      dotnet-gtk
42 Obsoletes:      gtk-sharp
43 ExcludeArch:    alpha
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 This package provides bindings for .NET to GTK+2 and GNOME2 libraries.
48
49 %description -l pl
50 Pakiet ten dostarcza wi±zania dla .NET do bibliotek z GTK+2 oraz
51 GNOME2.
52
53 %package devel
54 Summary:        Development part of GTK#
55 Summary(pl):    Czê¶æ dla programistów GTK#
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Provides:       dotnet-gtk-devel
59 Provides:       gtk-sharp-devel
60 Obsoletes:      dotnet-gtk-devel
61 Obsoletes:      gtk-sharp-devel
62
63 %description devel
64 Tools (C source parser and C# code generator) and documentation for
65 developing applications using GTK#.
66
67 %description devel -l pl
68 Narzêdzia (parser kodu C oraz generator kodu C#) i dokumentacja
69 potrzebne przy tworzeniu aplikacji korzystaj±cych z GTK#.
70
71 %package static
72 Summary:        Static gtk-sharp libraries
73 Summary(pl):    Biblioteki statyczne gtk-sharp
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76 Provides:       dotnet-gtk-static
77 Provides:       gtk-sharp-static
78 Obsoletes:      dotnet-gtk-static
79 Obsoletes:      gtk-sharp-static
80
81 %description static
82 Static gtk-sharp libraries.
83
84 %description static -l pl
85 Biblioteki statyczne gtk-sharp.
86
87 %prep
88 %setup -q -n gtk-sharp-%{version}
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92 #%patch3 -p1
93 %patch4 -p1
94
95 %build
96 rm -rf autom4te.cache
97 %{__libtoolize}
98 %{__aclocal}
99 %{__autoheader}
100 %{__automake}
101 %{__autoconf}
102
103 %configure \
104         GTKHTMLSOVERSION=%{gtkhtml_soversion}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{perl_vendorlib},%{_examplesdir}/%{name}-%{version}}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 cp -a sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc README
125 %attr(755,root,root) %{_bindir}/gconfsharp-schemagen*
126 %attr(755,root,root) %{_libdir}/lib*sharpglue.so
127 %{_libdir}/lib*sharpglue.la
128 %{_libdir}/mono/gac/*
129
130 %files devel
131 %defattr(644,root,root,755)
132 %doc README.generator ChangeLog
133 %attr(755,root,root) %{_bindir}/gapi*
134 %{_datadir}/gapi
135 %{_examplesdir}/%{name}-%{version}
136 %{_pkgconfigdir}/*
137 %{_libdir}/mono/gtk-sharp
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/lib*sharpglue.a
This page took 0.088946 seconds and 4 git commands to generate.