]> git.pld-linux.org Git - packages/dotnet-gtk-sharp.git/blob - dotnet-gtk-sharp.spec
- s/rpm-build >= 4.4.2-0.3/rpmbuild(monoautodeps)/
[packages/dotnet-gtk-sharp.git] / dotnet-gtk-sharp.spec
1 #
2 # Conditional build:
3 %bcond_without  gda     # don't build gda binding
4 %bcond_without  gnome   # don't build GNOME (and dependent) bindings
5 #
6 %define         gtkhtml_soversion       %(/bin/ls %{_libdir}/libgtkhtml-3.6.so.* 2>/dev/null | /usr/bin/head -n 1 | /bin/awk '{ split($1,v,"."); print v[4]; }')
7 %define         gtkhtml_version         %(if [ -e /usr/bin/pkg-config ]; then /usr/bin/pkg-config --modversion libgtkhtml-3.6 2>/dev/null || echo 0; else echo 0; fi)
8 %include        /usr/lib/rpm/macros.perl
9 %include        /usr/lib/rpm/macros.mono
10 Summary:        .NET language bindings for GTK+ and GNOME
11 Summary(pl):    Wi±zania GTK+ oraz GNOME dla .NET
12 Name:           dotnet-gtk-sharp
13 Version:        1.0.10
14 Release:        1
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://go-mono.com/sources/gtk-sharp/gtk-sharp-%{version}.tar.gz
18 # Source0-md5:  e21fb3c5a39374f86ba70b926311a6d0
19 Patch0:         %{name}-gtkhtml31.patch
20 Patch1:         %{name}-destdir.patch
21 Patch2:         %{name}-mint.patch
22 Patch3:         %{name}-pc-libdir.patch
23 URL:            http://gtk-sharp.sf.net/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  gawk
27 BuildRequires:  libart_lgpl-devel >= 2.2.0
28 %{?with_gda:BuildRequires:      libgda-devel >= 1.0.0}
29 BuildRequires:  libglade2-devel >= 2.0.1
30 BuildRequires:  libtool
31 BuildRequires:  libxml2-devel
32 BuildRequires:  mono-csharp >= 1.0.2
33 BuildRequires:  ncurses-devel
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(monoautodeps)
36 BuildRequires:  rpm-perlprov
37 %if %{with gnome}
38 BuildRequires:  gtkhtml-devel >= 3.6.2
39 BuildRequires:  libgnomecanvas-devel >= 2.4.0
40 %{?with_gda:BuildRequires:      libgnomedb-devel >= 1.0.0}
41 BuildRequires:  libgnomeprintui-devel >= 2.4.0
42 BuildRequires:  libgnomeui-devel >= 2.4.0
43 # depends on GNOME (vfs, printui) in PLD
44 BuildRequires:  librsvg-devel >= 2.4.0
45 BuildRequires:  vte-devel >= 0.11.10
46 %endif
47 Requires:       mono >= 1.0.2
48 Provides:       dotnet-gtk
49 Provides:       gtk-sharp
50 Obsoletes:      dotnet-gtk
51 Obsoletes:      gtk-sharp
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 This package provides bindings for .NET to GTK+2 and GNOME2 libraries.
56
57 %description -l pl
58 Pakiet ten dostarcza wi±zania dla .NET do bibliotek z GTK+2 oraz
59 GNOME2.
60
61 %package devel
62 Summary:        Development part of GTK#
63 Summary(pl):    Czê¶æ dla programistów GTK#
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Provides:       dotnet-gtk-devel
67 Provides:       gtk-sharp-devel
68 Obsoletes:      dotnet-gtk-devel
69 Obsoletes:      gtk-sharp-devel
70
71 %description devel
72 Tools (C source parser and C# code generator) and documentation for
73 developing applications using GTK#.
74
75 %description devel -l pl
76 Narzêdzia (parser kodu C oraz generator kodu C#) i dokumentacja
77 potrzebne przy tworzeniu aplikacji korzystaj±cych z GTK#.
78
79 %package static
80 Summary:        Static gtk-sharp libraries
81 Summary(pl):    Biblioteki statyczne gtk-sharp
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84 Provides:       dotnet-gtk-static
85 Provides:       gtk-sharp-static
86 Obsoletes:      dotnet-gtk-static
87 Obsoletes:      gtk-sharp-static
88
89 %description static
90 Static gtk-sharp libraries.
91
92 %description static -l pl
93 Biblioteki statyczne gtk-sharp.
94
95 %package gnome
96 Summary:        .NET language bindings for GNOME libraries
97 Summary(pl):    Wi±zania .NET dla bibliotek GNOME
98 Group:          Libraries
99 Requires:       %{name} = %{version}-%{release}
100 %{?with_gnome:Requires: gtkhtml = %{gtkhtml_version}}
101
102 %description gnome
103 .NET language bindings for GNOME libraries.
104
105 %description gnome -l pl
106 Wi±zania .NET dla bibliotek GNOME.
107
108 %package gnome-devel
109 Summary:        .NET language bindings for GNOME libraries - development files
110 Summary(pl):    Wi±zania .NET dla bibliotek GNOME - pliki programistyczne
111 Group:          Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113 Requires:       %{name}-gnome = %{version}-%{release}
114
115 %description gnome-devel
116 .NET language bindings for GNOME libraries - development files.
117
118 %description gnome-devel -l pl
119 Wi±zania .NET dla bibliotek GNOME - pliki programistyczne.
120
121 %package gnome-static
122 Summary:        .NET language bindings for GNOME libraries - static libraries
123 Summary(pl):    Wi±zania .NET dla bibliotek GNOME - static libraries
124 Group:          Libraries
125 Requires:       %{name}-gnome-devel = %{version}-%{release}
126
127 %description gnome-static
128 .NET language bindings for GNOME libraries - static libraries.
129
130 %description gnome-static -l pl
131 Wi±zania .NET dla bibliotek GNOME - static libraries.
132
133 %package gda
134 Summary:        .NET language bindings for GDA library
135 Summary(pl):    Wi±zania .NET dla biblioteki GDA
136 Group:          Libraries
137 Requires:       %{name} = %{version}-%{release}
138
139 %description gda
140 .NET language bindings for GDA library.
141
142 %description gda -l pl
143 Wi±zania .NET dla biblioteki GDA.
144
145 %package gda-devel
146 Summary:        .NET language bindings for GDA library - development files
147 Summary(pl):    Wi±zania .NET dla biblioteki GDA - pliki programistyczne
148 Group:          Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150 Requires:       %{name}-gda = %{version}-%{release}
151
152 %description gda-devel
153 .NET language bindings for GDA library - development files.
154
155 %description gda-devel -l pl
156 Wi±zania .NET dla biblioteki GDA - pliki programistyczne.
157
158 %package gnomedb
159 Summary:        .NET language bindings for GNOME-DB library
160 Summary(pl):    Wi±zania .NET dla biblioteki GNOME-DB
161 Group:          Libraries
162 Requires:       %{name}-gda = %{version}-%{release}
163 Requires:       %{name}-gnome = %{version}-%{release}
164
165 %description gnomedb
166 .NET language bindings for GNOME-DB library.
167
168 %description gnomedb -l pl
169 Wi±zania .NET dla biblioteki GNOME-DB.
170
171 %package gnomedb-devel
172 Summary:        .NET language bindings for GNOME-DB library - development files
173 Summary(pl):    Wi±zania .NET dla biblioteki GNOME-DB - pliki programistyczne
174 Group:          Libraries
175 Requires:       %{name}-gda-devel = %{version}-%{release}
176 Requires:       %{name}-gnome-devel = %{version}-%{release}
177 Requires:       %{name}-gnomedb = %{version}-%{release}
178
179 %description gnomedb-devel
180 .NET language bindings for GNOME-DB library - development files.
181
182 %description gnomedb-devel -l pl
183 Wi±zania .NET dla biblioteki GNOME-DB - pliki programistyczne.
184
185 %prep
186 %setup -q -n gtk-sharp-%{version}
187 %patch0 -p1
188 %patch1 -p1
189 %patch2 -p1
190 %patch3 -p1
191
192 # workaround for variable name
193 echo 'm4_pattern_allow(PKG_PATH)' > acinclude.m4
194
195 %build
196 %{__libtoolize}
197 %{__aclocal}
198 %{__autoheader}
199 %{__automake}
200 %{__autoconf}
201 %configure \
202         %{?with_gnome:GTKHTMLSOVERSION=%{gtkhtml_soversion}}
203 %{__make}
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
208
209 %{__make} install \
210         DESTDIR=$RPM_BUILD_ROOT
211
212 cp -a sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %post   -p /sbin/ldconfig
218 %postun -p /sbin/ldconfig
219
220 %files
221 %defattr(644,root,root,755)
222 %doc README
223 %attr(755,root,root) %{_libdir}/libgdksharpglue.so
224 %attr(755,root,root) %{_libdir}/libgladesharpglue.so
225 %attr(755,root,root) %{_libdir}/libglibsharpglue.so
226 %attr(755,root,root) %{_libdir}/libgtksharpglue.so
227 %attr(755,root,root) %{_libdir}/libpangosharpglue.so
228 %{_libdir}/libgdksharpglue.la
229 %{_libdir}/libgladesharpglue.la
230 %{_libdir}/libglibsharpglue.la
231 %{_libdir}/libgtksharpglue.la
232 %{_libdir}/libpangosharpglue.la
233 %{_libdir}/mono/gac/art-sharp
234 %{_libdir}/mono/gac/atk-sharp
235 %{_libdir}/mono/gac/gdk-sharp
236 %{_libdir}/mono/gac/glade-sharp
237 %{_libdir}/mono/gac/glib-sharp
238 %{_libdir}/mono/gac/gtk-sharp
239 %{_libdir}/mono/gac/pango-sharp
240
241 %files devel
242 %defattr(644,root,root,755)
243 %doc README.generator ChangeLog
244 %attr(755,root,root) %{_bindir}/gapi*
245 %dir %{_libdir}/mono/gtk-sharp
246 %{_libdir}/mono/gtk-sharp/art-sharp.dll
247 %{_libdir}/mono/gtk-sharp/atk-sharp.dll
248 %{_libdir}/mono/gtk-sharp/gdk-sharp.dll
249 %{_libdir}/mono/gtk-sharp/glade-sharp.dll
250 %{_libdir}/mono/gtk-sharp/glib-sharp.dll
251 %{_libdir}/mono/gtk-sharp/gtk-sharp.dll
252 %{_libdir}/mono/gtk-sharp/pango-sharp.dll
253 %dir %{_datadir}/gapi
254 %{_datadir}/gapi/art-*.xml
255 %{_datadir}/gapi/atk-api.xml
256 %{_datadir}/gapi/gdk-*.xml
257 %{_datadir}/gapi/glade-api.xml
258 %{_datadir}/gapi/gtk-*.xml
259 %{_datadir}/gapi/pango-api.xml
260 %{_pkgconfigdir}/art-sharp.pc
261 %{_pkgconfigdir}/gapi.pc
262 %{_pkgconfigdir}/glade-sharp.pc
263 %{_pkgconfigdir}/gtk-sharp.pc
264 %{_examplesdir}/%{name}-%{version}
265
266 %files static
267 %defattr(644,root,root,755)
268 %{_libdir}/libgdksharpglue.a
269 %{_libdir}/libgladesharpglue.a
270 %{_libdir}/libglibsharpglue.a
271 %{_libdir}/libgtksharpglue.a
272 %{_libdir}/libpangosharpglue.a
273
274 %if %{with gnome}
275 %files gnome
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{_bindir}/gconfsharp-schemagen*
278 %attr(755,root,root) %{_libdir}/libgnomesharpglue.so
279 %{_libdir}/libgnomesharpglue.la
280 %{_libdir}/mono/gac/gconf-sharp
281 %{_libdir}/mono/gac/gconf-sharp-peditors
282 %{_libdir}/mono/gac/gnome-sharp
283 %{_libdir}/mono/gac/gtkhtml-sharp
284 %{_libdir}/mono/gac/rsvg-sharp
285 %{_libdir}/mono/gac/vte-sharp
286
287 %files gnome-devel
288 %defattr(644,root,root,755)
289 %{_libdir}/mono/gtk-sharp/gconf-sharp.dll
290 %{_libdir}/mono/gtk-sharp/gconf-sharp-peditors.dll
291 %{_libdir}/mono/gtk-sharp/gnome-sharp.dll
292 %{_libdir}/mono/gtk-sharp/gtkhtml-sharp.dll
293 %{_libdir}/mono/gtk-sharp/rsvg-sharp.dll
294 %{_libdir}/mono/gtk-sharp/vte-sharp.dll
295 %{_datadir}/gapi/gnome-api.xml
296 %{_datadir}/gapi/gtkhtml-api.xml
297 %{_datadir}/gapi/rsvg-api.xml
298 %{_datadir}/gapi/vte-api.xml
299 %{_pkgconfigdir}/gconf-sharp.pc
300 %{_pkgconfigdir}/gnome-sharp.pc
301 %{_pkgconfigdir}/gtkhtml-sharp.pc
302 %{_pkgconfigdir}/rsvg-sharp.pc
303 %{_pkgconfigdir}/vte-sharp.pc
304
305 %files gnome-static
306 %defattr(644,root,root,755)
307 %{_libdir}/libgnomesharpglue.a
308 %endif
309
310 %if %{with gda}
311 %files gda
312 %defattr(644,root,root,755)
313 %{_libdir}/mono/gac/gda-sharp
314
315 %files gda-devel
316 %defattr(644,root,root,755)
317 %{_libdir}/mono/gtk-sharp/gda-sharp.dll
318 %{_datadir}/gapi/gda-api.xml
319 %{_pkgconfigdir}/gda-sharp.pc
320 %endif
321
322 %if %{with gnome} && %{with gda}
323 %files gnomedb
324 %defattr(644,root,root,755)
325 %{_libdir}/mono/gac/gnomedb-sharp
326
327 %files gnomedb-devel
328 %defattr(644,root,root,755)
329 %{_libdir}/mono/gtk-sharp/gnomedb-sharp.dll
330 %{_datadir}/gapi/gnomedb-api.xml
331 %{_pkgconfigdir}/gnomedb-sharp.pc
332 %endif
This page took 0.097301 seconds and 4 git commands to generate.