]> git.pld-linux.org Git - packages/dotnet-gtk-sharp.git/blob - dotnet-gtk-sharp.spec
- allow installation with dotnet-gtk-sharp2
[packages/dotnet-gtk-sharp.git] / dotnet-gtk-sharp.spec
1 #
2 # Conditional build:
3 %bcond_without  gda     # don't build gda binding
4 %bcond_without  gnome   # don't build GNOME (and dependent) bindings
5 #
6 %define         gtkhtml_soversion       %(/bin/ls %{_libdir}/libgtkhtml-3.6.so.* 2>/dev/null | /usr/bin/head -n 1 | /bin/awk '{ split($1,v,"."); print v[4]; }')
7 %define         gtkhtml_version         %(if [ -e /usr/bin/pkg-config ]; then /usr/bin/pkg-config --modversion libgtkhtml-3.6 2>/dev/null || echo 0; else echo 0; fi)
8 %include        /usr/lib/rpm/macros.perl
9 %include        /usr/lib/rpm/macros.mono
10 Summary:        .NET language bindings for GTK+ and GNOME
11 Summary(pl):    Wi±zania GTK+ oraz GNOME dla .NET
12 Name:           dotnet-gtk-sharp
13 Version:        1.0.10
14 Release:        1
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://go-mono.com/sources/gtk-sharp/gtk-sharp-%{version}.tar.gz
18 # Source0-md5:  e21fb3c5a39374f86ba70b926311a6d0
19 Patch0:         %{name}-gtkhtml31.patch
20 Patch1:         %{name}-destdir.patch
21 Patch2:         %{name}-mint.patch
22 Patch3:         %{name}-pc-libdir.patch
23 URL:            http://gtk-sharp.sf.net/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  gawk
27 BuildRequires:  libart_lgpl-devel >= 2.2.0
28 %{?with_gda:BuildRequires:      libgda-devel >= 1.0.0}
29 BuildRequires:  libglade2-devel >= 2.0.1
30 BuildRequires:  libtool
31 BuildRequires:  libxml2-devel
32 BuildRequires:  mono-csharp >= 1.0.2
33 BuildRequires:  ncurses-devel
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(monoautodeps)
36 BuildRequires:  rpm-perlprov
37 %if %{with gnome}
38 BuildRequires:  gtkhtml-devel >= 3.6.2
39 BuildRequires:  libgnomecanvas-devel >= 2.4.0
40 %{?with_gda:BuildRequires:      libgnomedb-devel >= 1.0.0}
41 BuildRequires:  libgnomeprintui-devel >= 2.4.0
42 BuildRequires:  libgnomeui-devel >= 2.4.0
43 # depends on GNOME (vfs, printui) in PLD
44 BuildRequires:  librsvg-devel >= 2.4.0
45 BuildRequires:  vte-devel >= 0.11.10
46 %endif
47 Requires:       mono >= 1.0.2
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 This package provides bindings for .NET to GTK+2 and GNOME2 libraries.
52
53 %description -l pl
54 Pakiet ten dostarcza wi±zania dla .NET do bibliotek z GTK+2 oraz
55 GNOME2.
56
57 %package devel
58 Summary:        Development part of GTK#
59 Summary(pl):    Czê¶æ dla programistów GTK#
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description devel
64 Tools (C source parser and C# code generator) and documentation for
65 developing applications using GTK#.
66
67 %description devel -l pl
68 Narzêdzia (parser kodu C oraz generator kodu C#) i dokumentacja
69 potrzebne przy tworzeniu aplikacji korzystaj±cych z GTK#.
70
71 %package static
72 Summary:        Static gtk-sharp libraries
73 Summary(pl):    Biblioteki statyczne gtk-sharp
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Static gtk-sharp libraries.
79
80 %description static -l pl
81 Biblioteki statyczne gtk-sharp.
82
83 %package gnome
84 Summary:        .NET language bindings for GNOME libraries
85 Summary(pl):    Wi±zania .NET dla bibliotek GNOME
86 Group:          Libraries
87 Requires:       %{name} = %{version}-%{release}
88 %{?with_gnome:Requires: gtkhtml = %{gtkhtml_version}}
89
90 %description gnome
91 .NET language bindings for GNOME libraries.
92
93 %description gnome -l pl
94 Wi±zania .NET dla bibliotek GNOME.
95
96 %package gnome-devel
97 Summary:        .NET language bindings for GNOME libraries - development files
98 Summary(pl):    Wi±zania .NET dla bibliotek GNOME - pliki programistyczne
99 Group:          Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101 Requires:       %{name}-gnome = %{version}-%{release}
102
103 %description gnome-devel
104 .NET language bindings for GNOME libraries - development files.
105
106 %description gnome-devel -l pl
107 Wi±zania .NET dla bibliotek GNOME - pliki programistyczne.
108
109 %package gnome-static
110 Summary:        .NET language bindings for GNOME libraries - static libraries
111 Summary(pl):    Wi±zania .NET dla bibliotek GNOME - static libraries
112 Group:          Libraries
113 Requires:       %{name}-gnome-devel = %{version}-%{release}
114
115 %description gnome-static
116 .NET language bindings for GNOME libraries - static libraries.
117
118 %description gnome-static -l pl
119 Wi±zania .NET dla bibliotek GNOME - static libraries.
120
121 %package gda
122 Summary:        .NET language bindings for GDA library
123 Summary(pl):    Wi±zania .NET dla biblioteki GDA
124 Group:          Libraries
125 Requires:       %{name} = %{version}-%{release}
126
127 %description gda
128 .NET language bindings for GDA library.
129
130 %description gda -l pl
131 Wi±zania .NET dla biblioteki GDA.
132
133 %package gda-devel
134 Summary:        .NET language bindings for GDA library - development files
135 Summary(pl):    Wi±zania .NET dla biblioteki GDA - pliki programistyczne
136 Group:          Libraries
137 Requires:       %{name}-devel = %{version}-%{release}
138 Requires:       %{name}-gda = %{version}-%{release}
139
140 %description gda-devel
141 .NET language bindings for GDA library - development files.
142
143 %description gda-devel -l pl
144 Wi±zania .NET dla biblioteki GDA - pliki programistyczne.
145
146 %package gnomedb
147 Summary:        .NET language bindings for GNOME-DB library
148 Summary(pl):    Wi±zania .NET dla biblioteki GNOME-DB
149 Group:          Libraries
150 Requires:       %{name}-gda = %{version}-%{release}
151 Requires:       %{name}-gnome = %{version}-%{release}
152
153 %description gnomedb
154 .NET language bindings for GNOME-DB library.
155
156 %description gnomedb -l pl
157 Wi±zania .NET dla biblioteki GNOME-DB.
158
159 %package gnomedb-devel
160 Summary:        .NET language bindings for GNOME-DB library - development files
161 Summary(pl):    Wi±zania .NET dla biblioteki GNOME-DB - pliki programistyczne
162 Group:          Libraries
163 Requires:       %{name}-gda-devel = %{version}-%{release}
164 Requires:       %{name}-gnome-devel = %{version}-%{release}
165 Requires:       %{name}-gnomedb = %{version}-%{release}
166
167 %description gnomedb-devel
168 .NET language bindings for GNOME-DB library - development files.
169
170 %description gnomedb-devel -l pl
171 Wi±zania .NET dla biblioteki GNOME-DB - pliki programistyczne.
172
173 %prep
174 %setup -q -n gtk-sharp-%{version}
175 %patch0 -p1
176 %patch1 -p1
177 %patch2 -p1
178 %patch3 -p1
179
180 # workaround for variable name
181 echo 'm4_pattern_allow(PKG_PATH)' > acinclude.m4
182
183 %build
184 %{__libtoolize}
185 %{__aclocal}
186 %{__autoheader}
187 %{__automake}
188 %{__autoconf}
189 %configure \
190         %{?with_gnome:GTKHTMLSOVERSION=%{gtkhtml_soversion}}
191 %{__make}
192
193 %install
194 rm -rf $RPM_BUILD_ROOT
195 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
196
197 %{__make} install \
198         DESTDIR=$RPM_BUILD_ROOT
199
200 cp -a sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
201
202 %clean
203 rm -rf $RPM_BUILD_ROOT
204
205 %post   -p /sbin/ldconfig
206 %postun -p /sbin/ldconfig
207
208 %files
209 %defattr(644,root,root,755)
210 %doc README
211 %attr(755,root,root) %{_libdir}/libgdksharpglue.so
212 %attr(755,root,root) %{_libdir}/libgladesharpglue.so
213 %attr(755,root,root) %{_libdir}/libglibsharpglue.so
214 %attr(755,root,root) %{_libdir}/libgtksharpglue.so
215 %attr(755,root,root) %{_libdir}/libpangosharpglue.so
216 %{_libdir}/libgdksharpglue.la
217 %{_libdir}/libgladesharpglue.la
218 %{_libdir}/libglibsharpglue.la
219 %{_libdir}/libgtksharpglue.la
220 %{_libdir}/libpangosharpglue.la
221 %{_libdir}/mono/gac/art-sharp
222 %{_libdir}/mono/gac/atk-sharp
223 %{_libdir}/mono/gac/gdk-sharp
224 %{_libdir}/mono/gac/glade-sharp
225 %{_libdir}/mono/gac/glib-sharp
226 %{_libdir}/mono/gac/gtk-sharp
227 %{_libdir}/mono/gac/pango-sharp
228
229 %files devel
230 %defattr(644,root,root,755)
231 %doc README.generator ChangeLog
232 %attr(755,root,root) %{_bindir}/gapi*
233 %dir %{_libdir}/mono/gtk-sharp
234 %{_libdir}/mono/gtk-sharp/art-sharp.dll
235 %{_libdir}/mono/gtk-sharp/atk-sharp.dll
236 %{_libdir}/mono/gtk-sharp/gdk-sharp.dll
237 %{_libdir}/mono/gtk-sharp/glade-sharp.dll
238 %{_libdir}/mono/gtk-sharp/glib-sharp.dll
239 %{_libdir}/mono/gtk-sharp/gtk-sharp.dll
240 %{_libdir}/mono/gtk-sharp/pango-sharp.dll
241 %dir %{_datadir}/gapi
242 %{_datadir}/gapi/art-*.xml
243 %{_datadir}/gapi/atk-api.xml
244 %{_datadir}/gapi/gdk-*.xml
245 %{_datadir}/gapi/glade-api.xml
246 %{_datadir}/gapi/gtk-*.xml
247 %{_datadir}/gapi/pango-api.xml
248 %{_pkgconfigdir}/art-sharp.pc
249 %{_pkgconfigdir}/gapi.pc
250 %{_pkgconfigdir}/glade-sharp.pc
251 %{_pkgconfigdir}/gtk-sharp.pc
252 %{_examplesdir}/%{name}-%{version}
253
254 %files static
255 %defattr(644,root,root,755)
256 %{_libdir}/libgdksharpglue.a
257 %{_libdir}/libgladesharpglue.a
258 %{_libdir}/libglibsharpglue.a
259 %{_libdir}/libgtksharpglue.a
260 %{_libdir}/libpangosharpglue.a
261
262 %if %{with gnome}
263 %files gnome
264 %defattr(644,root,root,755)
265 %attr(755,root,root) %{_bindir}/gconfsharp-schemagen*
266 %attr(755,root,root) %{_libdir}/libgnomesharpglue.so
267 %{_libdir}/libgnomesharpglue.la
268 %{_libdir}/mono/gac/gconf-sharp
269 %{_libdir}/mono/gac/gconf-sharp-peditors
270 %{_libdir}/mono/gac/gnome-sharp
271 %{_libdir}/mono/gac/gtkhtml-sharp
272 %{_libdir}/mono/gac/rsvg-sharp
273 %{_libdir}/mono/gac/vte-sharp
274
275 %files gnome-devel
276 %defattr(644,root,root,755)
277 %{_libdir}/mono/gtk-sharp/gconf-sharp.dll
278 %{_libdir}/mono/gtk-sharp/gconf-sharp-peditors.dll
279 %{_libdir}/mono/gtk-sharp/gnome-sharp.dll
280 %{_libdir}/mono/gtk-sharp/gtkhtml-sharp.dll
281 %{_libdir}/mono/gtk-sharp/rsvg-sharp.dll
282 %{_libdir}/mono/gtk-sharp/vte-sharp.dll
283 %{_datadir}/gapi/gnome-api.xml
284 %{_datadir}/gapi/gtkhtml-api.xml
285 %{_datadir}/gapi/rsvg-api.xml
286 %{_datadir}/gapi/vte-api.xml
287 %{_pkgconfigdir}/gconf-sharp.pc
288 %{_pkgconfigdir}/gnome-sharp.pc
289 %{_pkgconfigdir}/gtkhtml-sharp.pc
290 %{_pkgconfigdir}/rsvg-sharp.pc
291 %{_pkgconfigdir}/vte-sharp.pc
292
293 %files gnome-static
294 %defattr(644,root,root,755)
295 %{_libdir}/libgnomesharpglue.a
296 %endif
297
298 %if %{with gda}
299 %files gda
300 %defattr(644,root,root,755)
301 %{_libdir}/mono/gac/gda-sharp
302
303 %files gda-devel
304 %defattr(644,root,root,755)
305 %{_libdir}/mono/gtk-sharp/gda-sharp.dll
306 %{_datadir}/gapi/gda-api.xml
307 %{_pkgconfigdir}/gda-sharp.pc
308 %endif
309
310 %if %{with gnome} && %{with gda}
311 %files gnomedb
312 %defattr(644,root,root,755)
313 %{_libdir}/mono/gac/gnomedb-sharp
314
315 %files gnomedb-devel
316 %defattr(644,root,root,755)
317 %{_libdir}/mono/gtk-sharp/gnomedb-sharp.dll
318 %{_datadir}/gapi/gnomedb-api.xml
319 %{_pkgconfigdir}/gnomedb-sharp.pc
320 %endif
This page took 0.056199 seconds and 4 git commands to generate.