]> git.pld-linux.org Git - packages/dotnet-gtk-sharp.git/blob - dotnet-gtk-sharp.spec
- rel. 6 (I forgot)
[packages/dotnet-gtk-sharp.git] / dotnet-gtk-sharp.spec
1 %define         gtkhtml_soversion       %(/bin/ls %{_libdir}/libgtkhtml-3.1.so.* | /usr/bin/head -1 | /usr/bin/awk '{ split($1,v,"."); print v[4]; }')
2 %define         gtkhtml_version         %(/usr/bin/pkg-config --modversion libgtkhtml-3.1)
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        .NET language bindings for Gtk+ and GNOME
5 Summary(pl):    Wi±zania Gtk+ oraz GNOME dla .NET
6 Name:           dotnet-gtk-sharp
7 Version:        1.0
8 Release:        6
9 License:        LGPL
10 Group:          Development/Libraries
11 Source0:        http://www.go-mono.com/archive/%{version}/gtk-sharp-%{version}.tar.gz
12 # Source0-md5:  6eab56e11c1e1245ec6af12312969399
13 Patch0:         %{name}-gtkhtml31.patch
14 Patch1:         %{name}-destdir.patch
15 Patch2:         %{name}-mint.patch
16 Patch3:         %{name}-disable-rsvg-sample.patch
17 Patch4:         %{name}-pc-libdir.patch
18 URL:            http://gtk-sharp.sf.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gtkhtml-devel >= 3.1.14
22 BuildRequires:  libart_lgpl-devel >= 2.2.0
23 BuildRequires:  libgda-devel >= 1.0.0
24 BuildRequires:  libglade2-devel >= 2.0.1
25 BuildRequires:  libgnomecanvas-devel >= 2.4.0
26 BuildRequires:  libgnomedb-devel >= 1.0.0
27 BuildRequires:  libgnomeprintui-devel >= 2.4.0
28 BuildRequires:  libgnomeui-devel >= 2.4.0
29 BuildRequires:  librsvg-devel >= 2.4.0
30 BuildRequires:  libtool
31 BuildRequires:  libxml2-devel
32 BuildRequires:  mono-csharp
33 BuildRequires:  mono-devel >= 1.0-3
34 BuildRequires:  ncurses-devel
35 BuildRequires:  rpm-perlprov
36 BuildRequires:  vte-devel >= 0.11.10
37 BuildRequires:  gawk
38 Requires:       gtkhtml = %{gtkhtml_version}
39 Provides:       dotnet-gtk
40 Provides:       gtk-sharp
41 Obsoletes:      dotnet-gtk
42 Obsoletes:      gtk-sharp
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45
46
47 %description
48 This package provides bindings for .NET to Gtk+2 and GNOME2 libraries.
49
50 %description -l pl
51 Pakiet ten dostarcza wi±zania dla .NET do bibliotek z Gtk+2 oraz
52 GNOME2.
53
54 %package devel
55 Summary:        Development part of GTK#
56 Summary(pl):    Czê¶æ dla programistów GTK#
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Provides:       dotnet-gtk-devel
60 Provides:       gtk-sharp-devel
61 Obsoletes:      dotnet-gtk-devel
62 Obsoletes:      gtk-sharp-devel
63
64 %description devel
65 Tools (C source parser and C# code generator) and documentation for
66 developing applications using GTK#.
67
68 %description devel -l pl
69 Narzêdzia (parser kodu C oraz generator kodu C#) i dokumentacja
70 potrzebne przy tworzeniu aplikacji korzystaj±cych z GTK#.
71
72 %package static
73 Summary:        Static gtk-sharp libraries
74 Summary(pl):    Biblioteki statyczne gtk-sharp
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77 Provides:       dotnet-gtk-static
78 Provides:       gtk-sharp-static
79 Obsoletes:      dotnet-gtk-static
80 Obsoletes:      gtk-sharp-static
81
82 %description static
83 Static gtk-sharp libraries.
84
85 %description static -l pl
86 Biblioteki statyczne gtk-sharp.
87
88 %prep
89 %setup -q -n gtk-sharp-%{version}
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93 %patch3 -p1
94 %patch4 -p1
95
96 %build
97 rm -rf autom4te.cache
98 %{__libtoolize}
99 %{__aclocal}
100 %{__autoheader}
101 %{__automake}
102 %{__autoconf}
103
104 %configure \
105         GTKHTMLSOVERSION=%{gtkhtml_soversion}
106     
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{perl_vendorlib},%{_examplesdir}/%{name}-%{version}}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 cp -a sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc README
127 %attr(755,root,root) %{_bindir}/gconfsharp-schemagen*
128 %attr(755,root,root) %{_libdir}/lib*sharpglue.so
129 %{_libdir}/lib*sharpglue.la
130 %{_libdir}/mono/gac/*
131
132 %files devel
133 %defattr(644,root,root,755)
134 %doc README.generator ChangeLog
135 %attr(755,root,root) %{_bindir}/gapi*
136 %{_datadir}/gapi
137 %{_examplesdir}/%{name}-%{version}
138 %{_pkgconfigdir}/*
139 %{_libdir}/mono/gtk-sharp
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/lib*sharpglue.a
This page took 0.038558 seconds and 4 git commands to generate.