]> git.pld-linux.org Git - packages/dotnet-gnome-desktop-sharp.git/blob - dotnet-gnome-desktop-sharp.spec
- versioned Obsoletes, updated macros for mono dependency generators
[packages/dotnet-gnome-desktop-sharp.git] / dotnet-gnome-desktop-sharp.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilusburn    # NautilusBurn# binding
4 %bcond_with     gnomepanel      # GnomePanel# binding
5
6 %define gnome_ver               2.25.0
7 %define gnomesharp_ver          2.24.1
8 %define gtkhtml_ver             3.23.5
9 %define gtksharp_ver            2.12.2
10 %define gtksourceview_ver       2.2.2
11 %define libgnomeprint_ver       2.18.0
12 %define librsvg_ver             2.22.2
13 %define nautilusburn_ver        2.22.1
14 %define vte_ver                 0.16.14
15
16 %include        /usr/lib/rpm/macros.mono
17 %include        /usr/lib/rpm/macros.perl
18 Summary:        GnomeDesktop# - .NET binding for GNOME Desktop library
19 Summary(pl.UTF-8):      GnomeDesktop# - wiązanie .NET do biblioteki GNOME Desktop
20 Name:           dotnet-gnome-desktop-sharp
21 Version:        2.26.0
22 Release:        7
23 License:        LGPL v2.1
24 Group:          Libraries
25 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-desktop-sharp/2.26/gnome-desktop-sharp-%{version}.tar.bz2
26 # Source0-md5:  4bc990900bb318b2ba0b0e7998bb47d1
27 Patch0:         gnome-desktop-soname.patch
28 Patch1:         %{name}-opt.patch
29 URL:            http://gtk-sharp.sourceforge.net/
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  dotnet-gnome-sharp-devel >= %{gnomesharp_ver}
33 BuildRequires:  dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
34 BuildRequires:  gnome-desktop2-devel >= %{gnome_ver}
35 %if %{with gnomepanel}
36 BuildRequires:  gnome-panel-devel >= %{gnome_ver}
37 BuildRequires:  gnome-panel-devel < 3
38 %endif
39 BuildRequires:  gtk+2-devel >= 2:2.14.0
40 BuildRequires:  gtkhtml3-devel >= %{gtkhtml_ver}
41 BuildRequires:  gtksourceview2-devel >= %{gtksourceview_ver}
42 BuildRequires:  libgnomeprintui-devel >= %{libgnomeprint_ver}
43 BuildRequires:  librsvg-devel >= %{librsvg_ver}
44 BuildRequires:  libtool
45 BuildRequires:  libwnck2-devel >= %{gnome_ver}
46 BuildRequires:  mono-csharp >= 1.1.16.1
47 BuildRequires:  monodoc >= 1.1.16
48 %{?with_nautilusburn:BuildRequires:     nautilus-cd-burner-devel >= %{nautilusburn_ver}}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpm-perlprov
51 BuildRequires:  rpmbuild(monoautodeps)
52 BuildRequires:  vte0-devel >= %{vte_ver}
53 %{!?with_nautilusburn:BuildConflicts:   nautilus-cd-burner-devel}
54 Requires:       gnome-desktop2 >= 2.30
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 This package provides .NET bindings for some of the GNOME desktop
59 libraries.
60
61 %description -l pl.UTF-8
62 Pakiet ten dostarcza wiązania niektórych bibliotek GNOME desktop dla
63 .NET.
64
65 %package devel
66 Summary:        Development files for GnomeDesktop# library
67 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GnomeDesktop#
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       dotnet-gnome-sharp-devel >= %{gnomesharp_ver}
71 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
72
73 %description devel
74 Development files for GnomeDesktop# library.
75
76 %description devel -l pl.UTF-8
77 Pliki programistyczne biblioteki GnomeDesktop#.
78
79 %package static
80 Summary:        Static GNOMEDesktop# libraries
81 Summary(pl.UTF-8):      Biblioteki statyczne GNOMEDesktop#
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static GNOMEDesktop# libraries.
87
88 %description static -l pl.UTF-8
89 Biblioteki statyczne GNOMEDesktop#.
90
91 %package -n dotnet-gnome-panel-sharp
92 Summary:        GnomePanel# - .NET binding for libpanelapplet library
93 Summary(pl.UTF-8):      GnomePanel# - wiązanie .NET do biblioteki libpanelapplet
94 Group:          Libraries
95 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
96 Requires:       gnome-panel-devel >= %{gnome_ver}
97 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
98
99 %description -n dotnet-gnome-panel-sharp
100 GnomePanel# - .NET binding for libpanelapplet library.
101
102 %description -n dotnet-gnome-panel-sharp -l pl.UTF-8
103 GnomePanel# - wiązanie .NET do biblioteki libpanelapplet.
104
105 %package -n dotnet-gnome-panel-sharp-devel
106 Summary:        Development files for GnomePanel# library
107 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GnomePanel#
108 Group:          Development/Libraries
109 Requires:       dotnet-gnome-panel-sharp = %{version}-%{release}
110 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
111
112 %description -n dotnet-gnome-panel-sharp-devel
113 Development files for GnomePanel# library.
114
115 %description -n dotnet-gnome-panel-sharp-devel -l pl.UTF-8
116 Pliki programistyczne biblioteki GnomePanel#.
117
118 %package -n dotnet-gnome-panel-sharp-static
119 Summary:        Static GnomePanel# glue library
120 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca GnomePanel#
121 Group:          Development/Libraries
122 Requires:       dotnet-gnome-panel-sharp-devel = %{version}-%{release}
123 Obsoletes:      dotnet-gnome-desktop-sharp-static
124
125 %description -n dotnet-gnome-panel-sharp-static
126 Static GnomePanel# glue library.
127
128 %description -n dotnet-gnome-panel-sharp-static -l pl.UTF-8
129 Statyczna biblioteka sklejająca GnomePanel#.
130
131 %package -n dotnet-gnome-print-sharp
132 Summary:        GnomePrint# - .NET binding for libgnomeprint libraries
133 Summary(pl.UTF-8):      GnomePrint# - wiązanie .NET do bibliotek libgnomeprint
134 Group:          Libraries
135 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
136 Requires:       libgnomeprintui >= %{libgnomeprint_ver}
137 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
138
139 %description -n dotnet-gnome-print-sharp
140 GnomePrint# - .NET binding for libgnomeprint and libgnomeprintui
141 libraries.
142
143 %description -n dotnet-gnome-print-sharp -l pl.UTF-8
144 GnomePrint# - wiązanie .NET do bibliotek libgnomeprint oraz
145 libgnomeprintui.
146
147 %package -n dotnet-gnome-print-sharp-devel
148 Summary:        Development files for GnomePrint# library
149 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GnomePrint#
150 Group:          Development/Libraries
151 Requires:       dotnet-gnome-print-sharp = %{version}-%{release}
152 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
153
154 %description -n dotnet-gnome-print-sharp-devel
155 Development files for GnomePrint# library.
156
157 %description -n dotnet-gnome-print-sharp-devel -l pl.UTF-8
158 Pliki programistyczne biblioteki GnomePrint#.
159
160 %package -n dotnet-gtkhtml-sharp
161 Summary:        Gtkhtml# - .NET binding for Gtkhtml library
162 Summary(pl.UTF-8):      Gtkhtml# - wiązanie .NET do biblioteki Gtkhtml
163 Group:          Libraries
164 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
165 Requires:       gtkhtml3-devel >= %{gtkhtml_ver}
166 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
167
168 %description -n dotnet-gtkhtml-sharp
169 Gtkhtml# - .NET binding for Gtkhtml library.
170
171 %description -n dotnet-gtkhtml-sharp -l pl.UTF-8
172 Gtkhtml# - wiązanie .NET do biblioteki Gtkhtml.
173
174 %package -n dotnet-gtkhtml-sharp-devel
175 Summary:        Development files for Gtkhtml# library
176 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Gtkhtml#
177 Group:          Development/Libraries
178 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
179 Requires:       dotnet-gtkhtml-sharp = %{version}-%{release}
180
181 %description -n dotnet-gtkhtml-sharp-devel
182 Development files for Gtkhtml# library.
183
184 %description -n dotnet-gtkhtml-sharp-devel -l pl.UTF-8
185 Pliki programistyczne biblioteki Gtkhtml#.
186
187 %package -n dotnet-gtkhtml-sharp-static
188 Summary:        Static Gtkhtml# glue library
189 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca Gtkhtml#
190 Group:          Development/Libraries
191 Requires:       dotnet-gtkhtml-sharp-devel = %{version}-%{release}
192 Obsoletes:      dotnet-gnome-desktop-sharp-static
193
194 %description -n dotnet-gtkhtml-sharp-static
195 Static Gtkhtml# glue library.
196
197 %description -n dotnet-gtkhtml-sharp-static -l pl.UTF-8
198 Statyczna biblioteka sklejająca Gtkhtml#.
199
200 %package -n dotnet-gtksourceview2-sharp
201 Summary:        GtkSourceView# - .NET binding for gtksourceview library
202 Summary(pl.UTF-8):      GtkSourceView# - wiązanie .NET do biblioteki gtksourceview
203 Group:          Libraries
204 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
205 Requires:       gtksourceview2 >= %{gtksourceview_ver}
206 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
207
208 %description -n dotnet-gtksourceview2-sharp
209 GtkSourceView# - .NET binding for gtksourceview library.
210
211 %description -n dotnet-gtksourceview2-sharp -l pl.UTF-8
212 GtkSourceView# - wiązanie .NET do biblioteki gtksourceview.
213
214 %package -n dotnet-gtksourceview2-sharp-devel
215 Summary:        Development files for GtkSourceView# library
216 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GtkSourceView#
217 Group:          Development/Libraries
218 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
219 Requires:       dotnet-gtksourceview2-sharp = %{version}-%{release}
220
221 %description -n dotnet-gtksourceview2-sharp-devel
222 Development files for GtkSourceView# library.
223
224 %description -n dotnet-gtksourceview2-sharp-devel -l pl.UTF-8
225 Pliki programistyczne biblioteki GtkSourceView#.
226
227 %package -n dotnet-gtksourceview2-sharp-static
228 Summary:        Static GtkSourceView# glue library
229 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca GtkSourceView#
230 Group:          Development/Libraries
231 Requires:       dotnet-gtksourceview2-sharp-devel = %{version}-%{release}
232 Obsoletes:      dotnet-gnome-desktop-sharp-static
233
234 %description -n dotnet-gtksourceview2-sharp-static
235 Static GtkSourceView# glue library.
236
237 %description -n dotnet-gtksourceview2-sharp-static -l pl.UTF-8
238 Statyczna biblioteka sklejająca GtkSourceView#.
239
240 %package -n dotnet-nautilusburn-sharp
241 Summary:        NautilusBurn# - .NET binding for libnautilus-burn library
242 Summary(pl.UTF-8):      NautilusBurn# - wiązanie .NET do biblioteki libnautilus-burn
243 Group:          Libraries
244 Requires:       nautilus-cd-burner-libs >= %{nautilusburn_ver}
245 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
246
247 %description -n dotnet-nautilusburn-sharp
248 NautilusBurn# - .NET binding for libnautilus-burn library.
249
250 %description -n dotnet-nautilusburn-sharp -l pl.UTF-8
251 NautilusBurn# - wiązanie .NET do biblioteki libnautilus-burn.
252
253 %package -n dotnet-nautilusburn-sharp-devel
254 Summary:        Development files for NautilusBurn# library
255 Summary(pl.UTF-8):      Pliki programistyczne biblioteki NautilusBurn#
256 Group:          Development/Libraries
257 Requires:       dotnet-nautilusburn-sharp = %{version}-%{release}
258
259 %description -n dotnet-nautilusburn-sharp-devel
260 Development files for NautilusBurn# library.
261
262 %description -n dotnet-nautilusburn-sharp-devel -l pl.UTF-8
263 Pliki programistyczne biblioteki NautilusBurn#.
264
265 %package -n dotnet-nautilusburn-sharp-static
266 Summary:        Static NautilusBurn# glue library
267 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca NautilusBurn#
268 Group:          Development/Libraries
269 Requires:       dotnet-nautilusburn-sharp-devel = %{version}-%{release}
270 Obsoletes:      dotnet-gnome-desktop-sharp-static
271
272 %description -n dotnet-nautilusburn-sharp-static
273 Static NautilusBurn# glue library.
274
275 %description -n dotnet-nautilusburn-sharp-static -l pl.UTF-8
276 Statyczna biblioteka sklejająca NautilusBurn#.
277
278 %package -n dotnet-rsvg2-sharp
279 Summary:        Rsvg# - .NET binding for librsvg library
280 Summary(pl.UTF-8):      Rsvg# - wiązanie .NET do biblioteki librsvg
281 Group:          Libraries
282 Requires:       librsvg >= %{librsvg_ver}
283 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
284
285 %description -n dotnet-rsvg2-sharp
286 Rsvg# - .NET binding for librsvg library.
287
288 %description -n dotnet-rsvg2-sharp -l pl.UTF-8
289 Rsvg# - wiązanie .NET do biblioteki librsvg.
290
291 %package -n dotnet-rsvg2-sharp-devel
292 Summary:        Development files for Rsvg# library
293 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Rsvg#
294 Group:          Development/Libraries
295 Requires:       dotnet-rsvg2-sharp = %{version}-%{release}
296
297 %description -n dotnet-rsvg2-sharp-devel
298 Development files for Rsvg# library.
299
300 %description -n dotnet-rsvg2-sharp-devel -l pl.UTF-8
301 Pliki programistyczne biblioteki Rsvg#.
302
303 %package -n dotnet-vte-sharp
304 Summary:        Vte# - .NET binding for libvte library
305 Summary(pl.UTF-8):      Vte# - wiązanie .NET do biblioteki libvte
306 Group:          Libraries
307 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
308 Requires:       vte0 >= %{vte_ver}
309 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
310
311 %description -n dotnet-vte-sharp
312 Vte# - .NET binding for libvte library.
313
314 %description -n dotnet-vte-sharp -l pl.UTF-8
315 Vte# - wiązanie .NET do biblioteki libvte.
316
317 %package -n dotnet-vte-sharp-devel
318 Summary:        Development files for Vte# library
319 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Vte#
320 Group:          Development/Libraries
321 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
322 Requires:       dotnet-vte-sharp = %{version}-%{release}
323
324 %description -n dotnet-vte-sharp-devel
325 Development files for Vte# library.
326
327 %description -n dotnet-vte-sharp-devel -l pl.UTF-8
328 Pliki programistyczne biblioteki Vte#.
329
330 %package -n dotnet-vte-sharp-static
331 Summary:        Static Vte# glue library
332 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca Vte#
333 Group:          Development/Libraries
334 Requires:       dotnet-vte-sharp-devel = %{version}-%{release}
335 Obsoletes:      dotnet-gnome-desktop-sharp-static
336
337 %description -n dotnet-vte-sharp-static
338 Static Vte# glue library.
339
340 %description -n dotnet-vte-sharp-static -l pl.UTF-8
341 Statyczna biblioteka sklejająca Vte#.
342
343 %package -n dotnet-wnck-sharp
344 Summary:        Wnck# - .NET binding for libwnck library
345 Summary(pl.UTF-8):      Wnck# - wiązanie .NET do biblioteki libwnck
346 Group:          Libraries
347 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
348 Requires:       libwnck2 >= %{gnome_ver}
349 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
350
351 %description -n dotnet-wnck-sharp
352 Wnck# - .NET binding for libwnck library.
353
354 %description -n dotnet-wnck-sharp -l pl.UTF-8
355 Wnck# - wiązanie .NET do biblioteki libwnck.
356
357 %package -n dotnet-wnck-sharp-devel
358 Summary:        Development files for Wnck# library
359 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Wnck#
360 Group:          Development/Libraries
361 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
362 Requires:       dotnet-wnck-sharp = %{version}-%{release}
363
364 %description -n dotnet-wnck-sharp-devel
365 Development files for Wnck# library.
366
367 %description -n dotnet-wnck-sharp-devel -l pl.UTF-8
368 Pliki programistyczne biblioteki Wnck#.
369
370 %package -n dotnet-wnck-sharp-static
371 Summary:        Static Wnck# glue library
372 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca Wnck#
373 Group:          Development/Libraries
374 Requires:       dotnet-wnck-sharp-devel = %{version}-%{release}
375 Obsoletes:      dotnet-gnome-desktop-sharp-static
376
377 %description -n dotnet-wnck-sharp-static
378 Static Wnck# glue library.
379
380 %description -n dotnet-wnck-sharp-static -l pl.UTF-8
381 Statyczna biblioteka sklejająca Wnck#.
382
383 %prep
384 %setup -q -n gnome-desktop-sharp-%{version}
385 %patch0 -p1
386 %patch1 -p1
387
388 %build
389 %{__libtoolize}
390 %{__aclocal}
391 %{__autoconf}
392 %{__autoheader}
393 %{__automake}
394 %configure
395 %{__make}
396
397 %install
398 rm -rf $RPM_BUILD_ROOT
399
400 %{__make} install \
401         DESTDIR=$RPM_BUILD_ROOT \
402         monodocdir=%{_libdir}/monodoc/sources
403
404 %clean
405 rm -rf $RPM_BUILD_ROOT
406
407 %post   -n dotnet-gnome-panel-sharp -p /sbin/ldconfig
408 %postun -n dotnet-gnome-panel-sharp -p /sbin/ldconfig
409
410 %post   -n dotnet-gtkhtml-sharp -p /sbin/ldconfig
411 %postun -n dotnet-gtkhtml-sharp -p /sbin/ldconfig
412
413 %post   -n dotnet-gtksourceview2-sharp -p /sbin/ldconfig
414 %postun -n dotnet-gtksourceview2-sharp -p /sbin/ldconfig
415
416 %post   -n dotnet-nautilusburn-sharp -p /sbin/ldconfig
417 %postun -n dotnet-nautilusburn-sharp -p /sbin/ldconfig
418
419 %post   -n dotnet-vte-sharp -p /sbin/ldconfig
420 %postun -n dotnet-vte-sharp -p /sbin/ldconfig
421
422 %post   -n dotnet-wnck-sharp -p /sbin/ldconfig
423 %postun -n dotnet-wnck-sharp -p /sbin/ldconfig
424
425 %files
426 %defattr(644,root,root,755)
427 %doc AUTHORS ChangeLog NEWS README
428 %{_prefix}/lib/mono/gac/gnomedesktop-sharp
429
430 %files devel
431 %defattr(644,root,root,755)
432 %{_prefix}/lib/mono/gnomedesktop-sharp-2.20
433 %{_datadir}/gnomedesktop-sharp
434 %{_pkgconfigdir}/gnome-desktop-sharp-2.0.pc
435
436 %if %{with gnomepanel}
437 %files -n dotnet-gnome-panel-sharp
438 %defattr(644,root,root,755)
439 %attr(755,root,root) %{_libdir}/libgnomepanelsharpglue-2.so
440 %{_libdir}/libgnomepanelsharpglue-2.la
441 %{_prefix}/lib/mono/gac/gnome-panel-sharp
442
443 %files -n dotnet-gnome-panel-sharp-devel
444 %defattr(644,root,root,755)
445 %{_prefix}/lib/mono/gnome-panel-sharp-2.24
446 %{_pkgconfigdir}/gnome-panel-sharp-2.24.pc
447
448 %files -n dotnet-gnome-panel-sharp-static
449 %defattr(644,root,root,755)
450 %{_libdir}/libgnomepanelsharpglue-2.a
451 %endif
452
453 %files -n dotnet-gnome-print-sharp
454 %defattr(644,root,root,755)
455 %{_prefix}/lib/mono/gac/gnome-print-sharp
456
457 %files -n dotnet-gnome-print-sharp-devel
458 %defattr(644,root,root,755)
459 %{_prefix}/lib/mono/gnome-print-sharp-2.18
460 %{_datadir}/gnome-print-sharp
461 %{_pkgconfigdir}/gnome-print-sharp-2.18.pc
462
463 %files -n dotnet-gtkhtml-sharp
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_libdir}/libgtkhtmlsharpglue-2.so
466 %{_libdir}/libgtkhtmlsharpglue-2.la
467 %{_prefix}/lib/mono/gac/gtkhtml-sharp
468
469 %files -n dotnet-gtkhtml-sharp-devel
470 %defattr(644,root,root,755)
471 %{_prefix}/lib/mono/gtkhtml-sharp-3.14
472 %{_datadir}/gtkhtml-sharp
473 %{_pkgconfigdir}/gtkhtml-sharp-3.14.pc
474
475 %files -n dotnet-gtkhtml-sharp-static
476 %defattr(644,root,root,755)
477 %{_libdir}/libgtkhtmlsharpglue-2.a
478
479 %files -n dotnet-gtksourceview2-sharp
480 %defattr(644,root,root,755)
481 %attr(755,root,root) %{_libdir}/libgtksourceview2sharpglue-2.so
482 %{_libdir}/libgtksourceview2sharpglue-2.la
483 %{_prefix}/lib/mono/gac/gtksourceview2-sharp
484
485 %files -n dotnet-gtksourceview2-sharp-devel
486 %defattr(644,root,root,755)
487 %{_prefix}/lib/mono/gtksourceview2-sharp-2.0
488 %{_datadir}/gtksourceview2-sharp
489 %{_pkgconfigdir}/gtksourceview2-sharp.pc
490
491 %files -n dotnet-gtksourceview2-sharp-static
492 %defattr(644,root,root,755)
493 %{_libdir}/libgtksourceview2sharpglue-2.a
494
495 %if %{with nautilusburn}
496 %files -n dotnet-nautilusburn-sharp
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{_libdir}/libnautilusburnsharpglue-2.so
499 %{_libdir}/libnautilusburnsharpglue-2.la
500 %{_prefix}/lib/mono/gac/nautilusburn-sharp
501
502 %files -n dotnet-nautilusburn-sharp-devel
503 %defattr(644,root,root,755)
504 %{_prefix}/lib/mono/nautilusburn-sharp
505 %{_datadir}/nautilusburn-sharp
506 %{_pkgconfigdir}/nautilusburn-sharp.pc
507
508 %files -n dotnet-nautilusburn-sharp-static
509 %defattr(644,root,root,755)
510 %{_libdir}/libnautilusburnsharpglue-2.a
511 %endif
512
513 %files -n dotnet-rsvg2-sharp
514 %defattr(644,root,root,755)
515 %{_prefix}/lib/mono/gac/rsvg2-sharp
516
517 %files -n dotnet-rsvg2-sharp-devel
518 %defattr(644,root,root,755)
519 %{_prefix}/lib/mono/rsvg2-sharp-2.0
520 %{_datadir}/rsvg2-sharp
521 %{_pkgconfigdir}/rsvg2-sharp-2.0.pc
522
523 %files -n dotnet-vte-sharp
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_libdir}/libvtesharpglue-2.so
526 %{_libdir}/libvtesharpglue-2.la
527 %{_prefix}/lib/mono/gac/vte-sharp
528
529 %files -n dotnet-vte-sharp-devel
530 %defattr(644,root,root,755)
531 %{_prefix}/lib/mono/vte-sharp-0.16
532 %{_datadir}/vte-sharp
533 %{_pkgconfigdir}/vte-sharp-0.16.pc
534
535 %files -n dotnet-vte-sharp-static
536 %defattr(644,root,root,755)
537 %{_libdir}/libvtesharpglue-2.a
538
539 %files -n dotnet-wnck-sharp
540 %defattr(644,root,root,755)
541 %attr(755,root,root) %{_libdir}/libwncksharpglue-2.so
542 %{_libdir}/libwncksharpglue-2.la
543 %{_prefix}/lib/mono/gac/wnck-sharp
544
545 %files -n dotnet-wnck-sharp-devel
546 %defattr(644,root,root,755)
547 %{_prefix}/lib/mono/wnck-sharp-2.20
548 %{_datadir}/wnck-sharp
549 %{_pkgconfigdir}/wnck-sharp-1.0.pc
550
551 %files -n dotnet-wnck-sharp-static
552 %defattr(644,root,root,755)
553 %{_libdir}/libwncksharpglue-2.a
This page took 0.113678 seconds and 3 git commands to generate.