]> git.pld-linux.org Git - packages/dotnet-gnome-desktop-sharp.git/blob - dotnet-gnome-desktop-sharp.spec
- versioned Obsoletes, updated macros for mono dependency generators
[packages/dotnet-gnome-desktop-sharp.git] / dotnet-gnome-desktop-sharp.spec
1 #
2 # Conditional build:
3 %bcond_with     nautilusburn    # NautilusBurn# binding
4 %bcond_with     gnomepanel      # GnomePanel# binding
5
6 %define gnome_ver               2.25.0
7 %define gnomesharp_ver          2.24.1
8 %define gtkhtml_ver             3.23.5
9 %define gtksharp_ver            2.12.2
10 %define gtksourceview_ver       2.2.2
11 %define libgnomeprint_ver       2.18.0
12 %define librsvg_ver             2.22.2
13 %define nautilusburn_ver        2.22.1
14 %define vte_ver                 0.16.14
15
16 Summary:        GnomeDesktop# - .NET binding for GNOME Desktop library
17 Summary(pl.UTF-8):      GnomeDesktop# - wiązanie .NET do biblioteki GNOME Desktop
18 Name:           dotnet-gnome-desktop-sharp
19 Version:        2.26.0
20 Release:        7
21 License:        LGPL v2.1
22 Group:          Libraries
23 Source0:        https://download.gnome.org/sources/gnome-desktop-sharp/2.26/gnome-desktop-sharp-%{version}.tar.bz2
24 # Source0-md5:  4bc990900bb318b2ba0b0e7998bb47d1
25 Patch0:         gnome-desktop-soname.patch
26 Patch1:         %{name}-opt.patch
27 URL:            https://www.mono-project.com/GtkSharp/
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  dotnet-gnome-sharp-devel >= %{gnomesharp_ver}
31 BuildRequires:  dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
32 BuildRequires:  gnome-desktop2-devel >= %{gnome_ver}
33 %if %{with gnomepanel}
34 BuildRequires:  gnome-panel-devel >= %{gnome_ver}
35 BuildRequires:  gnome-panel-devel < 3
36 %endif
37 BuildRequires:  gtk+2-devel >= 2:2.14.0
38 BuildRequires:  gtkhtml3-devel >= %{gtkhtml_ver}
39 BuildRequires:  gtksourceview2-devel >= %{gtksourceview_ver}
40 BuildRequires:  libgnomeprintui-devel >= %{libgnomeprint_ver}
41 BuildRequires:  librsvg-devel >= %{librsvg_ver}
42 BuildRequires:  libtool
43 BuildRequires:  libwnck2-devel >= %{gnome_ver}
44 BuildRequires:  mono-csharp >= 1.1.16.1
45 BuildRequires:  monodoc >= 1.1.16
46 %{?with_nautilusburn:BuildRequires:     nautilus-cd-burner-devel >= %{nautilusburn_ver}}
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpm-perlprov
49 BuildRequires:  rpmbuild(macros) >= 2.015
50 BuildRequires:  vte0-devel >= %{vte_ver}
51 %{!?with_nautilusburn:BuildConflicts:   nautilus-cd-burner-devel}
52 Requires:       gnome-desktop2 >= 2.30
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 This package provides .NET bindings for some of the GNOME desktop
57 libraries.
58
59 %description -l pl.UTF-8
60 Pakiet ten dostarcza wiązania niektórych bibliotek GNOME desktop dla
61 .NET.
62
63 %package devel
64 Summary:        Development files for GnomeDesktop# library
65 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GnomeDesktop#
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68 Requires:       dotnet-gnome-sharp-devel >= %{gnomesharp_ver}
69 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
70
71 %description devel
72 Development files for GnomeDesktop# library.
73
74 %description devel -l pl.UTF-8
75 Pliki programistyczne biblioteki GnomeDesktop#.
76
77 %package static
78 Summary:        Static GNOMEDesktop# libraries
79 Summary(pl.UTF-8):      Biblioteki statyczne GNOMEDesktop#
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static GNOMEDesktop# libraries.
85
86 %description static -l pl.UTF-8
87 Biblioteki statyczne GNOMEDesktop#.
88
89 %package -n dotnet-gnome-panel-sharp
90 Summary:        GnomePanel# - .NET binding for libpanelapplet library
91 Summary(pl.UTF-8):      GnomePanel# - wiązanie .NET do biblioteki libpanelapplet
92 Group:          Libraries
93 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
94 Requires:       gnome-panel-devel >= %{gnome_ver}
95 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
96
97 %description -n dotnet-gnome-panel-sharp
98 GnomePanel# - .NET binding for libpanelapplet library.
99
100 %description -n dotnet-gnome-panel-sharp -l pl.UTF-8
101 GnomePanel# - wiązanie .NET do biblioteki libpanelapplet.
102
103 %package -n dotnet-gnome-panel-sharp-devel
104 Summary:        Development files for GnomePanel# library
105 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GnomePanel#
106 Group:          Development/Libraries
107 Requires:       dotnet-gnome-panel-sharp = %{version}-%{release}
108 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
109
110 %description -n dotnet-gnome-panel-sharp-devel
111 Development files for GnomePanel# library.
112
113 %description -n dotnet-gnome-panel-sharp-devel -l pl.UTF-8
114 Pliki programistyczne biblioteki GnomePanel#.
115
116 %package -n dotnet-gnome-panel-sharp-static
117 Summary:        Static GnomePanel# glue library
118 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca GnomePanel#
119 Group:          Development/Libraries
120 Requires:       dotnet-gnome-panel-sharp-devel = %{version}-%{release}
121 Obsoletes:      dotnet-gnome-desktop-sharp-static < 2.26.0-7
122
123 %description -n dotnet-gnome-panel-sharp-static
124 Static GnomePanel# glue library.
125
126 %description -n dotnet-gnome-panel-sharp-static -l pl.UTF-8
127 Statyczna biblioteka sklejająca GnomePanel#.
128
129 %package -n dotnet-gnome-print-sharp
130 Summary:        GnomePrint# - .NET binding for libgnomeprint libraries
131 Summary(pl.UTF-8):      GnomePrint# - wiązanie .NET do bibliotek libgnomeprint
132 Group:          Libraries
133 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
134 Requires:       libgnomeprintui >= %{libgnomeprint_ver}
135 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
136
137 %description -n dotnet-gnome-print-sharp
138 GnomePrint# - .NET binding for libgnomeprint and libgnomeprintui
139 libraries.
140
141 %description -n dotnet-gnome-print-sharp -l pl.UTF-8
142 GnomePrint# - wiązanie .NET do bibliotek libgnomeprint oraz
143 libgnomeprintui.
144
145 %package -n dotnet-gnome-print-sharp-devel
146 Summary:        Development files for GnomePrint# library
147 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GnomePrint#
148 Group:          Development/Libraries
149 Requires:       dotnet-gnome-print-sharp = %{version}-%{release}
150 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
151
152 %description -n dotnet-gnome-print-sharp-devel
153 Development files for GnomePrint# library.
154
155 %description -n dotnet-gnome-print-sharp-devel -l pl.UTF-8
156 Pliki programistyczne biblioteki GnomePrint#.
157
158 %package -n dotnet-gtkhtml-sharp
159 Summary:        Gtkhtml# - .NET binding for Gtkhtml library
160 Summary(pl.UTF-8):      Gtkhtml# - wiązanie .NET do biblioteki Gtkhtml
161 Group:          Libraries
162 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
163 Requires:       gtkhtml3-devel >= %{gtkhtml_ver}
164 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
165
166 %description -n dotnet-gtkhtml-sharp
167 Gtkhtml# - .NET binding for Gtkhtml library.
168
169 %description -n dotnet-gtkhtml-sharp -l pl.UTF-8
170 Gtkhtml# - wiązanie .NET do biblioteki Gtkhtml.
171
172 %package -n dotnet-gtkhtml-sharp-devel
173 Summary:        Development files for Gtkhtml# library
174 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Gtkhtml#
175 Group:          Development/Libraries
176 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
177 Requires:       dotnet-gtkhtml-sharp = %{version}-%{release}
178
179 %description -n dotnet-gtkhtml-sharp-devel
180 Development files for Gtkhtml# library.
181
182 %description -n dotnet-gtkhtml-sharp-devel -l pl.UTF-8
183 Pliki programistyczne biblioteki Gtkhtml#.
184
185 %package -n dotnet-gtkhtml-sharp-static
186 Summary:        Static Gtkhtml# glue library
187 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca Gtkhtml#
188 Group:          Development/Libraries
189 Requires:       dotnet-gtkhtml-sharp-devel = %{version}-%{release}
190 Obsoletes:      dotnet-gnome-desktop-sharp-static < 2.26.0-7
191
192 %description -n dotnet-gtkhtml-sharp-static
193 Static Gtkhtml# glue library.
194
195 %description -n dotnet-gtkhtml-sharp-static -l pl.UTF-8
196 Statyczna biblioteka sklejająca Gtkhtml#.
197
198 %package -n dotnet-gtksourceview2-sharp
199 Summary:        GtkSourceView# - .NET binding for gtksourceview library
200 Summary(pl.UTF-8):      GtkSourceView# - wiązanie .NET do biblioteki gtksourceview
201 Group:          Libraries
202 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
203 Requires:       gtksourceview2 >= %{gtksourceview_ver}
204 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
205
206 %description -n dotnet-gtksourceview2-sharp
207 GtkSourceView# - .NET binding for gtksourceview library.
208
209 %description -n dotnet-gtksourceview2-sharp -l pl.UTF-8
210 GtkSourceView# - wiązanie .NET do biblioteki gtksourceview.
211
212 %package -n dotnet-gtksourceview2-sharp-devel
213 Summary:        Development files for GtkSourceView# library
214 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GtkSourceView#
215 Group:          Development/Libraries
216 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
217 Requires:       dotnet-gtksourceview2-sharp = %{version}-%{release}
218
219 %description -n dotnet-gtksourceview2-sharp-devel
220 Development files for GtkSourceView# library.
221
222 %description -n dotnet-gtksourceview2-sharp-devel -l pl.UTF-8
223 Pliki programistyczne biblioteki GtkSourceView#.
224
225 %package -n dotnet-gtksourceview2-sharp-static
226 Summary:        Static GtkSourceView# glue library
227 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca GtkSourceView#
228 Group:          Development/Libraries
229 Requires:       dotnet-gtksourceview2-sharp-devel = %{version}-%{release}
230 Obsoletes:      dotnet-gnome-desktop-sharp-static < 2.26.0-7
231
232 %description -n dotnet-gtksourceview2-sharp-static
233 Static GtkSourceView# glue library.
234
235 %description -n dotnet-gtksourceview2-sharp-static -l pl.UTF-8
236 Statyczna biblioteka sklejająca GtkSourceView#.
237
238 %package -n dotnet-nautilusburn-sharp
239 Summary:        NautilusBurn# - .NET binding for libnautilus-burn library
240 Summary(pl.UTF-8):      NautilusBurn# - wiązanie .NET do biblioteki libnautilus-burn
241 Group:          Libraries
242 Requires:       nautilus-cd-burner-libs >= %{nautilusburn_ver}
243 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
244
245 %description -n dotnet-nautilusburn-sharp
246 NautilusBurn# - .NET binding for libnautilus-burn library.
247
248 %description -n dotnet-nautilusburn-sharp -l pl.UTF-8
249 NautilusBurn# - wiązanie .NET do biblioteki libnautilus-burn.
250
251 %package -n dotnet-nautilusburn-sharp-devel
252 Summary:        Development files for NautilusBurn# library
253 Summary(pl.UTF-8):      Pliki programistyczne biblioteki NautilusBurn#
254 Group:          Development/Libraries
255 Requires:       dotnet-nautilusburn-sharp = %{version}-%{release}
256
257 %description -n dotnet-nautilusburn-sharp-devel
258 Development files for NautilusBurn# library.
259
260 %description -n dotnet-nautilusburn-sharp-devel -l pl.UTF-8
261 Pliki programistyczne biblioteki NautilusBurn#.
262
263 %package -n dotnet-nautilusburn-sharp-static
264 Summary:        Static NautilusBurn# glue library
265 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca NautilusBurn#
266 Group:          Development/Libraries
267 Requires:       dotnet-nautilusburn-sharp-devel = %{version}-%{release}
268 Obsoletes:      dotnet-gnome-desktop-sharp-static < 2.26.0-7
269
270 %description -n dotnet-nautilusburn-sharp-static
271 Static NautilusBurn# glue library.
272
273 %description -n dotnet-nautilusburn-sharp-static -l pl.UTF-8
274 Statyczna biblioteka sklejająca NautilusBurn#.
275
276 %package -n dotnet-rsvg2-sharp
277 Summary:        Rsvg# - .NET binding for librsvg library
278 Summary(pl.UTF-8):      Rsvg# - wiązanie .NET do biblioteki librsvg
279 Group:          Libraries
280 Requires:       librsvg >= %{librsvg_ver}
281 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
282
283 %description -n dotnet-rsvg2-sharp
284 Rsvg# - .NET binding for librsvg library.
285
286 %description -n dotnet-rsvg2-sharp -l pl.UTF-8
287 Rsvg# - wiązanie .NET do biblioteki librsvg.
288
289 %package -n dotnet-rsvg2-sharp-devel
290 Summary:        Development files for Rsvg# library
291 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Rsvg#
292 Group:          Development/Libraries
293 Requires:       dotnet-rsvg2-sharp = %{version}-%{release}
294
295 %description -n dotnet-rsvg2-sharp-devel
296 Development files for Rsvg# library.
297
298 %description -n dotnet-rsvg2-sharp-devel -l pl.UTF-8
299 Pliki programistyczne biblioteki Rsvg#.
300
301 %package -n dotnet-vte-sharp
302 Summary:        Vte# - .NET binding for libvte library
303 Summary(pl.UTF-8):      Vte# - wiązanie .NET do biblioteki libvte
304 Group:          Libraries
305 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
306 Requires:       vte0 >= %{vte_ver}
307 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
308
309 %description -n dotnet-vte-sharp
310 Vte# - .NET binding for libvte library.
311
312 %description -n dotnet-vte-sharp -l pl.UTF-8
313 Vte# - wiązanie .NET do biblioteki libvte.
314
315 %package -n dotnet-vte-sharp-devel
316 Summary:        Development files for Vte# library
317 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Vte#
318 Group:          Development/Libraries
319 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
320 Requires:       dotnet-vte-sharp = %{version}-%{release}
321
322 %description -n dotnet-vte-sharp-devel
323 Development files for Vte# library.
324
325 %description -n dotnet-vte-sharp-devel -l pl.UTF-8
326 Pliki programistyczne biblioteki Vte#.
327
328 %package -n dotnet-vte-sharp-static
329 Summary:        Static Vte# glue library
330 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca Vte#
331 Group:          Development/Libraries
332 Requires:       dotnet-vte-sharp-devel = %{version}-%{release}
333 Obsoletes:      dotnet-gnome-desktop-sharp-static < 2.26.0-7
334
335 %description -n dotnet-vte-sharp-static
336 Static Vte# glue library.
337
338 %description -n dotnet-vte-sharp-static -l pl.UTF-8
339 Statyczna biblioteka sklejająca Vte#.
340
341 %package -n dotnet-wnck-sharp
342 Summary:        Wnck# - .NET binding for libwnck library
343 Summary(pl.UTF-8):      Wnck# - wiązanie .NET do biblioteki libwnck
344 Group:          Libraries
345 Requires:       dotnet-gtk-sharp2 >= %{gtksharp_ver}
346 Requires:       libwnck2 >= %{gnome_ver}
347 Conflicts:      dotnet-gnome-desktop-sharp < 2.26.0-7
348
349 %description -n dotnet-wnck-sharp
350 Wnck# - .NET binding for libwnck library.
351
352 %description -n dotnet-wnck-sharp -l pl.UTF-8
353 Wnck# - wiązanie .NET do biblioteki libwnck.
354
355 %package -n dotnet-wnck-sharp-devel
356 Summary:        Development files for Wnck# library
357 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Wnck#
358 Group:          Development/Libraries
359 Requires:       dotnet-gtk-sharp2-devel >= %{gtksharp_ver}
360 Requires:       dotnet-wnck-sharp = %{version}-%{release}
361
362 %description -n dotnet-wnck-sharp-devel
363 Development files for Wnck# library.
364
365 %description -n dotnet-wnck-sharp-devel -l pl.UTF-8
366 Pliki programistyczne biblioteki Wnck#.
367
368 %package -n dotnet-wnck-sharp-static
369 Summary:        Static Wnck# glue library
370 Summary(pl.UTF-8):      Statyczna biblioteka sklejająca Wnck#
371 Group:          Development/Libraries
372 Requires:       dotnet-wnck-sharp-devel = %{version}-%{release}
373 Obsoletes:      dotnet-gnome-desktop-sharp-static < 2.26.0-7
374
375 %description -n dotnet-wnck-sharp-static
376 Static Wnck# glue library.
377
378 %description -n dotnet-wnck-sharp-static -l pl.UTF-8
379 Statyczna biblioteka sklejająca Wnck#.
380
381 %prep
382 %setup -q -n gnome-desktop-sharp-%{version}
383 %patch0 -p1
384 %patch1 -p1
385
386 %build
387 %{__libtoolize}
388 %{__aclocal}
389 %{__autoconf}
390 %{__autoheader}
391 %{__automake}
392 %configure
393 %{__make}
394
395 %install
396 rm -rf $RPM_BUILD_ROOT
397
398 %{__make} install \
399         DESTDIR=$RPM_BUILD_ROOT \
400         monodocdir=%{_libdir}/monodoc/sources
401
402 %clean
403 rm -rf $RPM_BUILD_ROOT
404
405 %post   -n dotnet-gnome-panel-sharp -p /sbin/ldconfig
406 %postun -n dotnet-gnome-panel-sharp -p /sbin/ldconfig
407
408 %post   -n dotnet-gtkhtml-sharp -p /sbin/ldconfig
409 %postun -n dotnet-gtkhtml-sharp -p /sbin/ldconfig
410
411 %post   -n dotnet-gtksourceview2-sharp -p /sbin/ldconfig
412 %postun -n dotnet-gtksourceview2-sharp -p /sbin/ldconfig
413
414 %post   -n dotnet-nautilusburn-sharp -p /sbin/ldconfig
415 %postun -n dotnet-nautilusburn-sharp -p /sbin/ldconfig
416
417 %post   -n dotnet-vte-sharp -p /sbin/ldconfig
418 %postun -n dotnet-vte-sharp -p /sbin/ldconfig
419
420 %post   -n dotnet-wnck-sharp -p /sbin/ldconfig
421 %postun -n dotnet-wnck-sharp -p /sbin/ldconfig
422
423 %files
424 %defattr(644,root,root,755)
425 %doc AUTHORS ChangeLog NEWS README
426 %{_prefix}/lib/mono/gac/gnomedesktop-sharp
427
428 %files devel
429 %defattr(644,root,root,755)
430 %{_prefix}/lib/mono/gnomedesktop-sharp-2.20
431 %{_datadir}/gnomedesktop-sharp
432 %{_pkgconfigdir}/gnome-desktop-sharp-2.0.pc
433
434 %if %{with gnomepanel}
435 %files -n dotnet-gnome-panel-sharp
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_libdir}/libgnomepanelsharpglue-2.so
438 %{_libdir}/libgnomepanelsharpglue-2.la
439 %{_prefix}/lib/mono/gac/gnome-panel-sharp
440
441 %files -n dotnet-gnome-panel-sharp-devel
442 %defattr(644,root,root,755)
443 %{_prefix}/lib/mono/gnome-panel-sharp-2.24
444 %{_pkgconfigdir}/gnome-panel-sharp-2.24.pc
445
446 %files -n dotnet-gnome-panel-sharp-static
447 %defattr(644,root,root,755)
448 %{_libdir}/libgnomepanelsharpglue-2.a
449 %endif
450
451 %files -n dotnet-gnome-print-sharp
452 %defattr(644,root,root,755)
453 %{_prefix}/lib/mono/gac/gnome-print-sharp
454
455 %files -n dotnet-gnome-print-sharp-devel
456 %defattr(644,root,root,755)
457 %{_prefix}/lib/mono/gnome-print-sharp-2.18
458 %{_datadir}/gnome-print-sharp
459 %{_pkgconfigdir}/gnome-print-sharp-2.18.pc
460
461 %files -n dotnet-gtkhtml-sharp
462 %defattr(644,root,root,755)
463 %attr(755,root,root) %{_libdir}/libgtkhtmlsharpglue-2.so
464 %{_libdir}/libgtkhtmlsharpglue-2.la
465 %{_prefix}/lib/mono/gac/gtkhtml-sharp
466
467 %files -n dotnet-gtkhtml-sharp-devel
468 %defattr(644,root,root,755)
469 %{_prefix}/lib/mono/gtkhtml-sharp-3.14
470 %{_datadir}/gtkhtml-sharp
471 %{_pkgconfigdir}/gtkhtml-sharp-3.14.pc
472
473 %files -n dotnet-gtkhtml-sharp-static
474 %defattr(644,root,root,755)
475 %{_libdir}/libgtkhtmlsharpglue-2.a
476
477 %files -n dotnet-gtksourceview2-sharp
478 %defattr(644,root,root,755)
479 %attr(755,root,root) %{_libdir}/libgtksourceview2sharpglue-2.so
480 %{_libdir}/libgtksourceview2sharpglue-2.la
481 %{_prefix}/lib/mono/gac/gtksourceview2-sharp
482
483 %files -n dotnet-gtksourceview2-sharp-devel
484 %defattr(644,root,root,755)
485 %{_prefix}/lib/mono/gtksourceview2-sharp-2.0
486 %{_datadir}/gtksourceview2-sharp
487 %{_pkgconfigdir}/gtksourceview2-sharp.pc
488
489 %files -n dotnet-gtksourceview2-sharp-static
490 %defattr(644,root,root,755)
491 %{_libdir}/libgtksourceview2sharpglue-2.a
492
493 %if %{with nautilusburn}
494 %files -n dotnet-nautilusburn-sharp
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{_libdir}/libnautilusburnsharpglue-2.so
497 %{_libdir}/libnautilusburnsharpglue-2.la
498 %{_prefix}/lib/mono/gac/nautilusburn-sharp
499
500 %files -n dotnet-nautilusburn-sharp-devel
501 %defattr(644,root,root,755)
502 %{_prefix}/lib/mono/nautilusburn-sharp
503 %{_datadir}/nautilusburn-sharp
504 %{_pkgconfigdir}/nautilusburn-sharp.pc
505
506 %files -n dotnet-nautilusburn-sharp-static
507 %defattr(644,root,root,755)
508 %{_libdir}/libnautilusburnsharpglue-2.a
509 %endif
510
511 %files -n dotnet-rsvg2-sharp
512 %defattr(644,root,root,755)
513 %{_prefix}/lib/mono/gac/rsvg2-sharp
514
515 %files -n dotnet-rsvg2-sharp-devel
516 %defattr(644,root,root,755)
517 %{_prefix}/lib/mono/rsvg2-sharp-2.0
518 %{_datadir}/rsvg2-sharp
519 %{_pkgconfigdir}/rsvg2-sharp-2.0.pc
520
521 %files -n dotnet-vte-sharp
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/libvtesharpglue-2.so
524 %{_libdir}/libvtesharpglue-2.la
525 %{_prefix}/lib/mono/gac/vte-sharp
526
527 %files -n dotnet-vte-sharp-devel
528 %defattr(644,root,root,755)
529 %{_prefix}/lib/mono/vte-sharp-0.16
530 %{_datadir}/vte-sharp
531 %{_pkgconfigdir}/vte-sharp-0.16.pc
532
533 %files -n dotnet-vte-sharp-static
534 %defattr(644,root,root,755)
535 %{_libdir}/libvtesharpglue-2.a
536
537 %files -n dotnet-wnck-sharp
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_libdir}/libwncksharpglue-2.so
540 %{_libdir}/libwncksharpglue-2.la
541 %{_prefix}/lib/mono/gac/wnck-sharp
542
543 %files -n dotnet-wnck-sharp-devel
544 %defattr(644,root,root,755)
545 %{_prefix}/lib/mono/wnck-sharp-2.20
546 %{_datadir}/wnck-sharp
547 %{_pkgconfigdir}/wnck-sharp-1.0.pc
548
549 %files -n dotnet-wnck-sharp-static
550 %defattr(644,root,root,755)
551 %{_libdir}/libwncksharpglue-2.a
This page took 0.721399 seconds and 3 git commands to generate.