]> git.pld-linux.org Git - packages/dotnet-gdata-sharp.git/commitdiff
- updated to 2.2.0.0 auto/th/dotnet-gdata-sharp-2.2.0.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 15 Mar 2014 17:16:15 +0000 (18:16 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 15 Mar 2014 17:16:15 +0000 (18:16 +0100)
- added udpate patch (update Makefile wrt. Newtonsoft.Json usage)

dotnet-gdata-sharp-update.patch [new file with mode: 0644]
dotnet-gdata-sharp.spec

diff --git a/dotnet-gdata-sharp-update.patch b/dotnet-gdata-sharp-update.patch
new file mode 100644 (file)
index 0000000..948783d
--- /dev/null
@@ -0,0 +1,39 @@
+--- libgoogle-data-mono-2.2.0.0/Makefile.orig  2012-04-20 23:46:55.000000000 +0200
++++ libgoogle-data-mono-2.2.0.0/Makefile       2014-03-15 17:05:11.149860613 +0100
+@@ -30,10 +30,12 @@
+   Google.GData.YouTube.dll \\r
+   Google.GData.Blogger.dll \\r
+   Google.GData.Analytics.dll\r
++#  Google.GData.ContentForShopping.dll \\r
++#  Google.GData.WebmasterTools.dll\r
\r
+ UNINSTALLLIBS = $(basename $(ALLLIBS))\r
\r
+-FRAMEWORK_REFS = -r:System.dll -r:System.Xml.dll -r:System.Configuration.dll\r
++FRAMEWORK_REFS = -r:System.dll -r:System.Xml.dll -r:System.Configuration.dll $(shell pkg-config --libs newtonsoft-json)\r
\r
+ PKGCONFIG_FILES = $(patsubst %.pc.in,%.pc,$(wildcard misc/*.pc.in))\r
\r
+@@ -65,6 +67,8 @@
+ youtube_sources = $(wildcard src/youtube/*.cs) $(wildcard version/*.cs)\r
+ blogger_sources = $(wildcard src/blogger/*.cs) $(wildcard version/*.cs)\r
+ analytics_sources = $(wildcard src/analytics/*.cs) $(wildcard version/*.cs)\r
++contentforshopping_sources = $(wildcard src/contentforshopping/*.cs) $(wildcard version/*.cs)\r
++webmastertools_sources = $(wildcard src/webmastertools/*.cs) $(wildcard version/*.cs)\r
+ test_sources = $(wildcard src/unittests/*.cs) $(wildcard src/unittests/gapps/*.cs)\\r
+          $(wildcard src/unittests/spreadsheets/*.cs) $(wildcard src/unittests/youtube/*.cs)  $(wildcard src/version/*cs)\\r
+          $(wildcard src/unittests/core/*.cs)  $(wildcard src/unittests/picasa/*.cs)\r
+@@ -105,6 +109,13 @@
+ Google.GData.Analytics.dll: $(CORELIBS) $(analytics_sources) src/analytics/analytics.sn\r
+       $(CSC) $(DEFINES) -target:library -out:$@ $(COREREFS) $(analytics_sources) -keyfile:src/analytics/analytics.sn\r
\r
++Google.GData.ContentForShopping.dll: $(CORELIBS) $(contentforshopping_sources) \r
++      $(CSC) $(DEFINES) -target:library -out:$@ $(COREREFS) $(contentforshopping_sources)\r
++# -keyfile:src/contentforshopping/???.sn\r
++\r
++Google.GData.WebmasterTools.dll: $(CORELIBS) $(webmastertools_sources) \r
++      $(CSC) $(DEFINES) -target:library -out:$@ $(COREREFS) $(webmastertools_sources)\r
++# -keyfile:src/webmastertools/???.sn\r
\r
+ clean:\r
+       -rm -f *.sn *.dll *exe $(PKGCONFIG_FILES)\r
index 19d42f3acce49620aa9dd2e7e18232df549832aa..4cbe1d56a11e76b9fb74474b6beddae0af0d767c 100644 (file)
@@ -1,40 +1,59 @@
 #
 %include       /usr/lib/rpm/macros.mono
 #
-Summary:       gdata-sharp is a C# library that makes it easy to access data through Google Data APIs
+Summary:       gdata-sharp - C# library that makes it easy to access data through Google Data APIs
+Summary(pl.UTF-8):     gdata-sharp - biblioteka C# ułatwiająca dostęp do danych poprzez API Google Data
 Name:          dotnet-gdata-sharp
-Version:       1.7.0.1
+Version:       2.2.0.0
 Release:       1
 License:       Apache v2.0
-Group:         Development/Libraries
+Group:         Libraries
+#Source0Download: https://code.google.com/p/google-gdata/downloads/list
 Source0:       http://google-gdata.googlecode.com/files/libgoogle-data-mono-%{version}.tar.gz
-# Source0-md5: ba4f57eb5ed597d2e5d16f5deb69d411
+# Source0-md5: d748a5ae2b349b9832e303e95c18ce79
+Patch0:                %{name}-update.patch
 URL:           http://code.google.com/p/google-gdata/
 BuildRequires: dos2unix
+BuildRequires: dotnet-newtonsoft-json-devel
 BuildRequires: mono-csharp
 BuildRequires: mono-devel
+BuildRequires: rpmbuild(monoautodeps)
+Requires:      dotnet-newtonsoft-json
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 The GData .NET Client Library provides a library and source code that
 make it easy to access data through Google Data APIs.
 
+%description -l pl.UTF-8
+Biblioteka kliencka .NET GData ma na celu ułatwienie dostępu do danych
+poprzez API Google Data.
+
 %package devel
 Summary:       Files required for compilation using gdata-sharp
+Summary(pl.UTF-8):     Pliki wymagane do kompilacji z użyciem gdata-sharp
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      dotnet-newtonsoft-json-devel
 
 %description devel
 Files required for compilation using gdata-sharp.
 
+%description devel -l pl.UTF-8
+Pliki wymagane do kompilacji z użyciem gdata-sharp.
+
 %prep
 %setup -q -n libgoogle-data-mono-%{version}
+%patch0 -p1
 dos2unix misc/*.pc.in
 
 %build
 %{__make} \
        PREFIX=%{_prefix}
 
+# alternative (but with no functional install target)
+#xbuild "src/Google Data API SDK.sln"
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
@@ -52,10 +71,42 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%{_prefix}/lib/mono/gac/Google.GData.*
+%{_prefix}/lib/mono/gac/Google.GData.AccessControl
+%{_prefix}/lib/mono/gac/Google.GData.Analytics
+%{_prefix}/lib/mono/gac/Google.GData.Apps
+%{_prefix}/lib/mono/gac/Google.GData.Blogger
+%{_prefix}/lib/mono/gac/Google.GData.Calendar
+%{_prefix}/lib/mono/gac/Google.GData.Client
+%{_prefix}/lib/mono/gac/Google.GData.Contacts
+%{_prefix}/lib/mono/gac/Google.GData.Documents
+%{_prefix}/lib/mono/gac/Google.GData.Extensions
+%{_prefix}/lib/mono/gac/Google.GData.Photos
+%{_prefix}/lib/mono/gac/Google.GData.Spreadsheets
+%{_prefix}/lib/mono/gac/Google.GData.YouTube
 
 %files devel
 %defattr(644,root,root,755)
 %dir %{_prefix}/lib/mono/GData-Sharp
-%{_prefix}/lib/mono/GData-Sharp/*.dll
-%{_pkgconfigdir}/gdata-sharp-*.pc
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.AccessControl.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Analytics.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Apps.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Blogger.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Calendar.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Client.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Contacts.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Documents.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Extensions.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Photos.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.Spreadsheets.dll
+%{_prefix}/lib/mono/GData-Sharp/Google.GData.YouTube.dll
+%{_pkgconfigdir}/gdata-sharp-acl.pc
+%{_pkgconfigdir}/gdata-sharp-analytics.pc
+%{_pkgconfigdir}/gdata-sharp-apps.pc
+%{_pkgconfigdir}/gdata-sharp-blogger.pc
+%{_pkgconfigdir}/gdata-sharp-calendar.pc
+%{_pkgconfigdir}/gdata-sharp-contacts.pc
+%{_pkgconfigdir}/gdata-sharp-core.pc
+%{_pkgconfigdir}/gdata-sharp-documents.pc
+%{_pkgconfigdir}/gdata-sharp-photos.pc
+%{_pkgconfigdir}/gdata-sharp-spreadsheets.pc
+%{_pkgconfigdir}/gdata-sharp-youtube.pc
This page took 0.136499 seconds and 4 git commands to generate.