]> git.pld-linux.org Git - packages/dosemu.git/commitdiff
- up to 1.1.5 p5
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 19 Jul 2003 19:00:02 +0000 (19:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated man-pages,make-new patches, removed obsolete gcc33 patch
- added fix patch (compilation error if no X_GRAPHICS)

Changed files:
    dosemu-fix.patch -> 1.1
    dosemu-gcc33.patch -> 1.2
    dosemu-make-new.patch -> 1.6
    dosemu-man-pages.patch -> 1.6
    dosemu.spec -> 1.92

dosemu-fix.patch [new file with mode: 0644]
dosemu-gcc33.patch [deleted file]
dosemu-make-new.patch
dosemu-man-pages.patch
dosemu.spec

diff --git a/dosemu-fix.patch b/dosemu-fix.patch
new file mode 100644 (file)
index 0000000..f1b73df
--- /dev/null
@@ -0,0 +1,18 @@
+--- dosemu-1.1.5/src/base/bios/int10.c.orig    2003-07-19 17:21:55.000000000 +0200
++++ dosemu-1.1.5/src/base/bios/int10.c 2003-07-19 17:27:55.000000000 +0200
+@@ -723,6 +723,7 @@
+ /* helpers for font processing - eric@coli.uni-sb.de  11/2002 */
+ /* only for TEXT mode: Otherwise, int 0x43 is used...         */
++#ifdef X_GRAPHICS
+ static void vga_RAM_to_RAM(unsigned height, unsigned char chr, unsigned count,
+                            unsigned seg, unsigned ofs, int bank)
+ {
+@@ -767,6 +768,7 @@
+   }
+   vga_RAM_to_RAM(height,0,256,seg,ofs,bank);
+ }
++#endif
+ /******************************************************************/
diff --git a/dosemu-gcc33.patch b/dosemu-gcc33.patch
deleted file mode 100644 (file)
index 1e9f8b8..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- dosemu-1.1.4/configure.ac.orig     2003-05-18 01:17:04.000000000 +0200
-+++ dosemu-1.1.4/configure.ac  2003-05-18 01:20:19.000000000 +0200
-@@ -138,7 +138,7 @@
-    AC_MSG_WARN( )
-    ELF="ELF=1"
-  else
--   if grep __ELF__ `$CC -v 2>&1|head -n1|cut -d' ' -f4` /dev/null 1>/dev/null 2>&1; then 
-+   if grep '__ELF__\|elf_' `$CC -v 2>&1|head -n1|cut -d' ' -f4` /dev/null 1>/dev/null 2>&1; then 
-     ELF="ELF=1"
-    else
-      if test "$CONFIG_HOST" = "linux"; then
index 6d599cb1cbf3de1b10ce1e6f56cc01942da4b145..4ac98b0133217368dc8c03e67db199168ec600d6 100644 (file)
@@ -1,11 +1,11 @@
---- dosemu-1.1.4/configure.ac.orig     Fri Mar 28 10:32:29 2003
-+++ dosemu-1.1.4/configure.ac  Fri Mar 28 10:35:43 2003
+--- dosemu-1.1.5/configure.ac.orig     Fri Mar 28 10:32:29 2003
++++ dosemu-1.1.5/configure.ac  Fri Mar 28 10:35:43 2003
 @@ -421,15 +421,15 @@
  AC_SUBST(INCDIR)
  
  CFLAGS="-Wall -Wstrict-prototypes -Wmissing-declarations -Wnested-externs"
 +OPT="$OPTFLAGS"
- if test "$dodebug" = "yes"; then
+ if test "$dodebug" = "yes" -o "$debug" = "yes"; then
    CFLAGS="$CFLAGS -gstabs+"
    AC_DEFINE(_DEBUG)
 -  OPT="-O"
index ffc79ca981c9f2462b6e02288d28a4bd36bd02bc..e4597b8f97a27e85dc6b3277bafd6cc1ec4ba8cf 100644 (file)
@@ -4,13 +4,13 @@ diff -Nur dosemu-1.1.4/man.orig/dosdebug.1 dosemu-1.1.4/man/dosdebug.1
 @@ -1 +1 @@
 -.so man1/dosemu.bin.1
 +.so dos.1
-diff -Nur dosemu-1.1.4/man.orig/dosemu.bin.1 dosemu-1.1.4/man/dosemu.bin.1
---- dosemu-1.1.4/man.orig/dosemu.bin.1 2003-05-18 11:53:55.000000000 +0200
-+++ dosemu-1.1.4/man/dosemu.bin.1      2003-05-18 12:02:15.000000000 +0200
+diff -Nur dosemu-1.1.5/man.orig/dosemu.bin.1 dosemu-1.1.5/man/dosemu.bin.1
+--- dosemu-1.1.5/man.orig/dosemu.bin.1 2003-05-18 11:53:55.000000000 +0200
++++ dosemu-1.1.5/man/dosemu.bin.1      2003-05-18 12:02:15.000000000 +0200
 @@ -1,9 +1,9 @@
  .\" -*- nroff -*-  (This is for Emacs)
--.TH DOSEMU.BIN 1 "Jan, 2003" "Version 1.1.4.1" "DOS Emulation"
-+.TH DOS 1 "Jan, 2003" "Version 1.1.4.1" "DOS Emulation"
+-.TH DOSEMU.BIN 1 "Jun, 2003" "Version 1.1.5" "DOS Emulation"
++.TH DOS 1 "Jun, 2003" "Version 1.1.5" "DOS Emulation"
  .SH NAME
 -dosemu.bin, dosdebug \- run DOS and DOS programs under Linux
 +dos, xdos, dosdebug \- run DOS and DOS programs under Linux
@@ -38,16 +38,16 @@ diff -Nur dosemu-1.1.4/man.orig/dosemu.bin.1 dosemu-1.1.4/man/dosemu.bin.1
  .SH FILES
  .PD 0
  .TP
--.I /usr/local/bin/dosemu.bin
+-.I dosemu.bin
 +.I /usr/bin/dos
 +or
 +.I /usr/X11R6/bin/dos
  The binary
  .TP
--.I /usr/local/bin/dosemu
+-.I dosemu
 -The wrapper script, it is recommended not to invoke dosemu.bin directly.
 -.TP
--.I /usr/local/bin/xdosemu
+-.I xdosemu
 +.I /usr/X11R6/bin/xdos
  Same, but invoking DOS in an X window.
  .TP
index fc131c120c7d627c5f18f72a8f3afecfe495a10d..e94d1cfa09f2dd2f4864f65f97199483adec6b77 100644 (file)
@@ -10,17 +10,17 @@ Summary(pl):        Emulator DOSa
 Summary(pt_BR):        Emulador DOS
 Summary(tr):   DOS öykünümcüsü
 Name:          dosemu
-%define                ver 1.1.4
-%define        subver 15
+%define                ver 1.1.5
+%define        subver 5
 Version:       %{ver}.%{subver}
 # Please don't bump to 1 until dosemu-1.2
-Release:       0.3
+Release:       0.1
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://dl.sourceforge.net/dosemu/%{name}-%{ver}.tgz
-# Source0-md5: be632c6e5edd3388d9d6d2c8dba7dc10
+# Source0-md5: 15b37a5e45bbeaa31bb19269327707ff
 Source1:       http://dosemu.sourceforge.net/testing/patchset-%{version}.tgz
-# Source1-md5: 21b6d8cf3797333e6be0ddf8954e58e1
+# Source1-md5: ea5b334e65bddf8a2e88d8cbaf3ad569
 #Source2:      %{name}-sys.tar.gz
 Source3:       %{name}-PRZECZYTAJ_TO
 Source4:       %{name}-README.PLD
@@ -32,8 +32,8 @@ Patch1:               %{name}-make-new.patch
 Patch2:                %{name}-%{name}_conf.patch
 Patch3:                %{name}-doSgmlTools.patch
 Patch4:                %{name}-makehtml.patch
-Patch5:                %{name}-gcc33.patch
-#Patch5:               %{name}-nox.patch
+Patch5:                %{name}-fix.patch
+#Patch5:               %{name}-gcc33.patch
 URL:           http://www.dosemu.org/
 BuildRequires: XFree86-devel
 %{?_with_static:BuildRequires: XFree86-static}
@@ -231,7 +231,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc QuickStart COPYING ChangeLog* doc/*.html PRZECZYTAJ_TO README.PLD
+%doc QuickStart COPYING ChangeLog* doc/* README.PLD
+%lang(pl) %doc PRZECZYTAJ_TO
 %dir %{_dosemudir}
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dosemu.conf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dosemu.users
@@ -250,7 +251,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n xdosemu
 %defattr(644,root,root,755)
-%doc QuickStart COPYING ChangeLog* doc/*.html PRZECZYTAJ_TO README.PLD
+%doc QuickStart COPYING ChangeLog* doc/* README.PLD
+%lang(pl) %doc PRZECZYTAJ_TO
 %dir %{_dosemudir}
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dosemu.conf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dosemu.users
This page took 0.203469 seconds and 4 git commands to generate.