]> git.pld-linux.org Git - packages/dosemu.git/commitdiff
- standarized dosnet subpackage (kernel-net-dosnet now)
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 25 Dec 2001 13:33:14 +0000 (13:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- justroot, security and updated make-new patches are back
- changed dosemu_conf patch: disabled raw keyboard and console/graphics video
  (default configuration should be safe; these options are not)
- fixed conditional BuildRequires
- NFY (TODO: separate dosemu version without XFree86)

Changed files:
    dosemu-dosemu_conf.patch -> 1.2
    dosemu-make-new.patch -> 1.2
    dosemu.spec -> 1.34

dosemu-dosemu_conf.patch
dosemu-make-new.patch
dosemu.spec

index 5ce4bac9aa8841081a01579ce83d1b37fb50c221..3ba3946e53ce9be5082b19b09bd90c58d1b3ee0e 100644 (file)
@@ -15,7 +15,7 @@
  
 -$_rawkeyboard = (0)   # bypass normal keyboard input, maybe dangerous
 -$_layout = "auto"     # one of: finnish(-latin1), de(-latin1), be, it, us
-+$_rawkeyboard = (1)   # bypass normal keyboard input, maybe dangerous
++$_rawkeyboard = (0)   # bypass normal keyboard input, maybe dangerous
 +$_layout = "us"               # one of: finnish(-latin1), de(-latin1), be, it, us
                        # uk, dk(-latin1), keyb-no, no-latin1, dvorak, po
                        # sg(-latin1), fr(-latin1), sf(-latin1), es(-latin1)
@@ -26,8 +26,8 @@
  $_video = "vga"               # one of: plainvga, vga, ega, mda, mga, cga
 -$_console = (0)               # use 'console' video
 -$_graphics = (0)      # use the cards BIOS to set graphics
-+$_console = (1)               # use 'console' video
-+$_graphics = (1)      # use the cards BIOS to set graphics
++$_console = (0)               # use 'console' video
++$_graphics = (0)      # use the cards BIOS to set graphics
  $_videoportaccess = (1)       # allow videoportaccess when 'graphics' enabled
  $_vbios_seg = (0xc000)        # set the address of your VBIOS (e.g. 0xe000)
  $_vbios_size = (0x10000)# set the size of your BIOS (e.g. 0x8000)
index 4a84c4579262d7d5212701d51fa9640a9b59ebf5..da33a10d2c2378ad4c5cf77a923301563b731aa8 100644 (file)
@@ -1,22 +1,13 @@
-diff -ur dosemu-1.0.1.orig/base-configure dosemu-1.0.1/base-configure
---- dosemu-1.0.1.orig/base-configure   Sun Jun 18 16:34:26 2000
-+++ dosemu-1.0.1/base-configure        Thu Aug 17 09:56:30 2000
-@@ -72,7 +72,7 @@
- includedir='${prefix}/include'
- oldincludedir='/usr/include'
- infodir='${prefix}/info'
--mandir='${prefix}/man'
-+mandir='${prefix}/share/man'
- # Initialize some other variables.
- subdirs=
+diff -ur dosemu-1.0.2.orig/base-configure.in dosemu-1.0.2/base-configure.in
+--- dosemu-1.0.2.orig/base-configure.in        Sun Jun 18 16:34:26 2000
++++ dosemu-1.0.2/base-configure.in     Thu Aug 17 09:56:30 2000
 @@ -3855,19 +3855,8 @@
    OPT="$OPT -fomit-frame-pointer"  # never omit the frame pointer when debugging!
  fi
  
 -# -m486 is usually in the specs for the compiler
 -case "$host_cpu" in
--  i[456]86)
+-  i[[456]]86)
 -    OPT="$OPT -m486 -malign-loops=2 -malign-jumps=2 -malign-functions=2"
 -    ;;
 -  i386)
@@ -27,11 +18,10 @@ diff -ur dosemu-1.0.1.orig/base-configure dosemu-1.0.1/base-configure
 -esac
  
 -OPT="$OPT -MD" # this should give painless dependencies
-+OPT="$RPM_OPT_FLAGS -MD" # this should give painless dependencies
++OPT="$OPTFLAGS -MD" # this should give painless dependencies
  
  # OPT=-fno-inline
  if test "$CONFIG_HOST" = "linux"; then
-Only in dosemu-1.0.1: base-configure~
 diff -ur dosemu-1.0.1.orig/man/Makefile dosemu-1.0.1/man/Makefile
 --- dosemu-1.0.1.orig/man/Makefile     Sun Mar  5 13:57:36 2000
 +++ dosemu-1.0.1/man/Makefile  Thu Aug 17 09:57:21 2000
@@ -43,20 +33,18 @@ diff -ur dosemu-1.0.1.orig/man/Makefile dosemu-1.0.1/man/Makefile
 +      install *dos*.1 mkfatimage*.1 $(INSTROOT)/usr/share/man/man1
  
  clean realclean:
-Only in dosemu-1.0.1/man: Makefile~
-diff -ur dosemu-1.0.1.orig/src/arch/linux/Makefile.main dosemu-1.0.1/src/arch/linux/Makefile.main
---- dosemu-1.0.1.orig/src/arch/linux/Makefile.main     Tue Mar 28 01:22:01 2000
-+++ dosemu-1.0.1/src/arch/linux/Makefile.main  Thu Aug 17 10:02:53 2000
+diff -ur dosemu-1.0.2.orig/src/arch/linux/Makefile.main dosemu-1.0.2/src/arch/linux/Makefile.main
+--- dosemu-1.0.2.orig/src/arch/linux/Makefile.main     Tue Mar 28 01:22:01 2000
++++ dosemu-1.0.2/src/arch/linux/Makefile.main  Thu Aug 17 10:02:53 2000
 @@ -324,9 +324,9 @@
          install -m 0744 ../etc/keymap/* $(INSTROOT)/var/lib/dosemu/keymap; \
        fi
        @if [ -f $(INSTROOT)/lib/libemu ]; then rm -f $(INSTROOT)/lib/libemu ; fi
--      @install -c -o root -m 04755 $(BINPATH)/bin/dos $(INSTROOT)/usr/bin
-+      @install -c $(BINPATH)/bin/dos $(INSTROOT)/usr/bin
+-      @install -c -o root -m 0755 $(BINPATH)/bin/$(DOSBIN) $(INSTROOT)/usr/bin
++      @install -c $(BINPATH)/bin/$(DOSBIN) $(INSTROOT)/usr/bin
  ifdef  USE_MHPDBG
 -      @install -c -o root -m 0755 $(BINPATH)/bin/dosdebug $(INSTROOT)/usr/bin
 +      @install -c $(BINPATH)/bin/dosdebug $(INSTROOT)/usr/bin
  endif
  ifndef ELF
        @install -m 0644 $(LIBDOSEMU) $(INSTROOT)/usr/lib/libdosemu-$(THISVERSION)
-Only in dosemu-1.0.1/src/arch/linux: Makefile.main~
index aa184297204d308ea884d54d71c1b5edbab5d369..a80daf3d0db42e08d8cc5282f116d50df0c957af 100644 (file)
@@ -1,7 +1,15 @@
 # Conditional build:
 # --with static        - links statically
+
 %define         _kernel_ver %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null| cut -d'"' -f2)
-#%define         _kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
+%define         _kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
+%define                _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
+%if %{_kernel24}
+%define                _moddir         /lib/modules/%{_kernel_ver}/misc
+%else
+%define                _moddir         /lib/modules/%{_kernel_ver}/net
+%endif
+
 Summary:       A DOS emulator
 Summary(de):   DOS-Emulator
 Summary(fr):   Emulateur DOS
@@ -25,19 +33,24 @@ Source7:    egapl.exe
 Source8:       shsucdx.exe
 Patch0:                %{name}-dosemu_conf.patch
 Patch1:                %{name}-1.0.2-man-pages.patch
+Patch2:                %{name}-0.98.1-justroot.patch
+Patch3:                %{name}-0.98.1-security.patch
+Patch4:                %{name}-make-new.patch
 URL:           http://www.dosemu.org/
+BuildRequires: XFree86-devel
 BuildRequires: bin86
-BuildRequires: unzip
 BuildRequires: bison
 BuildRequires: flex
-BuildRequires: glibc-static
-BuildRequires: XFree86-static
-BuildRequires: slang-static
-Conflicts:     mtools < 3.6
+BuildRequires: slang-devel
+BuildRequires: unzip
+%{?_with_static:BuildRequires: glibc-static}
+%{?_with_static:BuildRequires: XFree86-static}
+%{?_with_static:BuildRequires: slang-static}
 Obsoletes:     xdosemu
 Exclusivearch: %{ix86}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Conflicts:     kernel < 2.0.28
+Conflicts:     mtools < 3.6
 
 %description
 Dosemu is a DOS emulator. Once you've installed dosemu, start the DOS
@@ -65,38 +78,44 @@ Essa 
 sessões X Window. Oferece suporte para gráficos VGA bem como suporte
 para mouse.
 
-%package dosnet
+%package -n kernel-net-dosnet
 Summary:       kernel module dosnet.o
 Summary(pl):   Modu³ dosnet.o do kernela
+Release:       %{release}@%{_kernel_ver_str}
 Group:         Applications/Emulators
 Group(de):     Applikationen/Emulators
 Group(pl):     Aplikacje/Emulatory
 Requires:      %{name} = %{version}
+Obsoletes:     dosnet
 Prereq:                /sbin/depmod
 
-%description dosnet
-Kernel module for dosnet (vnet).  Dosnet lets you establish TCP/IP
-connection beetween dosemu session and Linux kernel.  Read README
+%description -n kernel-net-dosnet
+Kernel module for dosnet (vnet). Dosnet lets you establish TCP/IP
+connection beetween dosemu session and Linux kernel. Read README
 for dosemu for more information.
 
-%description -l pl dosnet
-Modu³ dosnet.o dla kernela.  Modu³ ten pozwala ³±czyæ siê programom
-DOSowym wykorzystuj±cym TCP/IP z Linuksem.  Przydatny miêdzy innymi
-przy pisaniu programów sieciowych dla DOSa.  Rzeteln± informacjê na
+%description -n kernel-net-dosnet -l pl
+Modu³ dosnet.o dla kernela. Modu³ ten pozwala ³±czyæ siê programom
+DOSowym wykorzystuj±cym TCP/IP z Linuksem. Przydatny miêdzy innymi
+przy pisaniu programów sieciowych dla DOSa. Rzeteln± informacjê na
 temat dosnet mo¿esz znale¼æ w README do dosemu.   
 
 %prep
 %setup -q -a1 -a2
 %patch0 -p0
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 rm -rf freedos
 mkdir freedos
-unzip -L -o %{SOURCE3} -d freedos
+unzip -q -L -o %{SOURCE3} -d freedos
 
 %build
-cp base-configure.in configure.in
+cp -f base-configure.in configure.in
 autoconf
+OPTFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"; export OPTFLAGS
 %configure \
 %{?_with_static:--enable-linkstatic} \
        --enable-new-intcode \
@@ -113,17 +132,20 @@ mv -f man/dosemu.bin.1 man/dos.1
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir},%{_mandir}/man1,%{_mandir}/pl/man1,%{_pixmapsdir}}
 install -d $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel}
-install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/net
 
 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dos
 install bin/dosdebug $RPM_BUILD_ROOT%{_bindir}/dosdebug
 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage,mkfatimage16} $RPM_BUILD_ROOT%{_bindir}
+ln -sf dos $RPM_BUILD_ROOT%{_bindir}/xdos
+
 install etc/dosemu.xpm $RPM_BUILD_ROOT%{_prefix}/X11R6/share/pixmaps
 install etc/dosemu.users.secure $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
+
 install man/{dos.1,dosdebug.1,xdos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
 install pl/man1/{dos.1,dosdebug.1,xdos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
+
 install %{SOURCE4} $RPM_BUILD_ROOT%{_dosemudir}/bootdir/autoexec.bat
 install %{SOURCE5} $RPM_BUILD_ROOT%{_dosemudir}/bootdir/config.sys
 install %{SOURCE6} $RPM_BUILD_ROOT%{_dosemudir}/bootdir/keybpl.exe
@@ -131,34 +153,29 @@ install %{SOURCE7} $RPM_BUILD_ROOT%{_dosemudir}/bootdir/egapl.exe
 install %{SOURCE8} $RPM_BUILD_ROOT%{_dosemudir}/bootdir/shsucdx.exe
 install src/plugin/commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
 install dosemu/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
-install src/dosext/net/v-net/dosnet.o $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/net
 install freedos/bin/kernel.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir
 install freedos/doc/fdkernel/* $RPM_BUILD_ROOT%{_dosemudir}/bootdir/freedos/doc/fdkernel
 ln -sf dosemu/comcom.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/command.com
-ln -sf dos $RPM_BUILD_ROOT%{_bindir}/xdos
+
+install -d $RPM_BUILD_ROOT%{_moddir}
+install src/dosext/net/v-net/dosnet.o $RPM_BUILD_ROOT%{_moddir}
 
 # Take out irritating ^H's from the documentation
 for i in `ls --color=no doc/` ; do cat doc/$i > $i ; cat $i | perl -p -e 's/.\b//g' > doc/$i ; done
 
 rm -f doc/{configuration,dosemu.lsm}
 
-#mv -f $RPM_BUILD_ROOT/usr/X11R6/lib/X11/fonts/misc \
-#      $RPM_BUILD_ROOT%{_fontsdir}
-
-
 gzip -9nf QuickStart COPYING ChangeLog* doc/*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-
-%post dosnet
+%post  -n kernel-net-dosnet
 depmod -a
 
-%postun dosnet
+%postun        -n kernel-net-dosnet
 depmod -a
-
-    
 %files
 %defattr(644,root,root,755)
 %doc *.gz doc/*
@@ -194,6 +211,6 @@ depmod -a
 %lang(pl) %{_mandir}/pl/man1/*
 %{_pixmapsdir}/dosemu.xpm
 
-%files dosnet
+%files -n kernel-net-dosnet
 %defattr(644,root,root,755)
-/lib/modules/%{_kernel_ver}/net/dosnet.o
+%{_moddir}/dosnet.o
This page took 1.104422 seconds and 4 git commands to generate.