]> git.pld-linux.org Git - packages/dosemu.git/blob - dosemu.spec
- updated to 1.3.4
[packages/dosemu.git] / dosemu.spec
1 # NOTE: if /dev/shm is mounted, it cannot be mounted with noexec
2 #
3 # Conditional build:
4 %bcond_with     static          # link statically
5 %bcond_with     AC
6 %bcond_without  x               # X support
7 #
8 Summary:        A DOS emulator
9 Summary(de):    DOS-Emulator
10 Summary(es):    Emulador DOS
11 Summary(fr):    Emulateur DOS
12 Summary(pl):    Emulator DOS-a
13 Summary(pt_BR): Emulador DOS
14 Summary(tr):    DOS öykünümcüsü
15 Name:           dosemu
16 Version:        1.3.4
17 Release:        1
18 License:        GPL v2
19 Group:          Applications/Emulators
20 Source0:        http://dl.sourceforge.net/dosemu/%{name}-%{version}.tgz
21 # Source0-md5:  4fbfdc50ea86d860dd9cea59ea7f4b47
22 #Source2:       %{name}-sys.tar.gz
23 Source3:        %{name}-PRZECZYTAJ_TO
24 Source4:        %{name}-README.PLD
25 Source5:        %{name}.desktop
26 Source6:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
27 # Source6-md5:  7a8abf5c656e6b99bdd03a4783751895
28 Patch0:         %{name}-man-pages.patch
29 Patch1:         %{name}-make-new.patch
30 Patch2:         %{name}-%{name}_conf.patch
31 Patch3:         %{name}-doSgmlTools.patch
32 Patch4:         %{name}-makehtml.patch
33 URL:            http://www.dosemu.org/
34 BuildRequires:  SDL-devel
35 %if %{with x}
36 %if !%{with AC}
37 BuildRequires:  xorg-lib-libX11-devel
38 %{?with_static:BuildRequires:   xorg-lib-libX11-static}
39 %endif
40 %if %{with AC}
41 BuildRequires:  X11-devel
42 %{?with_static:BuildRequires:   X11-static}
43 %endif
44 %endif
45 BuildRequires:  autoconf >= 2.57
46 BuildRequires:  bin86
47 BuildRequires:  bison
48 BuildRequires:  docbook-dtd30-sgml
49 BuildRequires:  docbook-style-dsssl
50 BuildRequires:  flex
51 %{?with_static:BuildRequires:   glibc-static}
52 BuildRequires:  gpm-devel
53 BuildRequires:  lynx
54 BuildRequires:  openjade
55 BuildRequires:  perl
56 BuildRequires:  sgml-tools
57 BuildRequires:  slang-devel
58 %{?with_static:BuildRequires:   slang-static}
59 BuildRequires:  unzip
60 BuildRequires:  util-linux
61 Obsoletes:      xdosemu
62 Conflicts:      dosemu-freedos-minimal < 2.0.33
63 Conflicts:      kernel < 2.0.28
64 Conflicts:      mtools < 3.6
65 ExclusiveArch:  %{ix86}
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _dosemudir      /var/lib/dosemu
69 %define         specflags       -fomit-frame-pointer
70
71 %description
72 Dosemu is a DOS emulator. Once you've installed dosemu, start the DOS
73 emulator by typing in the "dos" command.
74
75 You need to install dosemu if you use DOS programs and you want to be
76 able to run them on your GNU/Linux system. You may also need to
77 install the dosemu-freedos-* packages.
78
79 %description -l pl
80 Dosemu to Emulator systemu DOS. Po zainstalowaniu mo¿esz go uruchomiæ
81 komend± "dos".
82
83 Je¶li korzystasz z dosowych programów i chcia³by¶ je uruchamiaæ na
84 twoim linuksowym systemie zainstaluj dosemu. Mo¿esz te¿ potrzebowaæ
85 pakietów dosemu-freedos-*.
86
87 %description -l pt_BR
88 Essa é uma versão do emulador DOS que foi projetada para rodar em
89 sessões X Window. Oferece suporte para gráficos VGA bem como suporte
90 para mouse.
91
92 %package utils
93 Summary:        Utilities for dosemu
94 Summary(pl):    Programy pomocnicze do dosemu
95 Group:          Applications/Emulators
96 Requires:       %{name} = %{version}-%{release}
97
98 %description utils
99 Utilities for dosemu: dexeconfig, hdinfo, mkhdimage, mkfatimage16.
100
101 %description utils -l pl
102 Programy pomocnicze dla dosemu: dexeconfig, hdinfo, mkhdimage,
103 mkfatimage16.
104
105 %package SDL
106 Summary:        SDL plugin for dosemu
107 Summary(pl):    Wtyczka SDL dla dosemu
108 Group:          Libraries
109 Requires:       %{name} = %{version}-%{release}
110
111 %description SDL
112 SDL plugin for dosemu.
113
114 %description SDL -l pl
115 Wtyczka SDL dla dosemu.
116
117 %package X
118 Summary:        X plugin for dosemu
119 Summary(pl):    Wtyczka X dla dosemu
120 Group:          Libraries
121 Requires:       %{name} = %{version}-%{release}
122
123 %description X
124 X plugin for dosemu.
125
126 %description X -l pl
127 Wtyczka X dla dosemu.
128
129 %prep
130 %setup -q -a6
131 #sh tmp/do_patch
132 #%patch0 -p1
133 %patch1 -p1
134 %patch2 -p1
135 %patch3 -p1
136 %patch4 -p1
137
138 %build
139 OPTFLAGS="%{rpmcflags}"; export OPTFLAGS
140
141 ./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
142 plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
143
144 %{__autoconf}
145 # configure2_13 must be used though because of ./default-configure
146
147 # non-X version
148 %configure2_13 \
149         %{?with_static:--enable-linkstatic} \
150         --enable-new-intcode \
151         --enable-aspi \
152         %{!?with_x:--without-x}
153
154 %{__make} \
155         WAIT=no
156
157 %{__make} -C man
158 mv -f man/dosemu.bin.1 man/dosemu.1
159 echo '.so dosemu.1' > man/dos.1
160 mv -f man/ru/dosemu.bin.1 man/ru/dosemu.1
161 echo '.so dosemu.1' > man/ru/dos.1
162
163 mv -f pl/man1/dos.1 pl/man1/dosemu.1
164 echo '.so dosemu.1' > pl/man1/dos.1
165 echo '.so dosemu.1' > pl/man1/xdosemu.1
166 echo '.so dosemu.1' > pl/man1/dosdebug.1
167
168 # documentation
169 %{__make} -C src/doc/DANG html
170 %{__make} -C src/doc/HOWTO html
171 %{__make} -C src/doc/README html
172
173 find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}} \
178         $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/{pl,ru}/man1} \
179         $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
180         $RPM_BUILD_ROOT%{_libdir}/dosemu
181
182 #%%{__make} install \
183 #       DESTDIR=$RPM_BUILD_ROOT
184
185 install bin/midid $RPM_BUILD_ROOT%{_bindir}/midid
186 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dosemu
187 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/dos
188 %if %{with x}
189 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdos
190 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosemu
191 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosexec
192 %endif
193
194 install bin/libplugin*.so  $RPM_BUILD_ROOT%{_libdir}/dosemu
195
196 install bin/{dosdebug,mkfatimage16} $RPM_BUILD_ROOT%{_bindir}
197 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage} $RPM_BUILD_ROOT%{_bindir}
198 ln -sf dos $RPM_BUILD_ROOT%{_bindir}/dosexec
199
200 install etc/dosemu.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
201 install etc/dosemu.users.example $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
202 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
203 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
204
205 install man/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
206 install pl/man1/{dosemu.1,dosdebug.1,xdosemu.1,dos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
207 install man/ru/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/ru/man1
208
209 install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
210 install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
211 cp %{SOURCE3} PRZECZYTAJ_TO
212 cp %{SOURCE4} README.PLD
213 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
214
215 rm -f doc/{configuration,dosemu.lsm}
216
217 %clean
218 rm -rf $RPM_BUILD_ROOT
219
220 %files
221 %defattr(644,root,root,755)
222 %doc QuickStart COPYING ChangeLog* doc/* README.PLD
223 %lang(pl) %doc PRZECZYTAJ_TO
224 %dir %{_dosemudir}
225 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.conf
226 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.users
227 %config(noreplace) %verify(not md5 mtime size) %{_dosemudir}/global.conf
228 %attr(755,root,root) %{_bindir}/dos
229 %attr(755,root,root) %{_bindir}/dosdebug
230 %attr(755,root,root) %{_bindir}/dosemu
231 %attr(755,root,root) %{_bindir}/dosexec
232 %attr(755,root,root) %{_bindir}/midid
233 %dir %{_libdir}/dosemu
234 %{_libdir}/dosemu/libplugin_gpm.so
235 %{_libdir}/dosemu/libplugin_term.so
236 %dir %{_dosemudir}/bootdir
237 %dir %{_dosemudir}/bootdir/dosemu
238 %{_dosemudir}/bootdir/dosemu/*
239 %{_mandir}/man1/d*
240 %lang(pl) %{_mandir}/pl/man1/d*
241 %lang(ru) %{_mandir}/ru/man1/d*
242 %{_pixmapsdir}/dosemu.xpm
243 %if %{with x}
244 %attr(755,root,root) %{_bindir}/xdos*
245 %{_mandir}/man1/xdosemu.1*
246 %lang(pl) %{_mandir}/pl/man1/xdosemu.1*
247 %lang(ru) %{_mandir}/ru/man1/xdosemu.1*
248 %{_desktopdir}/dosemu.desktop
249 %endif
250
251 %files utils
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/dexeconfig
254 %attr(755,root,root) %{_bindir}/hdinfo
255 %attr(755,root,root) %{_bindir}/mkhdimage
256 %attr(755,root,root) %{_bindir}/mkfatimage16
257 %{_mandir}/man1/mkfatimage16.1*
258 %lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
259
260 %files SDL
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_libdir}/dosemu/libplugin_sdl.so
263
264 %if %{with x}
265 %files X
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_libdir}/dosemu/libplugin_X.so
268 %endif
This page took 0.07565 seconds and 3 git commands to generate.