]> git.pld-linux.org Git - packages/dosemu.git/blob - dosemu.spec
- internal support for samba
[packages/dosemu.git] / dosemu.spec
1 # NOTE: if /dev/shm is mounted, it cannot be mounted with noexec
2 #
3 # Conditional build:
4 %bcond_with     static          # link statically
5 %bcond_with     AC
6 %bcond_without  x               # X support
7 %bcond_with     samba           # samba support
8 #
9 %define         smarthogver     0.1.0
10
11 Summary:        A DOS emulator
12 Summary(de.UTF-8):      DOS-Emulator
13 Summary(es.UTF-8):      Emulador DOS
14 Summary(fr.UTF-8):      Emulateur DOS
15 Summary(pl.UTF-8):      Emulator DOS-a
16 Summary(pt_BR.UTF-8):   Emulador DOS
17 Summary(tr.UTF-8):      DOS öykünümcüsü
18 Name:           dosemu
19 Version:        1.4.0
20 Release:        1%{?with_samba:.smb}
21 License:        GPL v2
22 Group:          Applications/Emulators
23 Source0:        http://dl.sourceforge.net/dosemu/%{name}-%{version}.tgz
24 # Source0-md5:  0bba530637266f99d404ba15e3f118d4
25 #Source2:       %{name}-sys.tar.gz
26 Source3:        %{name}-PRZECZYTAJ_TO
27 Source4:        %{name}-README.PLD
28 Source5:        %{name}.desktop
29 Source6:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
30 # Source6-md5:  7a8abf5c656e6b99bdd03a4783751895
31 Source7:        smarthog-%{smarthogver}.tgz
32 Patch0:         %{name}-man-pages.patch
33 Patch1:         %{name}-make-new.patch
34 Patch2:         %{name}-%{name}_conf.patch
35 Patch3:         %{name}-doSgmlTools.patch
36 Patch4:         %{name}-makehtml.patch
37 Patch5:         http://www.pers.pl/~pascalek/%{name}-1.4.0-samba-beta1.patch.gz
38 URL:            http://www.dosemu.org/
39 BuildRequires:  SDL-devel
40 BuildRequires:  alsa-lib-devel >= 0.9
41 BuildRequires:  autoconf >= 2.59-9
42 BuildRequires:  bin86
43 BuildRequires:  bison
44 BuildRequires:  docbook-dtd30-sgml
45 BuildRequires:  docbook-style-dsssl
46 BuildRequires:  flex
47 %{?with_static:BuildRequires:   glibc-static}
48 BuildRequires:  gpm-devel
49 %{?with_samba:BuildRequires:    libcli_smb-devel}
50 BuildRequires:  libsndfile-devel
51 BuildRequires:  lynx
52 BuildRequires:  openjade
53 BuildRequires:  perl-base
54 BuildRequires:  sgml-tools
55 BuildRequires:  slang-devel
56 %{?with_static:BuildRequires:   slang-static}
57 BuildRequires:  unzip
58 BuildRequires:  util-linux
59 %if %{with x}
60 %if !%{with AC}
61 BuildRequires:  xorg-app-bdftopcf
62 BuildRequires:  xorg-lib-libX11-devel
63 BuildRequires:  xorg-lib-libXext-devel
64 BuildRequires:  xorg-lib-libXxf86vm-devel
65 %if %{with static}
66 BuildRequires:  xorg-lib-libX11-static
67 BuildRequires:  xorg-lib-libXext-static
68 BuildRequires:  xorg-lib-libXxf86vm-static
69 %endif
70 %endif
71 %if %{with AC}
72 BuildRequires:  X11-devel
73 %{?with_static:BuildRequires:   X11-static}
74 %endif
75 %endif
76 Obsoletes:      xdosemu
77 Conflicts:      dosemu-freedos-minimal < 2.0.33
78 Conflicts:      kernel < 2.0.28
79 Conflicts:      mtools < 3.6
80 ExclusiveArch:  %{ix86} %{x8664}
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         _dosemudir      /var/lib/dosemu
84 %define         specflags       -fomit-frame-pointer
85
86 %description
87 Dosemu is a DOS emulator. Once you've installed dosemu, start the DOS
88 emulator by typing in the "dos" command.
89
90 You need to install dosemu if you use DOS programs and you want to be
91 able to run them on your GNU/Linux system. You may also need to
92 install the dosemu-freedos-* packages.
93
94 %description -l pl.UTF-8
95 Dosemu to Emulator systemu DOS. Po zainstalowaniu możesz go uruchomić
96 komendą "dos".
97
98 Jeśli korzystasz z dosowych programów i chciałbyś je uruchamiać na
99 twoim linuksowym systemie zainstaluj dosemu. Możesz też potrzebować
100 pakietów dosemu-freedos-*.
101
102 %description -l pt_BR.UTF-8
103 Essa é uma versão do emulador DOS que foi projetada para rodar em
104 sessões X Window. Oferece suporte para gráficos VGA bem como suporte
105 para mouse.
106
107 %package utils
108 Summary:        Utilities for dosemu
109 Summary(pl.UTF-8):      Programy pomocnicze do dosemu
110 Group:          Applications/Emulators
111 Requires:       %{name} = %{version}-%{release}
112
113 %description utils
114 Utilities for dosemu: dexeconfig, hdinfo, mkhdimage, mkfatimage16.
115
116 %description utils -l pl.UTF-8
117 Programy pomocnicze dla dosemu: dexeconfig, hdinfo, mkhdimage,
118 mkfatimage16.
119
120 %package SDL
121 Summary:        SDL plugin for dosemu
122 Summary(pl.UTF-8):      Wtyczka SDL dla dosemu
123 Group:          Libraries
124 Requires:       %{name} = %{version}-%{release}
125
126 %description SDL
127 SDL plugin for dosemu.
128
129 %description SDL -l pl.UTF-8
130 Wtyczka SDL dla dosemu.
131
132 %package X
133 Summary:        X plugin for dosemu
134 Summary(pl.UTF-8):      Wtyczka X dla dosemu
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137
138 %description X
139 X plugin for dosemu.
140
141 %description X -l pl.UTF-8
142 Wtyczka X dla dosemu.
143
144 %prep
145 %setup -q -a6 -a7
146
147 %patch0 -p1
148 %patch1 -p1
149 %patch2 -p1
150 %patch3 -p1
151 %patch4 -p1
152 %{?with_samba:%patch5 -p1}
153
154 %build
155 OPTFLAGS="%{rpmcflags}"; export OPTFLAGS
156
157 ./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
158 plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
159
160 %{__autoconf}
161 # configure2_13 must be used though because of ./default-configure
162
163 # non-X version
164 %configure2_13 \
165         %{?with_static:--enable-linkstatic} \
166         --enable-new-intcode \
167         --enable-aspi \
168         %{!?with_x:--without-x}
169
170 %{__make} \
171         WAIT=no
172
173 %{__make} -C man
174 mv -f man/dosemu.bin.1 man/dosemu.1
175 echo '.so dosemu.1' > man/dos.1
176 mv -f man/ru/dosemu.bin.1 man/ru/dosemu.1
177 echo '.so dosemu.1' > man/ru/dos.1
178
179 mv -f pl/man1/dos.1 pl/man1/dosemu.1
180 echo '.so dosemu.1' > pl/man1/dos.1
181 echo '.so dosemu.1' > pl/man1/xdosemu.1
182 echo '.so dosemu.1' > pl/man1/dosdebug.1
183
184 # documentation
185 #%{__make} -C src/doc/DANG html
186 #%{__make} -C src/doc/HOWTO html
187 #%{__make} -C src/doc/README html
188
189 #find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}} \
194         $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/{pl,ru}/man1} \
195         $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
196         $RPM_BUILD_ROOT%{_libdir}/dosemu
197
198 #%%{__make} install \
199 #       DESTDIR=$RPM_BUILD_ROOT
200
201 install bin/midid $RPM_BUILD_ROOT%{_bindir}/midid
202 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dosemu
203 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/dos
204 %if %{with x}
205 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdos
206 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosemu
207 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosexec
208 %endif
209
210 install bin/libplugin*.so  $RPM_BUILD_ROOT%{_libdir}/dosemu
211
212 install bin/{dosdebug,mkfatimage16} $RPM_BUILD_ROOT%{_bindir}
213 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage} $RPM_BUILD_ROOT%{_bindir}
214 ln -sf dos $RPM_BUILD_ROOT%{_bindir}/dosexec
215
216 install etc/dosemu.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
217 install etc/dosemu.users.example $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
218 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
219 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
220
221 install man/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
222 install pl/man1/{dosemu.1,dosdebug.1,xdosemu.1,dos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
223 install man/ru/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/ru/man1
224
225 install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
226 install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
227 install smarthog-%{smarthogver}/*.exe   $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
228 cp %{SOURCE3} PRZECZYTAJ_TO
229 cp %{SOURCE4} README.PLD
230 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
231
232 rm -f doc/{configuration,dosemu.lsm}
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %files
238 %defattr(644,root,root,755)
239 %doc QuickStart COPYING ChangeLog* doc/* README.PLD
240 %lang(pl) %doc PRZECZYTAJ_TO
241 %dir %{_dosemudir}
242 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.conf
243 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.users
244 %config(noreplace) %verify(not md5 mtime size) %{_dosemudir}/global.conf
245 %attr(755,root,root) %{_bindir}/dos
246 %attr(755,root,root) %{_bindir}/dosdebug
247 %attr(755,root,root) %{_bindir}/dosemu
248 %attr(755,root,root) %{_bindir}/dosexec
249 %attr(755,root,root) %{_bindir}/midid
250 %dir %{_libdir}/dosemu
251 %{_libdir}/dosemu/libplugin_alsa.so
252 %{_libdir}/dosemu/libplugin_gpm.so
253 %{_libdir}/dosemu/libplugin_sndfile.so
254 %{_libdir}/dosemu/libplugin_term.so
255 %dir %{_dosemudir}/bootdir
256 %dir %{_dosemudir}/bootdir/dosemu
257 %{_dosemudir}/bootdir/dosemu/*
258 %{_mandir}/man1/d*
259 %lang(pl) %{_mandir}/pl/man1/d*
260 %lang(ru) %{_mandir}/ru/man1/d*
261 %{_pixmapsdir}/dosemu.xpm
262 %if %{with x}
263 %attr(755,root,root) %{_bindir}/xdos*
264 %{_mandir}/man1/xdosemu.1*
265 %lang(pl) %{_mandir}/pl/man1/xdosemu.1*
266 %lang(ru) %{_mandir}/ru/man1/xdosemu.1*
267 %{_desktopdir}/dosemu.desktop
268 %endif
269
270 %files utils
271 %defattr(644,root,root,755)
272 %attr(755,root,root) %{_bindir}/dexeconfig
273 %attr(755,root,root) %{_bindir}/hdinfo
274 %attr(755,root,root) %{_bindir}/mkhdimage
275 %attr(755,root,root) %{_bindir}/mkfatimage16
276 %{_mandir}/man1/mkfatimage16.1*
277 %lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
278
279 %files SDL
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_libdir}/dosemu/libplugin_sdl.so
282
283 %if %{with x}
284 %files X
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_libdir}/dosemu/libplugin_X.so
287 %endif
This page took 0.196042 seconds and 3 git commands to generate.