]> git.pld-linux.org Git - packages/dosemu.git/blob - dosemu.spec
- BR: xorg-app-mkfontdir
[packages/dosemu.git] / dosemu.spec
1 # NOTE: if /dev/shm is mounted, it cannot be mounted with noexec
2 #
3 # Conditional build:
4 %bcond_with     static          # link statically
5 %bcond_with     AC
6 %bcond_without  htmldocs        # do not build documentation in HTML
7 %bcond_without  x               # X support
8 %bcond_with     samba           # samba support
9 #
10 %define         smarthogver     0.1.0
11 %define         smbrel          01
12
13 Summary:        A DOS emulator
14 Summary(de.UTF-8):      DOS-Emulator
15 Summary(es.UTF-8):      Emulador DOS
16 Summary(fr.UTF-8):      Emulateur DOS
17 Summary(pl.UTF-8):      Emulator DOS-a
18 Summary(pt_BR.UTF-8):   Emulador DOS
19 Summary(tr.UTF-8):      DOS öykünümcüsü
20 Name:           dosemu
21 Version:        1.4.0
22 Release:        2%{?with_samba:.smb%{smbrel}}
23 License:        GPL v2
24 Group:          Applications/Emulators
25 Source0:        http://dl.sourceforge.net/dosemu/%{name}-%{version}.tgz
26 # Source0-md5:  0bba530637266f99d404ba15e3f118d4
27 #Source2:       %{name}-sys.tar.gz
28 Source3:        %{name}-PRZECZYTAJ_TO
29 Source4:        %{name}-README.PLD
30 Source5:        %{name}.desktop
31 Source6:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
32 # Source6-md5:  7a8abf5c656e6b99bdd03a4783751895
33 Source7:        smarthog-%{smarthogver}.tgz
34 Patch0:         %{name}-man-pages.patch
35 Patch1:         %{name}-make-new.patch
36 Patch2:         %{name}-%{name}_conf.patch
37 Patch3:         %{name}-doSgmlTools.patch
38 Patch4:         %{name}-makehtml.patch
39 Patch5:         http://pascalek.pers.pl/files/projects/Samba4DosEmu/%{name}-1.4.0-samba-beta2.patch.gz
40 Patch6:         http://pascalek.pers.pl/files/projects/Samba4DosEmu/s4d-beta2-fix1.patch
41 Patch7:         %{name}-lpt4.patch
42 Patch8:         %{name}-Xquit.patch
43 URL:            http://www.dosemu.org/
44 BuildRequires:  SDL-devel
45 BuildRequires:  alsa-lib-devel >= 0.9
46 BuildRequires:  autoconf >= 2.59-9
47 BuildRequires:  bin86
48 BuildRequires:  bison
49 BuildRequires:  docbook-dtd30-sgml
50 BuildRequires:  docbook-style-dsssl
51 BuildRequires:  flex
52 %{?with_static:BuildRequires:   glibc-static}
53 BuildRequires:  gpm-devel
54 %{?with_samba:BuildRequires:    libcli_smb-devel}
55 BuildRequires:  libsndfile-devel
56 BuildRequires:  lynx
57 %{?with_htmldocs:BuildRequires: openjade}
58 %{?with_htmldocs:BuildRequires: perl-base}
59 %{?with_htmldocs:BuildRequires: sgml-tools}
60 BuildRequires:  slang-devel
61 %{?with_static:BuildRequires:   slang-static}
62 BuildRequires:  unzip
63 BuildRequires:  util-linux
64 %if %{with x}
65 %if !%{with AC}
66 BuildRequires:  xorg-app-bdftopcf
67 BuildRequires:  xorg-app-mkfontdir
68 BuildRequires:  xorg-lib-libX11-devel
69 BuildRequires:  xorg-lib-libXext-devel
70 BuildRequires:  xorg-lib-libXxf86vm-devel
71 %if %{with static}
72 BuildRequires:  xorg-lib-libX11-static
73 BuildRequires:  xorg-lib-libXext-static
74 BuildRequires:  xorg-lib-libXxf86vm-static
75 %endif
76 %endif
77 %if %{with AC}
78 BuildRequires:  X11-devel
79 %{?with_static:BuildRequires:   X11-static}
80 %endif
81 %endif
82 Obsoletes:      xdosemu
83 Conflicts:      dosemu-freedos-minimal < 2.0.33
84 Conflicts:      kernel < 2.0.28
85 Conflicts:      mtools < 3.6
86 ExclusiveArch:  %{ix86} %{x8664}
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %define         _dosemudir      /var/lib/dosemu
90 %define         specflags       -fomit-frame-pointer
91
92 %description
93 Dosemu is a DOS emulator. Once you've installed dosemu, start the DOS
94 emulator by typing in the "dos" command.
95
96 You need to install dosemu if you use DOS programs and you want to be
97 able to run them on your GNU/Linux system. You may also need to
98 install the dosemu-freedos-* packages.
99
100 %description -l pl.UTF-8
101 Dosemu to Emulator systemu DOS. Po zainstalowaniu możesz go uruchomić
102 komendą "dos".
103
104 Jeśli korzystasz z dosowych programów i chciałbyś je uruchamiać na
105 twoim linuksowym systemie zainstaluj dosemu. Możesz też potrzebować
106 pakietów dosemu-freedos-*.
107
108 %description -l pt_BR.UTF-8
109 Essa é uma versão do emulador DOS que foi projetada para rodar em
110 sessões X Window. Oferece suporte para gráficos VGA bem como suporte
111 para mouse.
112
113 %package utils
114 Summary:        Utilities for dosemu
115 Summary(pl.UTF-8):      Programy pomocnicze do dosemu
116 Group:          Applications/Emulators
117 Requires:       %{name} = %{version}-%{release}
118
119 %description utils
120 Utilities for dosemu: dexeconfig, hdinfo, mkhdimage, mkfatimage16.
121
122 %description utils -l pl.UTF-8
123 Programy pomocnicze dla dosemu: dexeconfig, hdinfo, mkhdimage,
124 mkfatimage16.
125
126 %package SDL
127 Summary:        SDL plugin for dosemu
128 Summary(pl.UTF-8):      Wtyczka SDL dla dosemu
129 Group:          Libraries
130 Requires:       %{name} = %{version}-%{release}
131
132 %description SDL
133 SDL plugin for dosemu.
134
135 %description SDL -l pl.UTF-8
136 Wtyczka SDL dla dosemu.
137
138 %package X
139 Summary:        X plugin for dosemu
140 Summary(pl.UTF-8):      Wtyczka X dla dosemu
141 Group:          Libraries
142 Requires:       %{name} = %{version}-%{release}
143
144 %description X
145 X plugin for dosemu.
146
147 %description X -l pl.UTF-8
148 Wtyczka X dla dosemu.
149
150 %prep
151 %setup -q -a6 -a7
152
153 %patch0 -p1
154 %patch1 -p1
155 %patch2 -p1
156 %patch3 -p1
157 %patch4 -p1
158 %{?with_samba:%patch5 -p1}
159 %{?with_samba:%patch6 -p1}
160 %patch7 -p1
161 %patch8 -p1
162
163 %build
164 OPTFLAGS="%{rpmcflags}"; export OPTFLAGS
165
166 ./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
167 plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
168
169 %{__autoconf}
170 # configure2_13 must be used though because of ./default-configure
171
172 # non-X version
173 %configure2_13 \
174         %{?with_static:--enable-linkstatic} \
175         --enable-new-intcode \
176         --enable-aspi \
177         %{!?with_x:--without-x}
178
179 %{__make} \
180         WAIT=no
181
182 %{__make} -C man
183 mv -f man/dosemu.bin.1 man/dosemu.1
184 echo '.so dosemu.1' > man/dos.1
185 mv -f man/ru/dosemu.bin.1 man/ru/dosemu.1
186 echo '.so dosemu.1' > man/ru/dos.1
187
188 mv -f pl/man1/dos.1 pl/man1/dosemu.1
189 echo '.so dosemu.1' > pl/man1/dos.1
190 echo '.so dosemu.1' > pl/man1/xdosemu.1
191 echo '.so dosemu.1' > pl/man1/dosdebug.1
192
193 %if %{with htmldocs}
194 # documentation
195 %{__make} -C src/doc/DANG html
196 %{__make} -C src/doc/HOWTO html
197 %{__make} -C src/doc/README html
198
199 find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
200 %endif
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}} \
205         $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/{pl,ru}/man1} \
206         $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
207         $RPM_BUILD_ROOT%{_libdir}/dosemu
208
209 #%%{__make} install \
210 #       DESTDIR=$RPM_BUILD_ROOT
211
212 install bin/midid $RPM_BUILD_ROOT%{_bindir}/midid
213 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dosemu
214 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/dos
215 %if %{with x}
216 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdos
217 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosemu
218 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosexec
219 %endif
220
221 install bin/libplugin*.so  $RPM_BUILD_ROOT%{_libdir}/dosemu
222
223 install bin/{dosdebug,mkfatimage16} $RPM_BUILD_ROOT%{_bindir}
224 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage} $RPM_BUILD_ROOT%{_bindir}
225 ln -sf dos $RPM_BUILD_ROOT%{_bindir}/dosexec
226
227 install etc/dosemu.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
228 install etc/dosemu.users.example $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
229 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
230 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
231
232 install man/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
233 install pl/man1/{dosemu.1,dosdebug.1,xdosemu.1,dos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
234 install man/ru/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/ru/man1
235
236 install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
237 install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
238 install smarthog-%{smarthogver}/*.exe   $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
239 cp %{SOURCE3} PRZECZYTAJ_TO
240 cp %{SOURCE4} README.PLD
241 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
242
243 rm -f doc/{configuration,dosemu.lsm}
244
245 %clean
246 rm -rf $RPM_BUILD_ROOT
247
248 %files
249 %defattr(644,root,root,755)
250 %doc QuickStart COPYING ChangeLog* doc/* README.PLD
251 %lang(pl) %doc PRZECZYTAJ_TO
252 %dir %{_dosemudir}
253 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.conf
254 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.users
255 %config(noreplace) %verify(not md5 mtime size) %{_dosemudir}/global.conf
256 %attr(755,root,root) %{_bindir}/dos
257 %attr(755,root,root) %{_bindir}/dosdebug
258 %attr(755,root,root) %{_bindir}/dosemu
259 %attr(755,root,root) %{_bindir}/dosexec
260 %attr(755,root,root) %{_bindir}/midid
261 %dir %{_libdir}/dosemu
262 %{_libdir}/dosemu/libplugin_alsa.so
263 %{_libdir}/dosemu/libplugin_gpm.so
264 %{_libdir}/dosemu/libplugin_sndfile.so
265 %{_libdir}/dosemu/libplugin_term.so
266 %dir %{_dosemudir}/bootdir
267 %dir %{_dosemudir}/bootdir/dosemu
268 %{_dosemudir}/bootdir/dosemu/*
269 %{_mandir}/man1/d*
270 %lang(pl) %{_mandir}/pl/man1/d*
271 %lang(ru) %{_mandir}/ru/man1/d*
272 %{_pixmapsdir}/dosemu.xpm
273 %if %{with x}
274 %attr(755,root,root) %{_bindir}/xdos*
275 %{_mandir}/man1/xdosemu.1*
276 %lang(pl) %{_mandir}/pl/man1/xdosemu.1*
277 %lang(ru) %{_mandir}/ru/man1/xdosemu.1*
278 %{_desktopdir}/dosemu.desktop
279 %endif
280
281 %files utils
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_bindir}/dexeconfig
284 %attr(755,root,root) %{_bindir}/hdinfo
285 %attr(755,root,root) %{_bindir}/mkhdimage
286 %attr(755,root,root) %{_bindir}/mkfatimage16
287 %{_mandir}/man1/mkfatimage16.1*
288 %lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
289
290 %files SDL
291 %defattr(644,root,root,755)
292 %attr(755,root,root) %{_libdir}/dosemu/libplugin_sdl.so
293
294 %if %{with x}
295 %files X
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/dosemu/libplugin_X.so
298 %endif
This page took 0.09821 seconds and 3 git commands to generate.