]> git.pld-linux.org Git - packages/dosemu.git/blob - dosemu.spec
70a3e0c1edd04ffc260be6e3d9fa0d0107ab82c4
[packages/dosemu.git] / dosemu.spec
1 # NOTE: if /dev/shm is mounted, it cannot be mounted with noexec
2 #
3 # Conditional build:
4 %bcond_with     static          # link statically
5 %bcond_with     AC
6 %bcond_without  x               # X support
7 #
8 Summary:        A DOS emulator
9 Summary(de):    DOS-Emulator
10 Summary(es):    Emulador DOS
11 Summary(fr):    Emulateur DOS
12 Summary(pl):    Emulator DOS-a
13 Summary(pt_BR): Emulador DOS
14 Summary(tr):    DOS öykünümcüsü
15 Name:           dosemu
16 Version:        1.3.3.1
17 Release:        0.svn.1
18 License:        GPL v2
19 Group:          Applications/Emulators
20 Source0:        http://dl.sourceforge.net/dosemu/%{name}-1.3.3.tgz
21 # Source0-md5:  f3b27a9326e5c95e59093fcb79a61023
22 #Source2:       %{name}-sys.tar.gz
23 Source3:        %{name}-PRZECZYTAJ_TO
24 Source4:        %{name}-README.PLD
25 Source5:        %{name}.desktop
26 Source6:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
27 # Source6-md5:  7a8abf5c656e6b99bdd03a4783751895
28 Patch0:         %{name}-man-pages.patch
29 Patch1:         %{name}-make-new.patch
30 Patch2:         %{name}-%{name}_conf.patch
31 Patch3:         %{name}-doSgmlTools.patch
32 Patch4:         %{name}-makehtml.patch
33 Patch5:         %{name}-1.3.3.1svn.patch.gz
34 URL:            http://www.dosemu.org/
35 BuildRequires:  SDL-devel
36 %if %{with x}
37 %if !%{with AC}
38 BuildRequires:  xorg-lib-libX11-devel
39 %{?with_static:BuildRequires:   xorg-lib-libX11-static}
40 %endif
41 %if %{with AC}
42 BuildRequires:  X11-devel
43 %{?with_static:BuildRequires:   X11-static}
44 %endif
45 %endif
46 BuildRequires:  autoconf >= 2.57
47 BuildRequires:  bin86
48 BuildRequires:  bison
49 BuildRequires:  docbook-dtd30-sgml
50 BuildRequires:  docbook-style-dsssl
51 BuildRequires:  flex
52 %{?with_static:BuildRequires:   glibc-static}
53 BuildRequires:  gpm-devel
54 BuildRequires:  lynx
55 BuildRequires:  openjade
56 BuildRequires:  perl
57 BuildRequires:  sgml-tools
58 BuildRequires:  slang-devel
59 %{?with_static:BuildRequires:   slang-static}
60 BuildRequires:  unzip
61 BuildRequires:  util-linux
62 Obsoletes:      xdosemu
63 Conflicts:      dosemu-freedos-minimal < 2.0.33
64 Conflicts:      kernel < 2.0.28
65 Conflicts:      mtools < 3.6
66 ExclusiveArch:  %{ix86}
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _dosemudir      /var/lib/dosemu
70 %define         specflags       -fomit-frame-pointer
71
72 %description
73 Dosemu is a DOS emulator. Once you've installed dosemu, start the DOS
74 emulator by typing in the "dos" command.
75
76 You need to install dosemu if you use DOS programs and you want to be
77 able to run them on your GNU/Linux system. You may also need to
78 install the dosemu-freedos-* packages.
79
80 %description -l pl
81 Dosemu to Emulator systemu DOS. Po zainstalowaniu mo¿esz go uruchomiæ
82 komend± "dos".
83
84 Je¶li korzystasz z dosowych programów i chcia³by¶ je uruchamiaæ na
85 twoim linuksowym systemie zainstaluj dosemu. Mo¿esz te¿ potrzebowaæ
86 pakietów dosemu-freedos-*.
87
88 %description -l pt_BR
89 Essa é uma versão do emulador DOS que foi projetada para rodar em
90 sessões X Window. Oferece suporte para gráficos VGA bem como suporte
91 para mouse.
92
93 %package utils
94 Summary:        Utilities for dosemu
95 Summary(pl):    Programy pomocnicze do dosemu
96 Group:          Applications/Emulators
97 Requires:       %{name} = %{version}-%{release}
98
99 %description utils
100 Utilities for dosemu: dexeconfig, hdinfo, mkhdimage, mkfatimage16.
101
102 %description utils -l pl
103 Programy pomocnicze dla dosemu: dexeconfig, hdinfo, mkhdimage,
104 mkfatimage16.
105
106 %package SDL
107 Summary:        SDL plugin for dosemu
108 Summary(pl):    Wtyczka SDL dla dosemu
109 Group:          Libraries
110 Requires:       %{name} = %{version}-%{release}
111
112 %description SDL
113 SDL plugin for dosemu.
114
115 %description SDL -l pl
116 Wtyczka SDL dla dosemu.
117
118 %package X
119 Summary:        X plugin for dosemu
120 Summary(pl):    Wtyczka X dla dosemu
121 Group:          Libraries
122 Requires:       %{name} = %{version}-%{release}
123
124 %description X
125 X plugin for dosemu.
126
127 %description X -l pl
128 Wtyczka X dla dosemu.
129
130 %prep
131 %setup -q -a6 -n %{name}-1.3.3
132 #sh tmp/do_patch
133 #%patch0 -p1
134 %patch1 -p1
135 %patch2 -p1
136 %patch3 -p1
137 %patch4 -p1
138 %patch5 -p1
139
140 %build
141 OPTFLAGS="%{rpmcflags}"; export OPTFLAGS
142
143 ./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
144 plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
145
146 %{__autoconf}
147 # configure2_13 must be used though because of ./default-configure
148
149 # non-X version
150 %configure2_13 \
151         %{?with_static:--enable-linkstatic} \
152         --enable-new-intcode \
153         --enable-aspi \
154         %{!?with_x:--without-x}
155
156 %{__make} \
157         WAIT=no
158
159 %{__make} -C man
160 mv -f man/dosemu.bin.1 man/dosemu.1
161 echo '.so dosemu.1' > man/dos.1
162 mv -f man/ru/dosemu.bin.1 man/ru/dosemu.1
163 echo '.so dosemu.1' > man/ru/dos.1
164
165 mv -f pl/man1/dos.1 pl/man1/dosemu.1
166 echo '.so dosemu.1' > pl/man1/dos.1
167 echo '.so dosemu.1' > pl/man1/xdosemu.1
168 echo '.so dosemu.1' > pl/man1/dosdebug.1
169
170 # documentation
171 %{__make} -C src/doc/DANG html
172 %{__make} -C src/doc/HOWTO html
173 %{__make} -C src/doc/README html
174
175 find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}} \
180         $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/{pl,ru}/man1} \
181         $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
182         $RPM_BUILD_ROOT%{_libdir}/dosemu
183
184 #%%{__make} install \
185 #       DESTDIR=$RPM_BUILD_ROOT
186
187 install bin/midid $RPM_BUILD_ROOT%{_bindir}/midid
188 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dosemu
189 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/dos
190 %if %{with x}
191 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdos
192 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosemu
193 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosexec
194 %endif
195
196 install bin/libplugin*.so  $RPM_BUILD_ROOT%{_libdir}/dosemu
197
198 install bin/dosdebug $RPM_BUILD_ROOT%{_bindir}/dosdebug
199 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage} $RPM_BUILD_ROOT%{_bindir}
200 ln -sf dos $RPM_BUILD_ROOT%{_bindir}/dosexec
201
202 install etc/dosemu.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
203 install etc/dosemu.users.example $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
204 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
205 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
206
207 install man/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
208 install pl/man1/{dosemu.1,dosdebug.1,xdosemu.1,dos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
209 install man/ru/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/ru/man1
210
211 install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
212 install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
213 cp %{SOURCE3} PRZECZYTAJ_TO
214 cp %{SOURCE4} README.PLD
215 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
216
217 rm -f doc/{configuration,dosemu.lsm}
218
219 %clean
220 rm -rf $RPM_BUILD_ROOT
221
222 %files
223 %defattr(644,root,root,755)
224 %doc QuickStart COPYING ChangeLog* doc/* README.PLD
225 %lang(pl) %doc PRZECZYTAJ_TO
226 %dir %{_dosemudir}
227 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.conf
228 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.users
229 %config(noreplace) %verify(not md5 mtime size) %{_dosemudir}/global.conf
230 %attr(755,root,root) %{_bindir}/dos
231 %attr(755,root,root) %{_bindir}/dosdebug
232 %attr(755,root,root) %{_bindir}/dosemu
233 %attr(755,root,root) %{_bindir}/dosexec
234 %attr(755,root,root) %{_bindir}/midid
235 %dir %{_libdir}/dosemu
236 %{_libdir}/dosemu/libplugin_gpm.so
237 %{_libdir}/dosemu/libplugin_term.so
238 %dir %{_dosemudir}/bootdir
239 %dir %{_dosemudir}/bootdir/dosemu
240 %{_dosemudir}/bootdir/dosemu/*
241 %{_mandir}/man1/d*
242 %lang(pl) %{_mandir}/pl/man1/d*
243 %lang(ru) %{_mandir}/ru/man1/d*
244 %{_pixmapsdir}/dosemu.xpm
245 %if %{with x}
246 %attr(755,root,root) %{_bindir}/xdos*
247 %{_mandir}/man1/xdosemu.1*
248 %lang(pl) %{_mandir}/pl/man1/xdosemu.1*
249 %lang(ru) %{_mandir}/ru/man1/xdosemu.1*
250 %{_desktopdir}/dosemu.desktop
251 %endif
252
253 %files utils
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_bindir}/dexeconfig
256 %attr(755,root,root) %{_bindir}/hdinfo
257 %attr(755,root,root) %{_bindir}/mkhdimage
258 #%attr(755,root,root) %{_bindir}/mkfatimage16
259 %{_mandir}/man1/mkfatimage16.1*
260 %lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
261
262 %files SDL
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_libdir}/dosemu/libplugin_sdl.so
265
266 %if %{with x}
267 %files X
268 %defattr(644,root,root,755)
269 %attr(755,root,root) %{_libdir}/dosemu/libplugin_X.so
270 %endif
This page took 0.056613 seconds and 2 git commands to generate.