]> git.pld-linux.org Git - packages/dosemu.git/blob - dosemu.spec
- BR: s/perl/perl-base/ (pointed out by Marcin Sikon <marphi /at/ student.agh.edu...
[packages/dosemu.git] / dosemu.spec
1 # NOTE: if /dev/shm is mounted, it cannot be mounted with noexec
2 #
3 # Conditional build:
4 %bcond_with     static          # link statically
5 %bcond_with     AC
6 %bcond_without  x               # X support
7 #
8 Summary:        A DOS emulator
9 Summary(de):    DOS-Emulator
10 Summary(es):    Emulador DOS
11 Summary(fr):    Emulateur DOS
12 Summary(pl):    Emulator DOS-a
13 Summary(pt_BR): Emulador DOS
14 Summary(tr):    DOS öykünümcüsü
15 Name:           dosemu
16 Version:        1.3.4
17 Release:        1
18 License:        GPL v2
19 Group:          Applications/Emulators
20 Source0:        http://dl.sourceforge.net/dosemu/%{name}-%{version}.tgz
21 # Source0-md5:  4fbfdc50ea86d860dd9cea59ea7f4b47
22 #Source2:       %{name}-sys.tar.gz
23 Source3:        %{name}-PRZECZYTAJ_TO
24 Source4:        %{name}-README.PLD
25 Source5:        %{name}.desktop
26 Source6:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
27 # Source6-md5:  7a8abf5c656e6b99bdd03a4783751895
28 Patch0:         %{name}-man-pages.patch
29 Patch1:         %{name}-make-new.patch
30 Patch2:         %{name}-%{name}_conf.patch
31 Patch3:         %{name}-doSgmlTools.patch
32 Patch4:         %{name}-makehtml.patch
33 URL:            http://www.dosemu.org/
34 BuildRequires:  SDL-devel
35 %if %{with x}
36 %if !%{with AC}
37 BuildRequires:  xorg-lib-libX11-devel
38 BuildRequires:  xorg-lib-libXext-devel
39 BuildRequires:  xorg-lib-libXxf86vm-devel
40 %if %{with static}
41 BuildRequires:  xorg-lib-libX11-static
42 BuildRequires:  xorg-lib-libXext-static
43 BuildRequires:  xorg-lib-libXxf86vm-static
44 %endif
45 %endif
46 %if %{with AC}
47 BuildRequires:  X11-devel
48 %{?with_static:BuildRequires:   X11-static}
49 %endif
50 %endif
51 BuildRequires:  autoconf >= 2.57
52 BuildRequires:  bin86
53 BuildRequires:  bison
54 BuildRequires:  docbook-dtd30-sgml
55 BuildRequires:  docbook-style-dsssl
56 BuildRequires:  flex
57 %{?with_static:BuildRequires:   glibc-static}
58 BuildRequires:  gpm-devel
59 BuildRequires:  lynx
60 BuildRequires:  openjade
61 BuildRequires:  perl-base
62 BuildRequires:  sgml-tools
63 BuildRequires:  slang-devel
64 %{?with_static:BuildRequires:   slang-static}
65 BuildRequires:  unzip
66 BuildRequires:  util-linux
67 Obsoletes:      xdosemu
68 Conflicts:      dosemu-freedos-minimal < 2.0.33
69 Conflicts:      kernel < 2.0.28
70 Conflicts:      mtools < 3.6
71 ExclusiveArch:  %{ix86}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _dosemudir      /var/lib/dosemu
75 %define         specflags       -fomit-frame-pointer
76
77 %description
78 Dosemu is a DOS emulator. Once you've installed dosemu, start the DOS
79 emulator by typing in the "dos" command.
80
81 You need to install dosemu if you use DOS programs and you want to be
82 able to run them on your GNU/Linux system. You may also need to
83 install the dosemu-freedos-* packages.
84
85 %description -l pl
86 Dosemu to Emulator systemu DOS. Po zainstalowaniu mo¿esz go uruchomiæ
87 komend± "dos".
88
89 Je¶li korzystasz z dosowych programów i chcia³by¶ je uruchamiaæ na
90 twoim linuksowym systemie zainstaluj dosemu. Mo¿esz te¿ potrzebowaæ
91 pakietów dosemu-freedos-*.
92
93 %description -l pt_BR
94 Essa é uma versão do emulador DOS que foi projetada para rodar em
95 sessões X Window. Oferece suporte para gráficos VGA bem como suporte
96 para mouse.
97
98 %package utils
99 Summary:        Utilities for dosemu
100 Summary(pl):    Programy pomocnicze do dosemu
101 Group:          Applications/Emulators
102 Requires:       %{name} = %{version}-%{release}
103
104 %description utils
105 Utilities for dosemu: dexeconfig, hdinfo, mkhdimage, mkfatimage16.
106
107 %description utils -l pl
108 Programy pomocnicze dla dosemu: dexeconfig, hdinfo, mkhdimage,
109 mkfatimage16.
110
111 %package SDL
112 Summary:        SDL plugin for dosemu
113 Summary(pl):    Wtyczka SDL dla dosemu
114 Group:          Libraries
115 Requires:       %{name} = %{version}-%{release}
116
117 %description SDL
118 SDL plugin for dosemu.
119
120 %description SDL -l pl
121 Wtyczka SDL dla dosemu.
122
123 %package X
124 Summary:        X plugin for dosemu
125 Summary(pl):    Wtyczka X dla dosemu
126 Group:          Libraries
127 Requires:       %{name} = %{version}-%{release}
128
129 %description X
130 X plugin for dosemu.
131
132 %description X -l pl
133 Wtyczka X dla dosemu.
134
135 %prep
136 %setup -q -a6
137 %patch0 -p1
138 %patch1 -p1
139 %patch2 -p1
140 %patch3 -p1
141 %patch4 -p1
142
143 %build
144 OPTFLAGS="%{rpmcflags}"; export OPTFLAGS
145
146 ./mkpluginhooks enable plugin_keyboard off plugin_kbd_unicode on \
147 plugin_extra_charset on plugin_term on plugin_translate on plugin_demo off
148
149 %{__autoconf}
150 # configure2_13 must be used though because of ./default-configure
151
152 # non-X version
153 %configure2_13 \
154         %{?with_static:--enable-linkstatic} \
155         --enable-new-intcode \
156         --enable-aspi \
157         %{!?with_x:--without-x}
158
159 %{__make} \
160         WAIT=no
161
162 %{__make} -C man
163 mv -f man/dosemu.bin.1 man/dosemu.1
164 echo '.so dosemu.1' > man/dos.1
165 mv -f man/ru/dosemu.bin.1 man/ru/dosemu.1
166 echo '.so dosemu.1' > man/ru/dos.1
167
168 mv -f pl/man1/dos.1 pl/man1/dosemu.1
169 echo '.so dosemu.1' > pl/man1/dos.1
170 echo '.so dosemu.1' > pl/man1/xdosemu.1
171 echo '.so dosemu.1' > pl/man1/dosdebug.1
172
173 # documentation
174 %{__make} -C src/doc/DANG html
175 %{__make} -C src/doc/HOWTO html
176 %{__make} -C src/doc/README html
177
178 find src/doc -name "*.html" -exec cp -f '{}' doc/ ';'
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}} \
183         $RPM_BUILD_ROOT{%{_mandir}/man1,%{_mandir}/{pl,ru}/man1} \
184         $RPM_BUILD_ROOT%{_dosemudir}/bootdir/{dosemu,freedos/doc/fdkernel} \
185         $RPM_BUILD_ROOT%{_libdir}/dosemu
186
187 #%%{__make} install \
188 #       DESTDIR=$RPM_BUILD_ROOT
189
190 install bin/midid $RPM_BUILD_ROOT%{_bindir}/midid
191 install bin/dosemu.bin $RPM_BUILD_ROOT%{_bindir}/dosemu
192 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/dos
193 %if %{with x}
194 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdos
195 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosemu
196 ln -sf dosemu $RPM_BUILD_ROOT%{_bindir}/xdosexec
197 %endif
198
199 install bin/libplugin*.so  $RPM_BUILD_ROOT%{_libdir}/dosemu
200
201 install bin/{dosdebug,mkfatimage16} $RPM_BUILD_ROOT%{_bindir}
202 install src/tools/periph/{dexeconfig,hdinfo,mkhdimage} $RPM_BUILD_ROOT%{_bindir}
203 ln -sf dos $RPM_BUILD_ROOT%{_bindir}/dosexec
204
205 install etc/dosemu.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
206 install etc/dosemu.users.example $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.users
207 install etc/global.conf $RPM_BUILD_ROOT%{_dosemudir}/global.conf
208 install etc/dosemu.conf $RPM_BUILD_ROOT%{_sysconfdir}/dosemu.conf
209
210 install man/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/man1
211 install pl/man1/{dosemu.1,dosdebug.1,xdosemu.1,dos.1} $RPM_BUILD_ROOT%{_mandir}/pl/man1
212 install man/ru/{dosemu.1,dosdebug.1,xdosemu.1,dos.1,mkfatimage16.1} $RPM_BUILD_ROOT%{_mandir}/ru/man1
213
214 install commands/*.com $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
215 install commands/*.sys $RPM_BUILD_ROOT%{_dosemudir}/bootdir/dosemu
216 cp %{SOURCE3} PRZECZYTAJ_TO
217 cp %{SOURCE4} README.PLD
218 install %{SOURCE5} $RPM_BUILD_ROOT%{_desktopdir}
219
220 rm -f doc/{configuration,dosemu.lsm}
221
222 %clean
223 rm -rf $RPM_BUILD_ROOT
224
225 %files
226 %defattr(644,root,root,755)
227 %doc QuickStart COPYING ChangeLog* doc/* README.PLD
228 %lang(pl) %doc PRZECZYTAJ_TO
229 %dir %{_dosemudir}
230 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.conf
231 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dosemu.users
232 %config(noreplace) %verify(not md5 mtime size) %{_dosemudir}/global.conf
233 %attr(755,root,root) %{_bindir}/dos
234 %attr(755,root,root) %{_bindir}/dosdebug
235 %attr(755,root,root) %{_bindir}/dosemu
236 %attr(755,root,root) %{_bindir}/dosexec
237 %attr(755,root,root) %{_bindir}/midid
238 %dir %{_libdir}/dosemu
239 %{_libdir}/dosemu/libplugin_gpm.so
240 %{_libdir}/dosemu/libplugin_term.so
241 %dir %{_dosemudir}/bootdir
242 %dir %{_dosemudir}/bootdir/dosemu
243 %{_dosemudir}/bootdir/dosemu/*
244 %{_mandir}/man1/d*
245 %lang(pl) %{_mandir}/pl/man1/d*
246 %lang(ru) %{_mandir}/ru/man1/d*
247 %{_pixmapsdir}/dosemu.xpm
248 %if %{with x}
249 %attr(755,root,root) %{_bindir}/xdos*
250 %{_mandir}/man1/xdosemu.1*
251 %lang(pl) %{_mandir}/pl/man1/xdosemu.1*
252 %lang(ru) %{_mandir}/ru/man1/xdosemu.1*
253 %{_desktopdir}/dosemu.desktop
254 %endif
255
256 %files utils
257 %defattr(644,root,root,755)
258 %attr(755,root,root) %{_bindir}/dexeconfig
259 %attr(755,root,root) %{_bindir}/hdinfo
260 %attr(755,root,root) %{_bindir}/mkhdimage
261 %attr(755,root,root) %{_bindir}/mkfatimage16
262 %{_mandir}/man1/mkfatimage16.1*
263 %lang(ru) %{_mandir}/ru/man1/mkfatimage16.1*
264
265 %files SDL
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_libdir}/dosemu/libplugin_sdl.so
268
269 %if %{with x}
270 %files X
271 %defattr(644,root,root,755)
272 %attr(755,root,root) %{_libdir}/dosemu/libplugin_X.so
273 %endif
This page took 0.096649 seconds and 3 git commands to generate.