]> git.pld-linux.org Git - packages/dopewars.git/blob - dopewars.spec
- rel 8; build fixed
[packages/dopewars.git] / dopewars.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk             # don't build GTK+ client
4 %bcond_without  curses          # don't build curses client
5 %bcond_without  sdl             # don't use sdl sound output
6 %bcond_with     esd             # don't use esd sound output
7 #
8 Summary:        Drug dealing game
9 Summary(pl.UTF-8):      Gra polegająca na handlowaniu narkotykami
10 Name:           dopewars
11 Version:        1.5.12
12 Release:        8
13 License:        GPL
14 Group:          Applications/Games
15 Source0:        http://downloads.sourceforge.net/dopewars/%{name}-%{version}.tar.gz
16 # Source0-md5:  debf749de9053dc2fb2e74c37ae06206
17 Patch0:         %{name}-desktop.patch
18 Patch1:         %{name}-scoredir.patch
19 Patch2:         %{name}-build.patch
20 URL:            http://dopewars.sourceforge.net/
21 %{?with_sdl:BuildRequires:      SDL-devel >= 1.0.0}
22 %{?with_sdl:BuildRequires:      SDL_mixer-devel}
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 %{?with_esd:BuildRequires:      esound-devel >= 0.0.20}
26 BuildRequires:  gettext-tools
27 BuildRequires:  glib2-devel >= 2.0.0
28 BuildRequires:  gtk+-devel
29 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.0.0}
30 %{?with_curses:BuildRequires:   ncurses-devel}
31 BuildRequires:  pkgconfig
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Based on John E. Dell's old Drug Wars game, dopewars is a simulation
36 of an imaginary drug market. dopewars is an All-American game which
37 features buying, selling, and trying to get past the cops!
38
39 The first thing you need to do is pay off your debt to the Loan Shark.
40 After that, your goal is to make as much money as possible (and stay
41 alive)! You have one month of game time to make your fortune.
42
43 dopewars supports multiple players via TCP/IP. Chatting to and
44 fighting with other players (computer or human) is supported; check
45 the command line switches (via dopewars -h) for further information.
46
47 %description -l pl.UTF-8
48 dopewars jest symulacją wyimaginowanego narkotykowego rynku, bazującą
49 na starej grze Drug Wars autorstwa Johna E. Della. Jest to gra w
50 amerykańskim stylu polegająca na kupowaniu, sprzedawaniu i omijaniu
51 policji!
52
53 Pierwszą rzeczą jaką trzeba zrobić jest spłacenie długu. Potem celem
54 jest zdobycie jak największej ilości pieniędzy (i przeżycie)! Gracz ma
55 jeden miesiąc gry na zdobycie fortuny.
56
57 W dopewars można grać z wieloma graczami poprzez TCP/IP. Można także z
58 nimi rozmawiać i walczyć; więcej informacji w opisie parametrów linii
59 poleceń (pokaże je dopewars -h).
60
61 %prep
62 %setup -q
63 %patch0 -p1
64 %patch1 -p1
65 %patch2 -p1
66
67 %build
68 rm -f missing
69 %{__aclocal}
70 %{__autoconf}
71 %{__automake}
72 %configure \
73         LIBS="-ltinfo" \
74         --enable-plugins \
75         --enable-networking \
76         %{?with_esd:--with-esd} \
77         %{?with_sdl:--with-sdl} \
78         %{?with_curses:--enable-curses-client} \
79         %{?with_gtk:--enable-gui-client} \
80         %{?with_gtk:--enable-gui-server}
81
82 %{__make} \
83         CFLAGS="%{rpmcflags} -Wall -I/usr/include/ncurses"
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT%{_desktopdir}
88
89 %{__make} install \
90         SCOREDIR=$RPM_BUILD_ROOT/var/games/dopewars \
91         DESTDIR=${RPM_BUILD_ROOT}
92
93 # I think this could be done somehow prettier
94 mv $RPM_BUILD_ROOT%{_datadir}/gnome/apps/Games/dopewars.desktop $RPM_BUILD_ROOT%{_desktopdir}
95
96 rm -f doc/help/Makefile*
97 rm -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
98
99 # es_ES.po seems to be newer than es.po
100 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/es_ES/LC_MESSAGES/* \
101         $RPM_BUILD_ROOT%{_datadir}/locale/es/LC_MESSAGES/
102 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/es_ES
103
104 %find_lang %{name}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %triggerpostun -- dopewars < 1.5.12-0.1
110 # move scorefile
111 mv -f %{_datadir}/dopewars.sco.rpmsave /var/games/dopewars/dopewars.sco
112 chown root:games /var/games/dopewars/dopewars.sco
113 chmod 660 /var/games/dopewars/dopewars.sco
114 %{_bindir}/dopewars -C /var/games/dopewars/dopewars.sco
115
116 %files -f %{name}.lang
117 %defattr(644,root,root,755)
118 %doc ChangeLog LICENCE README doc/{*.html,help}
119 %attr(2755,root,games) %{_bindir}/dopewars
120 %attr(770,root,games) /var/games/dopewars
121 %{_mandir}/man6/*
122 %{_libdir}/%{name}
123 %{_desktopdir}/*.desktop
124 %{_pixmapsdir}/*
125 %{_datadir}/%{name}
This page took 0.065367 seconds and 3 git commands to generate.