]> git.pld-linux.org Git - packages/dopewars.git/blob - dopewars.spec
- switched to the new style bconds
[packages/dopewars.git] / dopewars.spec
1 #
2 # TODO: move scores file to /var/games!
3 #
4 # Conditional build:
5 %bcond_without gtk              # don't build gtk client
6 %bcond_without curses           # don't build curses client
7 %bcond_without sdl              # don't use sdl sound output
8 %bcond_without esd              # don't use esd sound output
9 #
10 Summary:        Drug dealing game
11 Summary(pl):    Gra polegaj±ca na handlowaniu narkotykami
12 Name:           dopewars
13 Version:        1.5.9
14 Release:        2
15 License:        GPL
16 Group:          Applications/Games
17 Source0:        http://dl.sourceforge.net/dopewars/%{name}-%{version}.tar.gz
18 # Source0-md5:  77cdbc59e7550cfda7dfb7f6b7a01050
19 Patch0:         %{name}-desktop.patch
20 URL:            http://dopewars.sourceforge.net/
21 %{?with_sdl:BuildRequires:      SDL-devel >= 1.0.0}
22 %{?with_sdl:BuildRequires:      SDL_mixer-devel}
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 %{?with_esd:BuildRequires:      esound-devel >= 0.0.20}
26 BuildRequires:  glib2-devel >= 2.0.0
27 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2.0.0}
28 %{?with_curses:BuildRequires:   ncurses-devel}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Based on John E. Dell's old Drug Wars game, dopewars is a simulation
33 of an imaginary drug market. dopewars is an All-American game which
34 features buying, selling, and trying to get past the cops!
35
36 The first thing you need to do is pay off your debt to the Loan Shark.
37 After that, your goal is to make as much money as possible (and stay
38 alive)! You have one month of game time to make your fortune.
39
40 dopewars supports multiple players via TCP/IP. Chatting to and
41 fighting with other players (computer or human) is supported; check
42 the command line switches (via dopewars -h) for further information.
43
44 %description -l pl
45 dopewars jest symulacj± wyimaginowanego narkotykowego rynku, bazuj±c±
46 na starej grze Drug Wars autorstwa Johna E. Della. Jest to gra w
47 amerykañskim stylu polegaj±ca na kupowaniu, sprzedawaniu i omijaniu
48 policji!
49
50 Pierwsz± rzecz± jak± trzeba zrobiæ jest sp³acenie d³ugu. Potem celem
51 jest zdobycie jak najwiêkszej ilo¶ci pieniêdzy (i prze¿ycie)! Gracz ma
52 jeden miesi±c gry na zdobycie fortuny.
53
54 W dopewars mo¿na graæ z wieloma graczami poprzez TCP/IP. Mo¿na tak¿e z
55 nimi rozmawiaæ i walczyæ; wiêcej informacji w opisie parametrów linii
56 poleceñ (poka¿e je dopewars -h).
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 %build
63 rm -f missing
64 %{__aclocal}
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         --enable-plugins \
69         --enable-networking \
70         %{?with_esd:--with-esd} \
71         %{?with_sdl:--with-sdl} \
72         %{?with_curses:--enable-curses-client} \
73         %{?with_gtk:--enable-gui-client} \
74         %{?with_gtk:--enable-gui-server}
75
76 %{__make} CFLAGS="%{rpmcflags} -Wall -I/usr/include/ncurses"
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_desktopdir}
81
82 %{__make} install \
83         DESTDIR=${RPM_BUILD_ROOT}
84
85 # I think this could be done somehow prettier
86 mv $RPM_BUILD_ROOT%{_datadir}/gnome/apps/Games/dopewars.desktop $RPM_BUILD_ROOT%{_desktopdir}
87
88 rm -f doc/help/Makefile*
89
90 %find_lang %{name}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 %{_bindir}/dopewars -C %{_datadir}/dopewars.sco
97
98 %files -f %{name}.lang
99 %defattr(644,root,root,755)
100 %doc ChangeLog LICENCE README doc/{*.html,help}
101 %attr(2755,root,games) %{_bindir}/*
102 %attr(0660,root,games) %config(noreplace) %verify(not size mtime md5) %{_datadir}/dopewars.sco
103 %{_mandir}/man6/*
104 %{_libdir}/%{name}
105 %{_desktopdir}/*
106 %{_pixmapsdir}/*
107 %{_datadir}/%{name}
This page took 0.067855 seconds and 3 git commands to generate.