]> git.pld-linux.org Git - packages/doomsday.git/commitdiff
- rel 9; build fixed auto/th/doomsday-1.9.0-0.beta6.9.9
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 7 Nov 2013 13:25:35 +0000 (14:25 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 7 Nov 2013 13:25:35 +0000 (14:25 +0100)
doomsday-format.patch [new file with mode: 0644]
doomsday.spec

diff --git a/doomsday-format.patch b/doomsday-format.patch
new file mode 100644 (file)
index 0000000..d684783
--- /dev/null
@@ -0,0 +1,44 @@
+--- deng-1.9.0-beta6.9/doomsday/plugins/jdoom/src/m_cheat.c~   2010-04-07 22:52:50.000000000 +0200
++++ deng-1.9.0-beta6.9/doomsday/plugins/jdoom/src/m_cheat.c    2013-11-07 14:11:30.116079643 +0100
+@@ -489,7 +489,7 @@
+     P_SetMessage(plr, textBuffer, false);
+     // Also print some information to the console.
+-    Con_Message(textBuffer);
++    Con_Message("%s", textBuffer);
+     sub = plr->plr->mo->subsector;
+     Con_Message("\nSubsector %i:\n", P_ToIndex(sub));
+     Con_Message("  FloorZ:%g Material:%s\n",
+--- deng-1.9.0-beta6.9/doomsday/plugins/common/src/p_xgline.c~ 2010-04-07 22:52:50.000000000 +0200
++++ deng-1.9.0-beta6.9/doomsday/plugins/common/src/p_xgline.c  2013-11-07 14:12:20.268270732 +0100
+@@ -424,7 +424,7 @@
+     va_start(args, format);
+     dd_vsnprintf(buffer, sizeof(buffer), format, args);
+     strcat(buffer, "\n");
+-    Con_Message(buffer);
++    Con_Message("%s", buffer);
+     va_end(args);
+ }
+--- deng-1.9.0-beta6.9/doomsday/plugins/jheretic/src/m_cheat.c~        2010-04-07 22:52:50.000000000 +0200
++++ deng-1.9.0-beta6.9/doomsday/plugins/jheretic/src/m_cheat.c 2013-11-07 14:17:09.758211578 +0100
+@@ -382,7 +382,7 @@
+     P_SetMessage(plr, textBuffer, false);
+     // Also print some information to the console.
+-    Con_Message(textBuffer);
++    Con_Message("%s", textBuffer);
+     sub = plr->plr->mo->subsector;
+     Con_Message("\nSubsector %i:\n", P_ToIndex(sub));
+     Con_Message("  FloorZ:%g Material:%s\n",
+--- deng-1.9.0-beta6.9/doomsday/plugins/jhexen/src/m_cheat.c~  2010-04-07 22:52:50.000000000 +0200
++++ deng-1.9.0-beta6.9/doomsday/plugins/jhexen/src/m_cheat.c   2013-11-07 14:23:54.638714186 +0100
+@@ -454,7 +454,7 @@
+     P_SetMessage(plr, textBuffer, false);
+     // Also print some information to the console.
+-    Con_Message(textBuffer);
++    Con_Message("%s", textBuffer);
+     sub = plr->plr->mo->subsector;
+     Con_Message("\nSubsector %i:\n", P_ToIndex(sub));
+     Con_Message("  FloorZ:%g Material:%s\n",
index 339bd39a764e87b1d5d65e2d7987ac5e85ee5805..0ca315b107b44db29acd85016bb9dd7f7b61828f 100644 (file)
@@ -1,7 +1,7 @@
 # TODO
 # - sync pl
 %define                subver  beta6.9
-%define                rel             8
+%define                rel             9
 Summary:       jDoom, jHeretic and jHexen for Linux
 Summary(pl.UTF-8):     jDoom, jHeretic i jHexen dla Linuksa
 Name:          doomsday
@@ -18,6 +18,7 @@ Source2:      http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x
 Source3:       http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
 # Source3-md5: c89e36c49eabe2846137f313a5250308
 Patch0:                %{name}-libpng15.patch
+Patch1:                %{name}-format.patch
 URL:           http://www.dengine.net/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-GLU-devel
@@ -46,6 +47,7 @@ jDoom, jHeretic i jHexen dla Linuksa.
 %prep
 %setup -q -n deng-%{version}-%{subver}
 %patch0 -p1
+%patch1 -p1
 
 %build
 install -d build
This page took 0.161797 seconds and 4 git commands to generate.