]> git.pld-linux.org Git - packages/doomsday.git/commitdiff
- Up to the latest 1.15.4.
authorLukasz Masko <lmasko@pld-linux.org>
Sat, 17 Oct 2015 18:28:08 +0000 (20:28 +0200)
committerLukasz Masko <lmasko@pld-linux.org>
Sat, 17 Oct 2015 18:28:08 +0000 (20:28 +0200)
- Deffinitely needs cleenup and proper BRs in the spec.

doomsday-format.patch [deleted file]
doomsday-libpng15.patch [deleted file]
doomsday.spec

diff --git a/doomsday-format.patch b/doomsday-format.patch
deleted file mode 100644 (file)
index d684783..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
---- deng-1.9.0-beta6.9/doomsday/plugins/jdoom/src/m_cheat.c~   2010-04-07 22:52:50.000000000 +0200
-+++ deng-1.9.0-beta6.9/doomsday/plugins/jdoom/src/m_cheat.c    2013-11-07 14:11:30.116079643 +0100
-@@ -489,7 +489,7 @@
-     P_SetMessage(plr, textBuffer, false);
-     // Also print some information to the console.
--    Con_Message(textBuffer);
-+    Con_Message("%s", textBuffer);
-     sub = plr->plr->mo->subsector;
-     Con_Message("\nSubsector %i:\n", P_ToIndex(sub));
-     Con_Message("  FloorZ:%g Material:%s\n",
---- deng-1.9.0-beta6.9/doomsday/plugins/common/src/p_xgline.c~ 2010-04-07 22:52:50.000000000 +0200
-+++ deng-1.9.0-beta6.9/doomsday/plugins/common/src/p_xgline.c  2013-11-07 14:12:20.268270732 +0100
-@@ -424,7 +424,7 @@
-     va_start(args, format);
-     dd_vsnprintf(buffer, sizeof(buffer), format, args);
-     strcat(buffer, "\n");
--    Con_Message(buffer);
-+    Con_Message("%s", buffer);
-     va_end(args);
- }
---- deng-1.9.0-beta6.9/doomsday/plugins/jheretic/src/m_cheat.c~        2010-04-07 22:52:50.000000000 +0200
-+++ deng-1.9.0-beta6.9/doomsday/plugins/jheretic/src/m_cheat.c 2013-11-07 14:17:09.758211578 +0100
-@@ -382,7 +382,7 @@
-     P_SetMessage(plr, textBuffer, false);
-     // Also print some information to the console.
--    Con_Message(textBuffer);
-+    Con_Message("%s", textBuffer);
-     sub = plr->plr->mo->subsector;
-     Con_Message("\nSubsector %i:\n", P_ToIndex(sub));
-     Con_Message("  FloorZ:%g Material:%s\n",
---- deng-1.9.0-beta6.9/doomsday/plugins/jhexen/src/m_cheat.c~  2010-04-07 22:52:50.000000000 +0200
-+++ deng-1.9.0-beta6.9/doomsday/plugins/jhexen/src/m_cheat.c   2013-11-07 14:23:54.638714186 +0100
-@@ -454,7 +454,7 @@
-     P_SetMessage(plr, textBuffer, false);
-     // Also print some information to the console.
--    Con_Message(textBuffer);
-+    Con_Message("%s", textBuffer);
-     sub = plr->plr->mo->subsector;
-     Con_Message("\nSubsector %i:\n", P_ToIndex(sub));
-     Con_Message("  FloorZ:%g Material:%s\n",
diff --git a/doomsday-libpng15.patch b/doomsday-libpng15.patch
deleted file mode 100644 (file)
index 8cba0e1..0000000
+++ /dev/null
@@ -1,95 +0,0 @@
---- deng-1.9.0-beta6.9/doomsday/engine/portable/src/gl_png.c~  2010-04-07 22:52:50.000000000 +0200
-+++ deng-1.9.0-beta6.9/doomsday/engine/portable/src/gl_png.c   2012-02-12 19:29:04.632968012 +0100
-@@ -89,8 +89,9 @@
-     png_structp png_ptr = 0;
-     png_infop   png_info = 0, end_info = 0;
-     png_bytep  *rows, pixel;
-+    png_colorp  png_palette;
-     unsigned char *retbuf = 0;  // The return buffer.
--    int         i, k, off;
-+    int         i, k, off, num_palette;
-     if((file = F_Open(fileName, "rb")) == NULL)
-         return NULL;
-@@ -119,18 +120,18 @@
-                     // Check if it can be used.
-                     canLoad = true;
--                    if(png_info->bit_depth != 8)
-+                    if(png_get_bit_depth(png_ptr, png_info) != 8)
-                     {
-                         Con_Message("PNG_Load: \"%s\": Bit depth must be 8.\n", fileName);
-                         canLoad = false;
-                     }
--                    else if(!png_info->width || !png_info->height)
-+                    else if(!png_get_image_width(png_ptr, png_info) || !png_get_image_height(png_ptr, png_info))
-                     {
-                         Con_Message("PNG_Load: \"%s\": Bad file? Size is zero.\n", fileName);
-                         canLoad = false;
-                     }
--                    else if(png_info->channels <= 2 && 
--                            png_info->color_type == PNG_COLOR_TYPE_PALETTE &&
-+                    else if(png_get_channels(png_ptr, png_info) <= 2 && 
-+                            png_get_color_type(png_ptr, png_info) == PNG_COLOR_TYPE_PALETTE &&
-                             !png_get_valid(png_ptr, png_info, PNG_INFO_PLTE))
-                     {
-                         Con_Message("PNG_Load: \"%s\": Palette is invalid.\n", fileName);
-@@ -140,9 +141,9 @@
-                     if(canLoad)
-                     {
-                         // Information about the image.
--                        *width = png_info->width;
--                        *height = png_info->height;
--                        *pixelSize = png_info->channels;
-+                        *width = png_get_image_width(png_ptr, png_info);
-+                        *height = png_get_image_height(png_ptr, png_info);
-+                        *pixelSize = png_get_channels(png_ptr, png_info);
-                         // Paletted images have three color components
-                         // per pixel.
-@@ -154,33 +155,34 @@
-                         // OK, let's copy it into Doomsday's buffer.
-                         // \fixme Why not load directly into it?
-                         retbuf =
--                            M_Malloc(4 * png_info->width * png_info->height);
-+                            M_Malloc(4 * png_get_image_width(png_ptr, png_info) * png_get_image_height(png_ptr, png_info));
-                         rows = png_get_rows(png_ptr, png_info);
-+                      png_get_PLTE(png_ptr, png_info, &png_palette, &num_palette);
-                         for(i = 0; i < *height; ++i)
-                         {
--                            if(png_info->channels >= 3)
-+                            if(png_get_channels(png_ptr, png_info) >= 3)
-                             {
--                                memcpy(retbuf + i * (*pixelSize) * png_info->width,
--                                       rows[i], (*pixelSize) * png_info->width);
-+                                memcpy(retbuf + i * (*pixelSize) * png_get_image_width(png_ptr, png_info),
-+                                       rows[i], (*pixelSize) * png_get_image_width(png_ptr, png_info));
-                             }
-                             else // Paletted image.
-                             {
-                                 for(k = 0; k < *width; ++k)
-                                 {
--                                    pixel = retbuf + ((*pixelSize) * (i * png_info->width + k));
--                                    off = k * png_info->channels;
--                                    if(png_info->color_type == PNG_COLOR_TYPE_PALETTE)
-+                                    pixel = retbuf + ((*pixelSize) * (i * png_get_image_width(png_ptr, png_info) + k));
-+                                    off = k * png_get_channels(png_ptr, png_info);
-+                                    if(png_get_color_type(png_ptr, png_info) == PNG_COLOR_TYPE_PALETTE)
-                                     {
--                                        pixel[0] = png_info->palette[rows[i][off]].red;
--                                        pixel[1] = png_info->palette[rows[i][off]].green;
--                                        pixel[2] = png_info->palette[rows[i][off]].blue;
-+                                        pixel[0] = png_palette[rows[i][off]].red;
-+                                        pixel[1] = png_palette[rows[i][off]].green;
-+                                        pixel[2] = png_palette[rows[i][off]].blue;
-                                     }
-                                     else
-                                     {
-                                         // Grayscale.
-                                         pixel[0] = pixel[1] = pixel[2] = rows[i][off];
-                                     }
--                                    if(png_info->channels == 2) // Alpha data.
-+                                    if(png_get_channels(png_ptr, png_info) == 2) // Alpha data.
-                                     {
-                                         pixel[3] = rows[i][off + 1];
-                                     }
index 2511d35532f34c6d750e496d503ad9d6bb27d6ce..5de01d6e243e131b131383f295888d3003d7cfa6 100644 (file)
@@ -1,16 +1,16 @@
 # TODO
 # - sync pl
-%define                subver  beta6.9
-%define                rel             10
+# - cleen up spec
+%define                subver  stable
 Summary:       jDoom, jHeretic and jHexen for Linux
 Summary(pl.UTF-8):     jDoom, jHeretic i jHexen dla Linuksa
 Name:          doomsday
-Version:       1.9.0
-Release:       0.%{subver}.%{rel}
+Version:       1.15.4
+Release:       0.1
 License:       GPL v2 / CC 3.0 (icons)
 Group:         Applications/Games
-Source0:       http://downloads.sourceforge.net/deng/deng-%{version}-%{subver}.tar.gz
-# Source0-md5: 907ef41b70e2dbf148ef7e4a0350c6bd
+Source0:       http://downloads.sourceforge.net/deng/%{name}-%{subver}-%{version}.tar.gz
+# Source0-md5: 8329eacdea73edca7aea4034ca8d78aa
 Source1:       http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
 # Source1-md5: b7b7a9389eba56679e5db65d95c06803
 Source2:       http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
@@ -23,10 +23,10 @@ URL:                http://www.dengine.net/
 BuildRequires: OpenAL-devel
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
-BuildRequires: SDL-devel >= 1.2.0
-BuildRequires: SDL_mixer-devel
-BuildRequires: SDL_net-devel
-BuildRequires: cmake >= 2.4
+BuildRequires: SDL2-devel
+BuildRequires: SDL2_mixer-devel
+BuildRequires: qt4-qmake
+BuildRequires: assimp-devel
 BuildRequires: curl-devel
 BuildRequires: libpng-devel
 BuildRequires: ncurses-devel
@@ -45,27 +45,22 @@ hardware accelerated 3D graphics, surround sound and much more.
 jDoom, jHeretic i jHexen dla Linuksa.
 
 %prep
-%setup -q -n deng-%{version}-%{subver}
-%patch0 -p1
-%patch1 -p1
+%setup -q -n doomsday-%{subver}-%{version}
+#%patch0 -p1
+#%patch1 -p1
 
 %build
 install -d build
 cd build
 LDFLAGS="-lm"
-%cmake \
-       -DBUILDOPENAL=1 \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-       -DCURSES_INCLUDE_PATH=/usr/include/ncurses \
-       -Dlibdir=%{_libdir} \
-       ../doomsday
+qmake-qt4 CONFIG+=deng_notools \
+       -r ../doomsday/doomsday.pro
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_desktopdir}
-%{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+%{__make} -C build install INSTALL_ROOT=$RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
@@ -111,7 +106,7 @@ EOF
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
+%post -p /sbin/ldconfig
 %banner -o -e %{name} <<-EOF
 To run doomsday you need some WAD file: either freedoom package
 or some shareware or commercial WAD from Doom or Heretic:
@@ -121,16 +116,31 @@ When you have them, run doomsday with:
 doomsday -game [ jdoom | jheretic | jhexen ]
 EOF
 
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc doomsday/build/README
+#%doc doomsday/build/README
 %attr(755,root,root) %{_bindir}/doomsday
-%attr(755,root,root) %{_libdir}/libdpdehread.so
-%attr(755,root,root) %{_libdir}/libdpwadmapconverter.so
-%attr(755,root,root) %{_libdir}/libjdoom.so
-%attr(755,root,root) %{_libdir}/libjheretic.so
-%attr(755,root,root) %{_libdir}/libjhexen.so
-%attr(755,root,root) %{_libdir}/libdsopenal.so
-%{_datadir}/deng
+%attr(755,root,root) %{_bindir}/doomsday-server
+%attr(755,root,root) %{_bindir}/launch-doomsday
+
+%attr(755,root,root) %{_libdir}/libdeng_core.so.2.0.0
+%attr(755,root,root) %ghost %{_libdir}/libdeng_core.so.2
+%attr(755,root,root) %{_libdir}/libdeng_appfw.so.1.15.4
+%attr(755,root,root) %ghost %{_libdir}/libdeng_appfw.so.1
+%attr(755,root,root) %{_libdir}/libdeng_doomsday.so.1.15.4
+%attr(755,root,root) %ghost %{_libdir}/libdeng_doomsday.so.1
+%attr(755,root,root) %{_libdir}/libdeng_gui.so.1.15.4
+%attr(755,root,root) %ghost %{_libdir}/libdeng_gui.so.1
+%attr(755,root,root) %{_libdir}/libdeng_legacy.so.1.15.4
+%attr(755,root,root) %ghost %{_libdir}/libdeng_legacy.so.1
+%attr(755,root,root) %{_libdir}/libdeng_shell.so.1.15.4
+%attr(755,root,root) %ghost %{_libdir}/libdeng_shell.so.1
+
+%{_libdir}/doomsday
+%{_datadir}/doomsday
 %{_desktopdir}/*.desktop
 %{_pixmapsdir}/*.png
+%{_mandir}/man6/*
+
This page took 0.039496 seconds and 4 git commands to generate.