]> git.pld-linux.org Git - packages/doomsday.git/blobdiff - doomsday.spec
cleanup
[packages/doomsday.git] / doomsday.spec
index 7819b582846648f4c2e08a5fecad331674aa5e9a..1653e23ec527f64d8be7c1ba5ecb1e72935f379d 100644 (file)
@@ -1,36 +1,47 @@
 # TODO
 # - sync pl
-%define                subver  beta6.9
-%define                rel             3
+# - clean up spec. cleanup what?
+%define                subver  stable
 Summary:       jDoom, jHeretic and jHexen for Linux
 Summary(pl.UTF-8):     jDoom, jHeretic i jHexen dla Linuksa
 Name:          doomsday
-Version:       1.9.0
-Release:       0.%{subver}.%{rel}
+Version:       1.15.4
+Release:       0.1
 License:       GPL v2 / CC 3.0 (icons)
 Group:         Applications/Games
-Source0:       http://downloads.sourceforge.net/deng/deng-%{version}-%{subver}.tar.gz
-# Source0-md5: 907ef41b70e2dbf148ef7e4a0350c6bd
+Source0:       http://downloads.sourceforge.net/deng/%{name}-%{subver}-%{version}.tar.gz
+# Source0-md5: 8329eacdea73edca7aea4034ca8d78aa
 Source1:       http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
 # Source1-md5: b7b7a9389eba56679e5db65d95c06803
 Source2:       http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
 # Source2-md5: 573845e6e747f68617ac67f3a87dc78e
 Source3:       http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
 # Source3-md5: c89e36c49eabe2846137f313a5250308
+Source4:       %{name}-doom.desktop
+Source5:       %{name}-heretic.desktop
+Source6:       %{name}-hexen.desktop
+#Patch0:               %{name}-libpng15.patch
+#Patch1:               %{name}-format.patch
 URL:           http://www.dengine.net/
-BuildRequires: OpenAL-devel
-BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
-BuildRequires: SDL-devel >= 1.2.0
-BuildRequires: SDL_mixer-devel
-BuildRequires: SDL_net-devel
-BuildRequires: cmake >= 2.4
-BuildRequires: curl-devel
+BuildRequires: QtCore-devel
+BuildRequires: QtNetwork-devel
+BuildRequires: QtOpenGL-devel
+BuildRequires: SDL2-devel
+BuildRequires: SDL2_mixer-devel
+BuildRequires: assimp-devel
 BuildRequires: libpng-devel
+BuildRequires: libstdc++-devel
 BuildRequires: ncurses-devel
+BuildRequires: pkgconfig
 BuildRequires: python
 BuildRequires: python-modules
+BuildRequires: qt4-build
+BuildRequires: qt4-qmake
+BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.595
+BuildRequires: xorg-lib-libXrandr-devel
+Requires(post):        /sbin/ldconfig
 Requires:      TiMidity++
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -43,71 +54,44 @@ hardware accelerated 3D graphics, surround sound and much more.
 jDoom, jHeretic i jHexen dla Linuksa.
 
 %prep
-%setup -q -n deng-%{version}-%{subver}
+%setup -q -n %{name}-%{subver}-%{version}
+#%patch0 -p1
+#%patch1 -p1
 
 %build
 install -d build
 cd build
 LDFLAGS="-lm"
-%cmake \
-       -DBUILDOPENAL=1 \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-       -DCURSES_INCLUDE_PATH=/usr/include/ncurses \
-       -Dlibdir=%{_libdir} \
-       ../doomsday
+qmake-qt4 CONFIG+=deng_notools \
+       -r ../doomsday/doomsday.pro
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_desktopdir}
 %{__make} -C build install \
-       DESTDIR=$RPM_BUILD_ROOT
+       INSTALL_ROOT=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT%{_pixmapsdir}
-cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
-cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
-cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
-
-cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
-[Desktop Entry]
-Name=Doom
-Comment=Doom for linux
-Exec=doomsday -game jdoom
-Icon=doom.png
-Terminal=false
-Type=Application
-Categories=Game;FirstPersonGame;
-Encoding=UTF-8
-EOF
+# no -devel package. cleanup
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_*.so
+# junk links
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_*.so.1.15
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdeng_core.so.2.0
 
-cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
-[Desktop Entry]
-Name=Hexen
-Comment=Hexen for linux
-Exec=doomsday -game jhexen
-Icon=hexen.png
-Terminal=false
-Type=Application
-Categories=Game;FirstPersonGame;
-Encoding=UTF-8
-EOF
+install -d $RPM_BUILD_ROOT%{_pixmapsdir}
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
 
-cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
-[Desktop Entry]
-Name=Heretic
-Comment=Heretic for linux
-Exec=doomsday -game jheretic
-Icon=heretic.png
-Terminal=false
-Type=Application
-Categories=Game;FirstPersonGame;
-Encoding=UTF-8
-EOF
+cp -p %{_sourcedir}/%{name}-doom.desktop $RPM_BUILD_ROOT%{_desktopdir}
+cp -p %{_sourcedir}/%{name}-hexen.desktop $RPM_BUILD_ROOT%{_desktopdir}
+cp -p %{_sourcedir}/%{name}-heretic.desktop $RPM_BUILD_ROOT%{_desktopdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
+/sbin/ldconfig
 %banner -o -e %{name} <<-EOF
 To run doomsday you need some WAD file: either freedoom package
 or some shareware or commercial WAD from Doom or Heretic:
@@ -117,16 +101,31 @@ When you have them, run doomsday with:
 doomsday -game [ jdoom | jheretic | jhexen ]
 EOF
 
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc doomsday/build/README
+#%doc doomsday/build/README
 %attr(755,root,root) %{_bindir}/doomsday
-%attr(755,root,root) %{_libdir}/libdpdehread.so
-%attr(755,root,root) %{_libdir}/libdpwadmapconverter.so
-%attr(755,root,root) %{_libdir}/libjdoom.so
-%attr(755,root,root) %{_libdir}/libjheretic.so
-%attr(755,root,root) %{_libdir}/libjhexen.so
-%attr(755,root,root) %{_libdir}/libdsopenal.so
-%{_datadir}/deng
+%attr(755,root,root) %{_bindir}/doomsday-server
+%attr(755,root,root) %{_bindir}/launch-doomsday
+
+%attr(755,root,root) %{_libdir}/libdeng_core.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdeng_core.so.2
+%attr(755,root,root) %{_libdir}/libdeng_appfw.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdeng_appfw.so.1
+%attr(755,root,root) %{_libdir}/libdeng_doomsday.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdeng_doomsday.so.1
+%attr(755,root,root) %{_libdir}/libdeng_gui.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdeng_gui.so.1
+%attr(755,root,root) %{_libdir}/libdeng_legacy.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdeng_legacy.so.1
+%attr(755,root,root) %{_libdir}/libdeng_shell.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libdeng_shell.so.1
+
+
+%{_libdir}/doomsday
+%{_datadir}/doomsday
 %{_desktopdir}/*.desktop
 %{_pixmapsdir}/*.png
+%{_mandir}/man6/*
This page took 0.180427 seconds and 4 git commands to generate.