]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
e335c23485a1503e667cee4bcd2f225b62355ed1
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - icons for desktop files
3 # - (CVE-2006-1618) http://security.gentoo.org/glsa/glsa-200604-05.xml
4 #
5 %define         _beta beta4
6 #
7 Summary:        jDoom, jHeretic and jHexen for Linux
8 Summary(pl.UTF-8):      jDoom, jHeretic i jHexen dla Linuksa
9 Name:           doomsday
10 Version:        1.9.0
11 Release:        0.%{_beta}.1
12 License:        GPL v2
13 Group:          Applications/Games
14 Source0:        http://dl.sourceforge.net/deng/deng-%{version}-%{_beta}.tar.gz
15 # Source0-md5:  b2bec9a475eee1438f55ebde00b3d13f
16 Patch0:         %{name}-ncurses.patch
17 Patch1:         %{name}-runtimedir.patch
18 Patch2:         %{name}-ac.patch
19 URL:            http://www.doomsdayhq.com/
20 BuildRequires:  OpenAL-devel
21 BuildRequires:  OpenGL-devel
22 BuildRequires:  SDL-devel >= 1.2.0
23 BuildRequires:  SDL_mixer-devel
24 BuildRequires:  SDL_net-devel
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  rpmbuild(macros) >= 1.213
28 Requires(post): /sbin/ldconfig
29 Requires:               TiMidity++
30 # it's FUBAR by storing pointers in int struct fields
31 ExcludeArch:    %{x8664} alpha ia64 ppc64 s390x sparc64
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
35
36 %description
37 jDoom, jHeretic and jHexen for Linux.
38
39 %description -l pl.UTF-8
40 jDoom, jHeretic i jHexen dla Linuksa.
41
42 %prep
43 %setup -q -n deng-%{version}-%{_beta}
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47
48 %build
49 %{__aclocal}
50 %{__autoconf}
51 %{__automake}
52
53 %configure
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_desktopdir}
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
64 [Desktop Entry]
65 Name=Doom
66 Comment=Doom for linux
67 Exec=doomsday -game jdoom
68 #Icon=hexen.png
69 Terminal=false
70 Type=Application
71 Categories=Game;FirstPersonGame;
72 Encoding=UTF-8
73 # vi: encoding=utf-8
74 EOF
75
76 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
77 [Desktop Entry]
78 Name=Hexen
79 Comment=Hexen for linux
80 Exec=doomsday -game jhexen
81 #Icon=heretic.png
82 Terminal=false
83 Type=Application
84 Categories=Game;FirstPersonGame;
85 Encoding=UTF-8
86 # vi: encoding=utf-8
87 EOF
88
89 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
90 [Desktop Entry]
91 Name=Heretic
92 Comment=Heretic for linux
93 Exec=doomsday -game jheretic
94 #Icon=heretic.png
95 Terminal=false
96 Type=Application
97 Categories=Game;FirstPersonGame;
98 Encoding=UTF-8
99 # vi: encoding=utf-8
100 EOF
101
102 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 /sbin/ldconfig
109 if [ "$1" = "1" ]; then
110         %banner -e %{name} <<-EOF
111         To run doomsday you need some WAD file: either freedoom package
112         or some shareware or commercial WAD from Doom or Heretic:
113         Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
114         Heretic.wad or Heretic1.wad.
115         When you have them, run doomsday with:
116         doomsday -game [ jdoom | jheretic | jhexen ]
117 EOF
118 fi
119
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc Doc/*
125 %attr(755,root,root) %{_bindir}/doomsday
126 %attr(755,root,root) %{_libdir}/*.so.*.*.*
127 %{_libdir}/*.la
128 %{_datadir}/deng
129 %{_desktopdir}/*.desktop
This page took 0.056898 seconds and 2 git commands to generate.