]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
471c9435a0d2fdf0e5cd56fd85d370319b2180e9
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - icons for desktop files
3 Summary:        jDoom, jHeretic and jHexen for Linux
4 Summary(pl):    jDoom, jHeretic i jHexen dla Linuksa
5 Name:           doomsday
6 Version:        1.9.0
7 Release:        0.beta3.1
8 License:        GPL v2
9 Group:          Applications/Games
10 Source0:        http://dl.sourceforge.net/deng/deng-%{version}-beta3.tar.gz
11 # Source0-md5:  581fefd6165dd4104b25656a6b9f31b4
12 Patch0:         %{name}-ncurses.patch
13 Patch1:         %{name}-runtimedir.patch
14 URL:            http://www.doomsdayhq.com/
15 BuildRequires:  OpenAL-devel
16 BuildRequires:  OpenGL-devel
17 BuildRequires:  SDL-devel >= 1.2.0
18 BuildRequires:  SDL_mixer-devel
19 BuildRequires:  SDL_net-devel
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  rpmbuild(macros) >= 1.213
23 Requires(post): /sbin/ldconfig
24 Requires:               TiMidity++
25 # it's FUBAR by storing pointers in int struct fields
26 ExcludeArch:    %{x8664} alpha ia64 ppc64 s390x sparc64
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
30
31 %description
32 jDoom, jHeretic and jHexen for Linux.
33
34 %description -l pl
35 jDoom, jHeretic i jHexen dla Linuksa.
36
37 %prep
38 %setup -q -n deng-%{version}-beta3
39 %patch0 -p1
40 %patch1 -p1
41
42 %build
43 %{__aclocal}
44 %{__autoconf}
45 %{__automake}
46
47 %configure
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_desktopdir}
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
58 [Desktop Entry]
59 Name=Doom
60 Comment=Doom for linux
61 Exec=doomsday -game jdoom
62 #Icon=hexen.png
63 Terminal=false
64 Type=Application
65 Categories=Game;FirstPersonGame;
66 Encoding=UTF-8
67 # vi: encoding=utf-8
68 EOF
69
70 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
71 [Desktop Entry]
72 Name=Hexen
73 Comment=Hexen for linux
74 Exec=doomsday -game jhexen
75 #Icon=heretic.png
76 Terminal=false
77 Type=Application
78 Categories=Game;FirstPersonGame;
79 Encoding=UTF-8
80 # vi: encoding=utf-8
81 EOF
82
83 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
84 [Desktop Entry]
85 Name=Heretic
86 Comment=Heretic for linux
87 Exec=doomsday -game jheretic
88 #Icon=heretic.png
89 Terminal=false
90 Type=Application
91 Categories=Game;FirstPersonGame;
92 Encoding=UTF-8
93 # vi: encoding=utf-8
94 EOF
95
96 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post
102 /sbin/ldconfig
103 if [ "$1" = "1" ]; then
104         %banner -e %{name} <<-EOF
105         To run doomsday you need some WAD file: either freedoom package
106         or some shareware or commercial WAD from Doom or Heretic:
107         Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
108         Heretic.wad or Heretic1.wad.
109         When you have them, run doomsday with:
110         doomsday -game [ jdoom | jheretic | jhexen ]
111 EOF
112 fi
113
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc Doc/*
119 %attr(755,root,root) %{_bindir}/doomsday
120 %attr(755,root,root) %{_libdir}/*.so.*.*.*
121 %{_libdir}/*.la
122 %{_datadir}/deng
123 %{_desktopdir}/*.desktop
This page took 0.046598 seconds and 2 git commands to generate.