]> git.pld-linux.org Git - packages/doomsday.git/blob - doomsday.spec
14eb6881d2814cdc1e4515ba6d2cf45826cf8970
[packages/doomsday.git] / doomsday.spec
1 # TODO
2 # - sync pl
3 # - clean up spec. cleanup what?
4 %define         subver  stable
5 Summary:        jDoom, jHeretic and jHexen for Linux
6 Summary(pl.UTF-8):      jDoom, jHeretic i jHexen dla Linuksa
7 Name:           doomsday
8 Version:        1.15.4
9 Release:        0.1
10 License:        GPL v2 / CC 3.0 (icons)
11 Group:          Applications/Games
12 Source0:        http://downloads.sourceforge.net/deng/%{name}-%{subver}-%{version}.tar.gz
13 # Source0-md5:  8329eacdea73edca7aea4034ca8d78aa
14 Source1:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-26/Doom-1-48x48.png
15 # Source1-md5:  b7b7a9389eba56679e5db65d95c06803
16 Source2:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-23/Hexen-1-48x48.png
17 # Source2-md5:  573845e6e747f68617ac67f3a87dc78e
18 Source3:        http://www.iconarchive.com/icons/3xhumed/mega-games-pack-28/Heretic-I-1-48x48.png
19 # Source3-md5:  c89e36c49eabe2846137f313a5250308
20 #Patch0:                %{name}-libpng15.patch
21 #Patch1:                %{name}-format.patch
22 URL:            http://www.dengine.net/
23 BuildRequires:  OpenAL-devel
24 BuildRequires:  OpenGL-GLU-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL2-devel
27 BuildRequires:  SDL2_mixer-devel
28 BuildRequires:  qt4-qmake
29 BuildRequires:  assimp-devel
30 BuildRequires:  curl-devel
31 BuildRequires:  libpng-devel
32 BuildRequires:  ncurses-devel
33 BuildRequires:  python
34 BuildRequires:  python-modules
35 BuildRequires:  rpmbuild(macros) >= 1.595
36 Requires(post): /sbin/ldconfig
37 Requires:       TiMidity++
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 The Doomsday Engine allows you to play the classic first-person
42 shooters DOOM, Heretic, and Hexen using modern technology, with
43 hardware accelerated 3D graphics, surround sound and much more.
44
45 %description -l pl.UTF-8
46 jDoom, jHeretic i jHexen dla Linuksa.
47
48 %prep
49 %setup -q -n doomsday-%{subver}-%{version}
50 #%patch0 -p1
51 #%patch1 -p1
52
53 %build
54 install -d build
55 cd build
56 LDFLAGS="-lm"
57 qmake-qt4 CONFIG+=deng_notools \
58         -r ../doomsday/doomsday.pro
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_desktopdir}
64 %{__make} -C build install \
65         INSTALL_ROOT=$RPM_BUILD_ROOT
66
67 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
68 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/doom.png
69 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/hexen.png
70 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/heretic.png
71
72 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-doom.desktop
73 [Desktop Entry]
74 Name=Doom
75 Comment=Doom for linux
76 Exec=doomsday -game jdoom
77 Icon=doom.png
78 Terminal=false
79 Type=Application
80 Categories=Game;FirstPersonGame;
81 Encoding=UTF-8
82 EOF
83
84 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-hexen.desktop
85 [Desktop Entry]
86 Name=Hexen
87 Comment=Hexen for linux
88 Exec=doomsday -game jhexen
89 Icon=hexen.png
90 Terminal=false
91 Type=Application
92 Categories=Game;FirstPersonGame;
93 Encoding=UTF-8
94 EOF
95
96 cat <<EOF > $RPM_BUILD_ROOT%{_desktopdir}/%{name}-heretic.desktop
97 [Desktop Entry]
98 Name=Heretic
99 Comment=Heretic for linux
100 Exec=doomsday -game jheretic
101 Icon=heretic.png
102 Terminal=false
103 Type=Application
104 Categories=Game;FirstPersonGame;
105 Encoding=UTF-8
106 EOF
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 /sbin/ldconfig
113 %banner -o -e %{name} <<-EOF
114 To run doomsday you need some WAD file: either freedoom package
115 or some shareware or commercial WAD from Doom or Heretic:
116 Doom.wad, Doom1.wad, Doom2.wad, Tnt.wad, Plutonia.wad,
117 Heretic.wad or Heretic1.wad.
118 When you have them, run doomsday with:
119 doomsday -game [ jdoom | jheretic | jhexen ]
120 EOF
121
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 #%doc doomsday/build/README
127 %attr(755,root,root) %{_bindir}/doomsday
128 %attr(755,root,root) %{_bindir}/doomsday-server
129 %attr(755,root,root) %{_bindir}/launch-doomsday
130
131 %attr(755,root,root) %{_libdir}/libdeng_core.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libdeng_core.so.2
133 %attr(755,root,root) %{_libdir}/libdeng_appfw.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libdeng_appfw.so.1
135 %attr(755,root,root) %{_libdir}/libdeng_doomsday.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libdeng_doomsday.so.1
137 %attr(755,root,root) %{_libdir}/libdeng_gui.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libdeng_gui.so.1
139 %attr(755,root,root) %{_libdir}/libdeng_legacy.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libdeng_legacy.so.1
141 %attr(755,root,root) %{_libdir}/libdeng_shell.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libdeng_shell.so.1
143
144 %{_libdir}/doomsday
145 %{_datadir}/doomsday
146 %{_desktopdir}/*.desktop
147 %{_pixmapsdir}/*.png
148 %{_mandir}/man6/*
This page took 0.628388 seconds and 2 git commands to generate.