]> git.pld-linux.org Git - packages/doomlegacy.git/commitdiff
- fixed Makefile patch (more OPTFLAGS needed)
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 27 Feb 2003 00:05:54 +0000 (00:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fixed build with current glibc (problem caused by precompiled objects)

Changed files:
    doomlegacy-Makefile.patch -> 1.4
    doomlegacy.spec -> 1.15

doomlegacy-Makefile.patch
doomlegacy.spec

index f871c447020608856652fc546305908a6e19fbbe..46c3ca590c3965d81e1d9c7cbf436ccefdcc447e 100644 (file)
 -      gcc -O6 -mpentium -Wall -s convert.c -o convert.exe
 +      gcc $(OPTFLAGS) -Wall -s convert.c -o convert.exe
        
---- doomlegacy_src/makefile.orig       Sat Feb 22 21:07:58 2003
-+++ doomlegacy_src/makefile    Sat Feb 22 21:11:27 2003
-@@ -471,7 +471,7 @@
+--- doomlegacy_src/makefile.orig       Thu Feb 27 00:30:58 2003
++++ doomlegacy_src/makefile    Thu Feb 27 00:34:37 2003
+@@ -298,7 +298,7 @@
+       SFLAGS=
+-    CFLAGS=-g
++    CFLAGS=
+       OBJS=$(O)/i_video.o $(O)/vid_vesa.o
+@@ -471,9 +471,9 @@
  
        # build with profiling information
        ifdef PGCC
 -              CFLAGS = -g -pg -DPARANOIA -fwritable-strings $(OPTS)
-+              CFLAGS = $(OPTS) $(OPTFLAGS) -ffast-math -fomit-frame-pointer -fwritable-strings
++              CFLAGS = -g -pg $(OPTFLAGS) -DPARANOIA -fwritable-strings $(OPTS)
+       else
+-              CFLAGS = -g -pg -m486 -O3 -ffast-math -fwritable-strings $(OPTS)
++              CFLAGS = -g -pg $(OPTFLAGS) -ffast-math -fwritable-strings $(OPTS)
+       endif
+       LDFLAGS = -g -pg -L/usr/X11R6/lib
+ else
+@@ -481,13 +481,13 @@
+       # build a normal optimised version
+       ifdef PGCC
+-              CFLAGS = $(OPTS) -mpentium -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
++              CFLAGS = $(OPTS) $(OPTFLAGS) -ffast-math -fwritable-strings
+               # -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \
+               # -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps  \
+               # -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \
+               # -fcaller-saves -finline-functions -mieee-fp -mfp-ret-in-387 -m80387 -mhard-float -finline
        else
-               CFLAGS = -g -pg -m486 -O3 -ffast-math -fwritable-strings $(OPTS)
+-              CFLAGS = -m486 -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
++              CFLAGS = $(OPTFLAGS) -ffast-math -fwritable-strings $(OPTS)
        endif
+ endif
 @@ -644,7 +644,7 @@
  
  #dll
  dll : $(O)/r_opengl.o $(O)/ogl_x11.o
 -      $(CC) -mpentium -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
-+      $(CC) $(OPTFLAGS) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lGL -lX11 -lXext -lGLU -lm
++      $(CC) $(OPTFLAGS) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
  
  musserv:
        @mkdir -p $(MUSSERV)/linux
  ifdef LINUX
  $(O)/r_opengl.o:      hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
 -      $(CC) -mpentium -O6 -o $(O)/r_opengl.o  -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
-+      $(CC) $(OPTFLAGS) -o $(O)/r_opengl.o    -DHWRENDER -DVID_X11 -DLINUX -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++      $(CC) $(OPTFLAGS) -o $(O)/r_opengl.o    -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
  endif
  
  ifdef SDL
-@@ -681,7 +681,7 @@
-       $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+@@ -672,16 +672,16 @@
+       $(CC) $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
+ else  #FBSD_SDL
+ $(O)/r_opengl.o:      hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
+-      $(CC) -mpentium -O6 -o $(O)/r_opengl.o  -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++      $(CC) $(OPTFLAGS) -o $(O)/r_opengl.o    -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+ endif #FBSD_SDL
+ endif #FREEBSD
+ ifndef FREEBSD
+ $(O)/ogl_x11.o:  hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
+-      $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++      $(CC) $(OPTFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
  else
  $(O)/ogl_x11.o:  hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
 -      $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
-+      $(CC) $(OPTFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++      $(CC) $(OPTFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
  endif
  
  
index bb98bd9c6310bbe866b57c5fbe0a9e9e42a88ce8..f968c38fa67f7997908df4669b7985d61f3c9c72 100644 (file)
@@ -74,11 +74,16 @@ To jest DOOM Legacy dla Linuksa - wersja SDL.
 %patch3 -p0
 
 %build
-install -d doomlegacy_src/linux_x/{musserv,sndserv}/{objs,bin} \
-          bin
-%{__make} -C doomlegacy_src PGCC=1 LINUX=1 OPTFLAGS="%{rpmcflags}"
+mkdir bin
+
+# linux_x contains some precompiled binary objects (incompatible with glibc 2.3) - kill them
+%{__make} -C doomlegacy_src clean LINUX=1
+%{__make} -C doomlegacy_src \
+       PGCC=1 LINUX=1 OPTFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
+
 %{__make} -C doomlegacy_src clean LINUX=1
-%{__make} -C doomlegacy_src PGCC=1 LINUX=1 SDL=1 OPTFLAGS="%{rpmcflags}"
+%{__make} -C doomlegacy_src \
+       PGCC=1 LINUX=1 SDL=1 OPTFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.072165 seconds and 4 git commands to generate.