]> git.pld-linux.org Git - packages/doomlegacy.git/commitdiff
- updated for 1.42
authorhavner <havner@pld-linux.org>
Fri, 29 Oct 2004 22:06:51 +0000 (22:06 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    doomlegacy-Makefile.patch -> 1.5
    doomlegacy-errno.patch -> 1.2
    doomlegacy-nocmap.patch -> 1.2
    doomlegacy-nosndstat.patch -> 1.4
    doomlegacy-paths.patch -> 1.6
    doomlegacy-sound.patch -> 1.2
    doomlegacy-vidmodes.patch -> 1.2

doomlegacy-Makefile.patch
doomlegacy-errno.patch
doomlegacy-nocmap.patch
doomlegacy-nosndstat.patch
doomlegacy-paths.patch
doomlegacy-sound.patch
doomlegacy-vidmodes.patch

index 46c3ca590c3965d81e1d9c7cbf436ccefdcc447e..9663a64682315140614d1e5949f81cb826b3b909 100644 (file)
@@ -1,5 +1,5 @@
---- doomlegacy_src/linux_x/musserv/Makefile.linux.orig Sat Feb 22 21:12:31 2003
-+++ doomlegacy_src/linux_x/musserv/Makefile.linux      Sat Feb 22 21:12:52 2003
+--- doomlegacy_142_src/linux_x/musserv/Makefile.linux.orig     Sat Feb 22 21:12:31 2003
++++ doomlegacy_142_src/linux_x/musserv/Makefile.linux  Sat Feb 22 21:12:52 2003
 @@ -3,7 +3,7 @@
  #
  
@@ -9,8 +9,8 @@
  LDFLAGS       =
  #LDFLAGS      = -static
  
---- doomlegacy_src/linux_x/sndserv/Makefile.orig       Sat Feb 22 21:11:50 2003
-+++ doomlegacy_src/linux_x/sndserv/Makefile    Sat Feb 22 21:12:12 2003
+--- doomlegacy_142_src/linux_x/sndserv/Makefile.orig   Sat Feb 22 21:11:50 2003
++++ doomlegacy_142_src/linux_x/sndserv/Makefile        Sat Feb 22 21:12:12 2003
 @@ -22,7 +22,7 @@
  #
  
@@ -20,8 +20,8 @@
  ifdef FREEBSD
  CFLAGS:=${CFLAGS} -DFREEBSD
  endif
---- doomlegacy_src/tools/makefile.orig Sat Feb 22 21:13:11 2003
-+++ doomlegacy_src/tools/makefile      Sat Feb 22 21:14:30 2003
+--- doomlegacy_142_src/tools/makefile.orig     Sat Feb 22 21:13:11 2003
++++ doomlegacy_142_src/tools/makefile  Sat Feb 22 21:14:30 2003
 @@ -1,24 +1,24 @@
  
  default:    dircomp2.c
@@ -54,8 +54,8 @@
 -      gcc -O6 -mpentium -Wall -s convert.c -o convert.exe
 +      gcc $(OPTFLAGS) -Wall -s convert.c -o convert.exe
        
---- doomlegacy_src/makefile.orig       Thu Feb 27 00:30:58 2003
-+++ doomlegacy_src/makefile    Thu Feb 27 00:34:37 2003
+--- doomlegacy_142_src/makefile.orig   Thu Feb 27 00:30:58 2003
++++ doomlegacy_142_src/makefile        Thu Feb 27 00:34:37 2003
 @@ -298,7 +298,7 @@
  
        SFLAGS=
@@ -72,7 +72,7 @@
 -              CFLAGS = -g -pg -DPARANOIA -fwritable-strings $(OPTS)
 +              CFLAGS = -g -pg $(OPTFLAGS) -DPARANOIA -fwritable-strings $(OPTS)
        else
--              CFLAGS = -g -pg -m486 -O3 -ffast-math -fwritable-strings $(OPTS)
+-              CFLAGS = -g -pg $(M4) -O3 -ffast-math -fwritable-strings $(OPTS)
 +              CFLAGS = -g -pg $(OPTFLAGS) -ffast-math -fwritable-strings $(OPTS)
        endif
        LDFLAGS = -g -pg -L/usr/X11R6/lib
  
        # build a normal optimised version
        ifdef PGCC
--              CFLAGS = $(OPTS) -mpentium -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
+-              CFLAGS = $(OPTS) $(M5) -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
 +              CFLAGS = $(OPTS) $(OPTFLAGS) -ffast-math -fwritable-strings
                # -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \
                # -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps  \
                # -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \
                # -fcaller-saves -finline-functions -mieee-fp -mfp-ret-in-387 -m80387 -mhard-float -finline
        else
--              CFLAGS = -m486 -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
+-              CFLAGS = $(M4) -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
 +              CFLAGS = $(OPTFLAGS) -ffast-math -fwritable-strings $(OPTS)
        endif
  endif
@@ -97,7 +97,7 @@
  
  #dll
  dll : $(O)/r_opengl.o $(O)/ogl_x11.o
--      $(CC) -mpentium -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
+-      $(CC) $(M5) -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
 +      $(CC) $(OPTFLAGS) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
  
  musserv:
  
  ifdef LINUX
  $(O)/r_opengl.o:      hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
--      $(CC) -mpentium -O6 -o $(O)/r_opengl.o  -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+-      $(CC) $(M5) -O6 -o $(O)/r_opengl.o      -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
 +      $(CC) $(OPTFLAGS) -o $(O)/r_opengl.o    -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
  endif
  
  ifdef SDL
-@@ -672,16 +672,16 @@
+@@ -763,7 +763,7 @@
        $(CC) $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
  else  #FBSD_SDL
  $(O)/r_opengl.o:      hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
--      $(CC) -mpentium -O6 -o $(O)/r_opengl.o  -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+-      $(CC) $(M5) -O6 -o $(O)/r_opengl.o      -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
 +      $(CC) $(OPTFLAGS) -o $(O)/r_opengl.o    -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
  endif #FBSD_SDL
  endif #FREEBSD
  
+@@ -774,10 +774,10 @@
  ifndef FREEBSD
  $(O)/ogl_x11.o:  hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
--      $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+-      $(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
 +      $(CC) $(OPTFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
  else
  $(O)/ogl_x11.o:  hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
--      $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+-      $(CC) $(M5) -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
 +      $(CC) $(OPTFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
  endif
  
index 93aedce27c4dac8ddc360faa19a6fe7d0f275355..f3ba68aeb6a843892151508a6725c9423d61d945 100644 (file)
@@ -1,5 +1,5 @@
---- doomlegacy-1.40/doomlegacy_src/linux_x/i_sound.c.orig      Fri Mar  7 22:14:51 2003
-+++ doomlegacy-1.40/doomlegacy_src/linux_x/i_sound.c   Fri Mar  7 22:18:30 2003
+--- doomlegacy-1.40/doomlegacy_142_src/linux_x/i_sound.c.orig  Fri Mar  7 22:14:51 2003
++++ doomlegacy-1.40/doomlegacy_142_src/linux_x/i_sound.c       Fri Mar  7 22:18:30 2003
 @@ -88,6 +88,7 @@
  #include <sys/filio.h>
  #endif
@@ -8,16 +8,16 @@
  #include <fcntl.h>
  #include <unistd.h>
  #include <sys/ioctl.h>
-@@ -261,7 +262,6 @@
  int*  arg )
- {   
-     int         rc;
--    extern int  errno;
-     
-     rc = ioctl(fd, command, arg);  
+@@ -262,7 +262,6 @@
void myioctl(int fd, int command, int *arg)
+ {
+     int rc;
+-    extern int errno;
+     rc = ioctl(fd, command, arg);
      if (rc < 0)
---- doomlegacy-1.40/doomlegacy_src/linux_x/sndserv/linux.c.orig        Sun Sep 22 00:35:57 2002
-+++ doomlegacy-1.40/doomlegacy_src/linux_x/sndserv/linux.c     Fri Mar  7 22:22:26 2003
+--- doomlegacy-1.40/doomlegacy_142_src/linux_x/sndserv/linux.c.orig    Sun Sep 22 00:35:57 2002
++++ doomlegacy-1.40/doomlegacy_142_src/linux_x/sndserv/linux.c Fri Mar  7 22:22:26 2003
 @@ -39,6 +39,7 @@
  
  #include <stdlib.h>
index 488e87fc71fd60f29f2001244c89f8a4be84a8d4..90dfcc4616bb34c170d338feb42e19e036fbc0b5 100644 (file)
@@ -1,5 +1,5 @@
---- doomlegacy-1.40/doomlegacy_src/linux_x/i_video_xshm.c.orig Fri Mar  7 22:22:56 2003
-+++ doomlegacy-1.40/doomlegacy_src/linux_x/i_video_xshm.c      Fri Mar  7 22:51:25 2003
+--- doomlegacy-1.40/doomlegacy_142_src/linux_x/i_video_xshm.c.orig     Fri Mar  7 22:22:56 2003
++++ doomlegacy-1.40/doomlegacy_142_src/linux_x/i_video_xshm.c  Fri Mar  7 22:51:25 2003
 @@ -1619,14 +1619,14 @@
      if(rendermode==render_soft) {
      // setup attributes for main window
index 2311c48b8581f78a09bfdb1f521fa3345d2a6be0..614f3dead5e45068eb8144eed8b936e440812b9e 100644 (file)
@@ -1,5 +1,5 @@
---- doomlegacy_src/linux_x/musserv/sequencer.c.orig    Sat Feb 22 21:25:59 2003
-+++ doomlegacy_src/linux_x/musserv/sequencer.c Sat Feb 22 21:27:23 2003
+--- doomlegacy_142_src/linux_x/musserv/sequencer.c.orig        Sat Feb 22 21:25:59 2003
++++ doomlegacy_142_src/linux_x/musserv/sequencer.c     Sat Feb 22 21:27:23 2003
 @@ -177,11 +177,7 @@
    seq_dev = num_fm;
  
index 9cebafb6ed028bfba725dc094c59179eb099a79b..ed3d3998b9883a1278799ea967ee43946dcc595c 100644 (file)
@@ -1,5 +1,5 @@
---- doomlegacy_src/linux_x/musserv/musserver.c.orig    Sat Feb 22 20:51:24 2003
-+++ doomlegacy_src/linux_x/musserv/musserver.c Sat Feb 22 20:52:15 2003
+--- doomlegacy_142_src/linux_x/musserv/musserver.c.orig        Sat Feb 22 20:51:24 2003
++++ doomlegacy_142_src/linux_x/musserv/musserver.c     Sat Feb 22 20:52:15 2003
 @@ -122,9 +122,7 @@
      ppid = getpid();
      if (verbose > 1) 
@@ -11,8 +11,8 @@
  
      while ((x = getopt(argc, argv, "acd:fhi:lmt:u:Vv")) != -1)
        switch (x)
---- doomlegacy_src/linux_x/musserv/readwad.c.orig      Sat Feb 22 20:52:25 2003
-+++ doomlegacy_src/linux_x/musserv/readwad.c   Sat Feb 22 20:53:03 2003
+--- doomlegacy_142_src/linux_x/musserv/readwad.c.orig  Sat Feb 22 20:52:25 2003
++++ doomlegacy_142_src/linux_x/musserv/readwad.c       Sat Feb 22 20:53:03 2003
 @@ -213,7 +213,7 @@
      FILE *fp;
  
@@ -22,8 +22,8 @@
  
      wadfilename = malloc(2 + strlen(s) + strlen(waddir));
      if (*s != '/')
---- doomlegacy_src/linux_x/i_video_xshm.c.orig Sat Feb 22 20:45:02 2003
-+++ doomlegacy_src/linux_x/i_video_xshm.c      Sat Feb 22 20:46:49 2003
+--- doomlegacy_142_src/linux_x/i_video_xshm.c.orig     Sat Feb 22 20:45:02 2003
++++ doomlegacy_142_src/linux_x/i_video_xshm.c  Sat Feb 22 20:46:49 2003
 @@ -1984,7 +1984,7 @@
         rendermode = render_opengl;
  
@@ -33,8 +33,8 @@
  
         if(!dlptr) {
           // try to open in LIBPATH
---- doomlegacy_src/linux_x/i_system.c.orig     Sat Feb 22 20:48:37 2003
-+++ doomlegacy_src/linux_x/i_system.c  Sat Feb 22 20:50:55 2003
+--- doomlegacy_142_src/linux_x/i_system.c.orig Sat Feb 22 20:48:37 2003
++++ doomlegacy_142_src/linux_x/i_system.c      Sat Feb 22 20:50:55 2003
 @@ -141,9 +141,9 @@
  extern int             eventtail;
  
  #define DEFAULTSEARCHPATH2 "/usr/games"
  #define WADKEYWORD "legacy.dat"
  
---- doomlegacy_src/linux_x/searchp.c.orig      Sat Feb 22 20:53:41 2003
-+++ doomlegacy_src/linux_x/searchp.c   Sat Feb 22 20:54:22 2003
+--- doomlegacy_142_src/linux_x/searchp.c.orig  Sat Feb 22 20:53:41 2003
++++ doomlegacy_142_src/linux_x/searchp.c       Sat Feb 22 20:54:22 2003
 @@ -22,6 +22,12 @@
        static char     b[2048];
        struct stat     s;
        char            pb[2048];
 +      
-+      strcpy(b,"/usr/X11R6/lib/doomlegacy_src/");
++      strcpy(b,"/usr/X11R6/lib/doomlegacy_142_src/");
 +      strcat(b,file);
 +      if (stat(b, &s) == 0) {
 +              return(b);
  
        /* get PATH, if not set just return filename, might be in cwd */
          /* added "./" for current path 19990416 by Kin */
---- doomlegacy_src/d_main.c.orig       Sat Feb 22 20:47:20 2003
-+++ doomlegacy_src/d_main.c    Sat Feb 22 20:48:10 2003
+--- doomlegacy_142_src/d_main.c.orig   Sat Feb 22 20:47:20 2003
++++ doomlegacy_142_src/d_main.c        Sat Feb 22 20:48:10 2003
 @@ -1022,16 +1022,8 @@
      // change to the directory where 'legacy.dat' is found
-    I_LocateWad();
+     I_LocateWad();
  #endif
 -    doomwaddir = getenv("DOOMWADDIR");
 -    if (!doomwaddir)
 -    {
 -        // get the current directory (possible problem on NT with "." as current dir)
--        if ( getcwd(pathtemp, _MAX_PATH) != NULL )
+-        if (getcwd(pathtemp, _MAX_PATH) != NULL)
 -            doomwaddir = pathtemp;
 -        else
 -            doomwaddir = ".";
 -    }
--        
-+      doomwaddir = getenv("DOOMWADDIR") ? getenv("DOOMWADDIR") : "/usr/share/doomlegacy";
-+
++    doomwaddir = getenv("DOOMWADDIR") ? getenv("DOOMWADDIR") : "/usr/share/doomlegacy";
  #ifdef __MACOS__
-         // cwd is always "/" when app is dbl-clicked
-         if (!stricmp(doomwaddir,"/"))
+     // cwd is always "/" when app is dbl-clicked
index cba341dad598e9baf616f91885eb7799fac63f57..588b1bec02892c3871ab0d56170be61620c0c904 100644 (file)
@@ -1,20 +1,20 @@
---- doomlegacy_src/linux_x/i_sound.c.orig      Sun Feb 23 01:03:54 2003
-+++ doomlegacy_src/linux_x/i_sound.c   Sun Feb 23 01:19:30 2003
-@@ -929,7 +929,7 @@
-   if (nosound)
-     return;
+--- doomlegacy_142_src/linux_x/i_sound.c.orig  Sun Feb 23 01:03:54 2003
++++ doomlegacy_142_src/linux_x/i_sound.c       Sun Feb 23 01:19:30 2003
+@@ -880,7 +880,7 @@
+     if (nosound)
+         return;
  
--  fn_snd = searchpath(sndserver_cmd.string);
-+  fn_snd = "/usr/lib/doomlegacy/llsndserv";
-   
-   // start sound process
-   if ( !access(fn_snd, X_OK) )
-@@ -1057,7 +1057,7 @@
-     return;
+-    fn_snd = searchpath(sndserver_cmd.string);
++    fn_snd = "/usr/lib/doomlegacy/llsndserv";
+     // start sound process
+     if (!access(fn_snd, X_OK))
+@@ -1004,7 +1004,7 @@
+         return;
  
  #ifdef MUSSERV
--  fn_mus = searchpath(musserver_cmd.string);
-+  fn_mus = "/usr/lib/doomlegacy/musserver";
+-    fn_mus = searchpath(musserver_cmd.string);
++    fn_mus = "/usr/lib/doomlegacy/musserver";
  
-   // now try to start the music server process
-   if (!access(fn_mus, X_OK)) {
+     // now try to start the music server process
+     if (!access(fn_mus, X_OK))
index 6b8b278467a32983e8c99908637d1bde6c99d3b1..d7aea8a6d607056c12fb6e62d315104d0fe2f665 100644 (file)
@@ -1,5 +1,5 @@
---- doomlegacy-1.40/doomlegacy_src/linux_x/i_video_xshm.c~     Fri Mar 14 03:11:35 2003
-+++ doomlegacy-1.40/doomlegacy_src/linux_x/i_video_xshm.c      Fri Mar 14 03:11:35 2003
+--- doomlegacy-1.40/doomlegacy_142_src/linux_x/i_video_xshm.c~ Fri Mar 14 03:11:35 2003
++++ doomlegacy-1.40/doomlegacy_142_src/linux_x/i_video_xshm.c  Fri Mar 14 03:11:35 2003
 @@ -182,7 +182,9 @@
  // resolution threshold for hires mode
  #define HIRES_HORIZ (640)
This page took 0.063055 seconds and 4 git commands to generate.