]> git.pld-linux.org Git - packages/doomlegacy.git/commitdiff
This commit was manufactured by cvs2git to create tag 'RA-1_0'. RA-1_0
authorcvs2git <feedback@pld-linux.org>
Fri, 7 Mar 2003 08:18:37 +0000 (08:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2001-07-18 19:41:44 UTC kloczek <kloczek@pld-linux.org> '- added "ExclusiveArch: %%{ix86}" (source code contains some x86 specyfic asm'
Cherrypick from master 2003-02-27 00:05:54 UTC Jakub Bogusz <qboosh@pld-linux.org> '- fixed Makefile patch (more OPTFLAGS needed)':
    doomlegacy-Makefile.patch -> 1.4
Cherrypick from RA-branch 2003-03-07 08:18:37 UTC misi3k <misi3k@pld-linux.org> '- updated to work with 1.40':
    doomlegacy-paths.patch -> 1.3.2.1

doomlegacy-Makefile.patch
doomlegacy-paths.patch

index aa8af12dc178de8bc9da32118dac2f1c5a73d860..46c3ca590c3965d81e1d9c7cbf436ccefdcc447e 100644 (file)
---- doomlegacy/makefile.orig   Sun May  6 01:39:28 2001
-+++ doomlegacy/makefile        Sat Jun 30 11:20:55 2001
-@@ -366,7 +366,7 @@
\r
-       # build a normal optimised version\r
-       ifdef PGCC\r
--              CFLAGS = $(OPTS) -mpentium -O6 -ffast-math -fomit-frame-pointer -fwritable-strings\r
-+              CFLAGS = $(OPTS) $(OPTFLAGS) -ffast-math -fomit-frame-pointer -fwritable-strings\r
-               # -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \\r
-               # -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps  \\r
-               # -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \\r
-@@ -506,7 +506,7 @@
\r
- #dll\r
- dll : $(O)/r_opengl.o $(O)/ogl_x11.o\r
--      $(CC) -mpentium -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lGL -lX11 -lXext -lGLU -lm\r
-+      $(CC) $(OPTFLAGS) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lGL -lX11 -lXext -lGLU -lm\r
\r
- musserv:\r
-       @mkdir -p $(MUSSERV)/linux\r
-@@ -520,7 +520,7 @@
\r
- ifdef LINUX\r
- $(O)/r_opengl.o:      hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h\r
--      $(CC) -mpentium -O6 -o $(O)/r_opengl.o  -DHWRENDER -DVID_X11 -DLINUX -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c\r
-+      $(CC) $(OPTFLAGS) -o $(O)/r_opengl.o    -DHWRENDER -DVID_X11 -DLINUX -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c\r
- endif\r
\r
- ifdef SDL\r
-@@ -529,7 +529,7 @@
- endif\r
\r
- $(O)/ogl_x11.o:  hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h\r
--      $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c\r
-+      $(CC) $(OPTFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DPOLL_POINTER -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c\r
\r
\r
- #dependecy made by gcc itself ! (see makedep.mak for more)\r
---- doomlegacy/linux_x/sndserv/Makefile.orig   Sun Apr 30 21:50:38 2000
-+++ doomlegacy/linux_x/sndserv/Makefile        Sat Jun 30 11:20:08 2001
-@@ -19,7 +19,7 @@
- #\r
\r
- CC=gcc\r
--CFLAGS=-O2 -m486 -Wall -DNORMALUNIX -DLINUX\r
-+CFLAGS=$(OPTFLAGS) -Wall -DNORMALUNIX -DLINUX\r
- LDFLAGS=\r
- LIBS=-lm\r
\r
---- doomlegacy/linux_x/musserv/Makefile.linux.orig     Sun Feb 27 01:42:12 2000
-+++ doomlegacy/linux_x/musserv/Makefile.linux  Sat Jun 30 11:20:08 2001
+--- doomlegacy_src/linux_x/musserv/Makefile.linux.orig Sat Feb 22 21:12:31 2003
++++ doomlegacy_src/linux_x/musserv/Makefile.linux      Sat Feb 22 21:12:52 2003
 @@ -3,7 +3,7 @@
- #\r
\r
- CC    = gcc\r
--CFLAGS        = -I. -Wall -O2 -m486\r
-+CFLAGS        = -I. -Wall $(OPTFLAGS)\r
- LDFLAGS       =\r
- #LDFLAGS      = -static\r
\r
---- doomlegacy/tools/makefile.orig     Thu Jan 25 23:15:46 2001
-+++ doomlegacy/tools/makefile  Sat Jun 30 11:20:08 2001
+ #
+ CC    = gcc
+-CFLAGS        = -I. -Wall -O2 -m486
++CFLAGS = -I. -Wall $(OPTFLAGS)
+ LDFLAGS       =
+ #LDFLAGS      = -static
+--- doomlegacy_src/linux_x/sndserv/Makefile.orig       Sat Feb 22 21:11:50 2003
++++ doomlegacy_src/linux_x/sndserv/Makefile    Sat Feb 22 21:12:12 2003
+@@ -22,7 +22,7 @@
+ #
+ CC=gcc
+-CFLAGS=-O2 -m486 -Wall -DNORMALUNIX -DLINUX
++CFLAGS=$(OPTFLAGS) -Wall -DNORMALUNIX -DLINUX
+ ifdef FREEBSD
+ CFLAGS:=${CFLAGS} -DFREEBSD
+ endif
+--- doomlegacy_src/tools/makefile.orig Sat Feb 22 21:13:11 2003
++++ doomlegacy_src/tools/makefile      Sat Feb 22 21:14:30 2003
 @@ -1,24 +1,24 @@
\r
- default:    dircomp2.c\r
--      gcc -O6 -mpentium -Wall -s dircomp2.c -o dircomp2.exe\r
-+      gcc $(OPTFLAGS) -Wall -s dircomp2.c -o dircomp2.exe\r
\r
- asm:\r
--      gcc -O6 -mpentium -Wall -g dircomp2.c -o tmp.exe\r
-+      gcc $(OPTFLAGS) -Wall -g dircomp2.c -o tmp.exe\r
-       objdump  -dS tmp.exe --debugging --no-show-raw-insn > dircomp2.s\r
-       del tmp.exe\r
\r
- h2d:   h2d.c\r
--      gcc -O6 -mpentium -Wall -s h2d.c -o h2d.exe\r
-+      gcc $(OPTFLAGS) -Wall -s h2d.c -o h2d.exe\r
\r
- dckconv:     dckconv.c\r
--      gcc -O6 -mpentium -Wall -s dckconv.c -o dckconv.exe\r
-+      gcc $(OPTFLAGS) -Wall -s dckconv.c -o dckconv.exe\r
\r
- dckconv2:     dckconv2.c\r
--      gcc -O6 -mpentium -Wall -s dckconv2.c -o dckconv2.exe\r
-+      gcc $(OPTFLAGS) -Wall -s dckconv2.c -o dckconv2.exe\r
\r
- dckcomp:     dckcomp.c\r
--      gcc -O6 -mpentium -Wall -s dckcomp.c -o dckcomp.exe\r
-+      gcc $(OPTFLAGS) -Wall -s dckcomp.c -o dckcomp.exe\r
\r
- convert:    convert.c\r
--      gcc -O6 -mpentium -Wall -s convert.c -o convert.exe\r
--      \r
-+      gcc $(OPTFLAGS) -Wall -s convert.c -o convert.exe\r
-+\r
+ default:    dircomp2.c
+-      gcc -O6 -mpentium -Wall -s dircomp2.c -o dircomp2.exe
++      gcc $(OPTFLAGS) -Wall -s dircomp2.c -o dircomp2.exe
+ asm:
+-      gcc -O6 -mpentium -Wall -g dircomp2.c -o tmp.exe
++      gcc $(OPTFLAGS) -Wall -g dircomp2.c -o tmp.exe
+       objdump  -dS tmp.exe --debugging --no-show-raw-insn > dircomp2.s
+       del tmp.exe
+ h2d:   h2d.c
+-      gcc -O6 -mpentium -Wall -s h2d.c -o h2d.exe
++      gcc $(OPTFLAGS) -Wall -s h2d.c -o h2d.exe
+ dckconv:     dckconv.c
+-      gcc -O6 -mpentium -Wall -s dckconv.c -o dckconv.exe
++      gcc $(OPTFLAGS) -Wall -s dckconv.c -o dckconv.exe
+ dckconv2:     dckconv2.c
+-      gcc -O6 -mpentium -Wall -s dckconv2.c -o dckconv2.exe
++      gcc $(OPTFLAGS) -Wall -s dckconv2.c -o dckconv2.exe
+ dckcomp:     dckcomp.c
+-      gcc -O6 -mpentium -Wall -s dckcomp.c -o dckcomp.exe
++      gcc $(OPTFLAGS) -Wall -s dckcomp.c -o dckcomp.exe
+ convert:    convert.c
+-      gcc -O6 -mpentium -Wall -s convert.c -o convert.exe
++      gcc $(OPTFLAGS) -Wall -s convert.c -o convert.exe
+       
+--- doomlegacy_src/makefile.orig       Thu Feb 27 00:30:58 2003
++++ doomlegacy_src/makefile    Thu Feb 27 00:34:37 2003
+@@ -298,7 +298,7 @@
+       SFLAGS=
+-    CFLAGS=-g
++    CFLAGS=
+       OBJS=$(O)/i_video.o $(O)/vid_vesa.o
+@@ -471,9 +471,9 @@
+       # build with profiling information
+       ifdef PGCC
+-              CFLAGS = -g -pg -DPARANOIA -fwritable-strings $(OPTS)
++              CFLAGS = -g -pg $(OPTFLAGS) -DPARANOIA -fwritable-strings $(OPTS)
+       else
+-              CFLAGS = -g -pg -m486 -O3 -ffast-math -fwritable-strings $(OPTS)
++              CFLAGS = -g -pg $(OPTFLAGS) -ffast-math -fwritable-strings $(OPTS)
+       endif
+       LDFLAGS = -g -pg -L/usr/X11R6/lib
+ else
+@@ -481,13 +481,13 @@
+       # build a normal optimised version
+       ifdef PGCC
+-              CFLAGS = $(OPTS) -mpentium -O6 -ffast-math -fomit-frame-pointer -fwritable-strings
++              CFLAGS = $(OPTS) $(OPTFLAGS) -ffast-math -fwritable-strings
+               # -fgcse -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -ffunction-cse \
+               # -fexpensive-optimizations -fforce-mem -fstrength-reduce -fthread-jumps  \
+               # -fregmove -fschedule-insns -fschedule-insns2 -fmove-all-movables \
+               # -fcaller-saves -finline-functions -mieee-fp -mfp-ret-in-387 -m80387 -mhard-float -finline
+       else
+-              CFLAGS = -m486 -O3 -ffast-math -fomit-frame-pointer -fwritable-strings $(OPTS)
++              CFLAGS = $(OPTFLAGS) -ffast-math -fwritable-strings $(OPTS)
+       endif
+ endif
+@@ -644,7 +644,7 @@
+ #dll
+ dll : $(O)/r_opengl.o $(O)/ogl_x11.o
+-      $(CC) -mpentium -O6 -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
++      $(CC) $(OPTFLAGS) -o $(BIN)/r_opengl.so -shared -nostartfiles $(O)/r_opengl.o $(O)/ogl_x11.o -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext -lGL -lGLU -lm
+ musserv:
+       @mkdir -p $(MUSSERV)/linux
+@@ -658,7 +658,7 @@
+ ifdef LINUX
+ $(O)/r_opengl.o:      hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
+-      $(CC) -mpentium -O6 -o $(O)/r_opengl.o  -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++      $(CC) $(OPTFLAGS) -o $(O)/r_opengl.o    -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+ endif
+ ifdef SDL
+@@ -672,16 +672,16 @@
+       $(CC) $(CFLAGS) $(LDFLAGS) $(WFLAGS) -I/usr/X11R6/include -c $< -o $@
+ else  #FBSD_SDL
+ $(O)/r_opengl.o:      hardware/r_opengl/r_opengl.c hardware/r_opengl/r_opengl.h
+-      $(CC) -mpentium -O6 -o $(O)/r_opengl.o  -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
++      $(CC) $(OPTFLAGS) -o $(O)/r_opengl.o    -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/r_opengl.c
+ endif #FBSD_SDL
+ endif #FREEBSD
+ ifndef FREEBSD
+ $(O)/ogl_x11.o:  hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
+-      $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++      $(CC) $(OPTFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+ else
+ $(O)/ogl_x11.o:  hardware/r_opengl/ogl_x11.c hardware/r_opengl/r_opengl.h
+-      $(CC) -mpentium -O6 -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
++      $(CC) $(OPTFLAGS) -o $(O)/ogl_x11.o -DHWRENDER -DVID_X11 -DLINUX -DFREEBSD $(POLL_POINTER) -shared -nostartfiles -I/usr/X11R6/include -c hardware/r_opengl/ogl_x11.c
+ endif
index 79ea756543b15b23a7cc82488a601f16df64903b..c9bdf13c7c31162959481014b5e7d6907b74e90d 100644 (file)
@@ -1,52 +1,5 @@
---- doomlegacy-1.32/doomlegacy/linux_x/i_video_xshm.c.orig     Fri May 11 14:54:59 2001
-+++ doomlegacy-1.32/doomlegacy/linux_x/i_video_xshm.c  Sat Jun 30 10:55:58 2001
-@@ -1896,7 +1896,7 @@
-         
-        rendermode = render_opengl;
-        //dlptr = dlopen("./r_opengl.so",RTLD_LAZY);
--       dlptr = dlopen("./r_opengl.so",RTLD_NOW | RTLD_GLOBAL);
-+       dlptr = dlopen("/usr/X11R6/lib/doomlegacy/r_opengl.so",RTLD_NOW | RTLD_GLOBAL);
-        if(!dlptr) {
-           fprintf(stderr,"Error opening r_opengl.so!\n%s\n",dlerror());
-           rendermode = render_soft;
---- doomlegacy-1.32/doomlegacy/d_main.c.orig   Fri May 11 14:33:54 2001
-+++ doomlegacy-1.32/doomlegacy/d_main.c        Sat Jun 30 10:54:48 2001
-@@ -979,15 +979,7 @@
-     // change to the directory where 'doom3.wad' is found
-    I_LocateWad();
- #endif
--    doomwaddir = getenv("DOOMWADDIR");
--    if (!doomwaddir)
--    {
--        // get the current directory (possible problem on NT with "." as current dir)
--        if ( getcwd(pathtemp, _MAX_PATH) != NULL )
--            doomwaddir = pathtemp;
--        else
--            doomwaddir = ".";
--    }
-+    doomwaddir = getenv("DOOMWADDIR") ? getenv("DOOMWADDIR") : "/usr/X11R6/share/doomlegacy";
-         
- #ifdef __MACOS__
-         // cwd is always "/" when app is dbl-clicked
---- doomlegacy-1.32/doomlegacy/linux_x/i_system.c.orig Fri May 11 14:54:58 2001
-+++ doomlegacy-1.32/doomlegacy/linux_x/i_system.c      Wed Jul 18 15:33:51 2001
-@@ -119,10 +119,10 @@
- extern int             eventtail;
- // Locations for searching the doom3.wad
--#define DEFAULTWADLOCATION1 "/usr/local/games/legacy"
--#define DEFAULTWADLOCATION2 "/usr/games/legacy"
--#define DEFAULTSEARCHPATH1 "/usr/local"
--#define DEFAULTSEARCHPATH2 "/usr/games"
-+#define DEFAULTWADLOCATION1 "/usr/X11R6/share/doomlegacy"
-+#define DEFAULTWADLOCATION2 "/usr/share/games/doomlegacy"
-+#define DEFAULTSEARCHPATH1 "/usr/share/games"
-+#define DEFAULTSEARCHPATH2 "/usr/X11R6/share"
- #define WADKEYWORD "doom3.wad"
- // holds wad path
---- doomlegacy-1.32/doomlegacy/linux_x/musserv/musserver.c.orig        Fri May 11 14:55:26 2001
-+++ doomlegacy-1.32/doomlegacy/linux_x/musserv/musserver.c     Wed Jul 18 15:35:53 2001
+--- doomlegacy_src/linux_x/musserv/musserver.c.orig    Sat Feb 22 20:51:24 2003
++++ doomlegacy_src/linux_x/musserv/musserver.c Sat Feb 22 20:52:15 2003
 @@ -122,9 +122,7 @@
      ppid = getpid();
      if (verbose > 1) 
  
      while ((x = getopt(argc, argv, "acd:fhi:lmt:u:Vv")) != -1)
        switch (x)
---- doomlegacy-1.32/doomlegacy/linux_x/musserv/readwad.c.orig  Fri May 11 14:55:27 2001
-+++ doomlegacy-1.32/doomlegacy/linux_x/musserv/readwad.c       Wed Jul 18 15:37:09 2001
+--- doomlegacy_src/linux_x/musserv/readwad.c.orig      Sat Feb 22 20:52:25 2003
++++ doomlegacy_src/linux_x/musserv/readwad.c   Sat Feb 22 20:53:03 2003
 @@ -213,7 +213,7 @@
      FILE *fp;
  
      if (!(waddir = getenv("DOOMWADDIR")))
 -        waddir = ".";
-+        waddir = "/usr/X11R6/share/doomlegacy";
++      waddir = "/usr/X11R6/share/doomlegacy";
  
      wadfilename = malloc(2 + strlen(s) + strlen(waddir));
      if (*s != '/')
---- doomlegacy-1.32/doomlegacy/linux_x/searchp.c.orig  Fri May 11 14:54:59 2001
-+++ doomlegacy-1.32/doomlegacy/linux_x/searchp.c       Wed Jul 18 15:46:11 2001
-@@ -23,6 +23,11 @@
+--- doomlegacy_src/linux_x/i_video_xshm.c.orig Sat Feb 22 20:45:02 2003
++++ doomlegacy_src/linux_x/i_video_xshm.c      Sat Feb 22 20:46:49 2003
+@@ -1984,7 +1984,7 @@
+        rendermode = render_opengl;
+        // try to open library in CWD
+-       dlptr = dlopen("./r_opengl.so",RTLD_NOW | RTLD_GLOBAL);
++      dlptr = dlopen("/usr/lib/share/doomlegacy/r_opengl.so",RTLD_NOW | RTLD_GLOBAL);
+        if(!dlptr) {
+          // try to open in LIBPATH
+--- doomlegacy_src/linux_x/i_system.c.orig     Sat Feb 22 20:48:37 2003
++++ doomlegacy_src/linux_x/i_system.c  Sat Feb 22 20:50:55 2003
+@@ -141,9 +141,9 @@
+ extern int             eventtail;
+ // Locations for searching the legacy.dat
+-#define DEFAULTWADLOCATION1 "/usr/local/games/legacy"
+-#define DEFAULTWADLOCATION2 "/usr/games/legacy"
+-#define DEFAULTSEARCHPATH1 "/usr/local"
++#define DEFAULTWADLOCATION1 "/usr/X11R6/share/doomlegacy"
++#define DEFAULTWADLOCATION2 "/usr/X11R6/share/games/doomlegacy"
++#define DEFAULTSEARCHPATH1 "/usr/X11R6/share/games/"
+ #define DEFAULTSEARCHPATH2 "/usr/games"
+ #define DEFAULTSEARCHPATH2 "/usr/games"
+ #define WADKEYWORD "legacy.dat"
+--- doomlegacy_src/linux_x/searchp.c.orig      Sat Feb 22 20:53:41 2003
++++ doomlegacy_src/linux_x/searchp.c   Sat Feb 22 20:54:22 2003
+@@ -22,6 +22,12 @@
+       static char     b[2048];
        struct stat     s;
        char            pb[2048];
-+      strcpy(b,"/usr/X11R6/lib/doomlegacy/");
++      
++      strcpy(b,"/usr/X11R6/lib/doomlegacy_src/");
 +      strcat(b,file);
 +      if (stat(b, &s) == 0) {
 +              return(b);
 +      }
        /* get PATH, if not set just return filename, might be in cwd */
          /* added "./" for current path 19990416 by Kin */
-       if ((path = getenv("PATH")) == NULL) {
+--- doomlegacy_src/d_main.c.orig       Sat Feb 22 20:47:20 2003
++++ doomlegacy_src/d_main.c    Sat Feb 22 20:48:10 2003
+@@ -1022,16 +1022,8 @@
+     // change to the directory where 'legacy.dat' is found
+    I_LocateWad();
+ #endif
+-    doomwaddir = getenv("DOOMWADDIR");
+-    if (!doomwaddir)
+-    {
+-        // get the current directory (possible problem on NT with "." as current dir)
+-        if ( getcwd(pathtemp, _MAX_PATH) != NULL )
+-            doomwaddir = pathtemp;
+-        else
+-            doomwaddir = ".";
+-    }
+-        
++      doomwaddir = getenv("DOOMWADDIR") ? getenv("DOOMWADDIR") : "/usr/X11R6/share/doomlegacy";
++
+ #ifdef __MACOS__
+         // cwd is always "/" when app is dbl-clicked
+         if (!stricmp(doomwaddir,"/"))
This page took 0.040839 seconds and 4 git commands to generate.