]> git.pld-linux.org Git - packages/doomlegacy.git/commitdiff
- added errno patch (build fix needed on glibc 2.3.2)
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 7 Mar 2003 22:38:34 +0000 (22:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added no-cmap patch (don't try to force colour map in TrueColor modes)

Changed files:
    doomlegacy-errno.patch -> 1.1
    doomlegacy-nocmap.patch -> 1.1
    doomlegacy.spec -> 1.20

doomlegacy-errno.patch [new file with mode: 0644]
doomlegacy-nocmap.patch [new file with mode: 0644]
doomlegacy.spec

diff --git a/doomlegacy-errno.patch b/doomlegacy-errno.patch
new file mode 100644 (file)
index 0000000..93aedce
--- /dev/null
@@ -0,0 +1,36 @@
+--- doomlegacy-1.40/doomlegacy_src/linux_x/i_sound.c.orig      Fri Mar  7 22:14:51 2003
++++ doomlegacy-1.40/doomlegacy_src/linux_x/i_sound.c   Fri Mar  7 22:18:30 2003
+@@ -88,6 +88,7 @@
+ #include <sys/filio.h>
+ #endif
++#include <errno.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+@@ -261,7 +262,6 @@
+   int*  arg )
+ {   
+     int         rc;
+-    extern int  errno;
+     
+     rc = ioctl(fd, command, arg);  
+     if (rc < 0)
+--- doomlegacy-1.40/doomlegacy_src/linux_x/sndserv/linux.c.orig        Sun Sep 22 00:35:57 2002
++++ doomlegacy-1.40/doomlegacy_src/linux_x/sndserv/linux.c     Fri Mar  7 22:22:26 2003
+@@ -39,6 +39,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <errno.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+@@ -67,7 +68,6 @@
+   int*  arg )
+ {   
+     int         rc;
+-    extern int  errno;
+     
+     rc = ioctl(fd, command, arg);  
+     if (rc < 0)
diff --git a/doomlegacy-nocmap.patch b/doomlegacy-nocmap.patch
new file mode 100644 (file)
index 0000000..488e87f
--- /dev/null
@@ -0,0 +1,30 @@
+--- doomlegacy-1.40/doomlegacy_src/linux_x/i_video_xshm.c.orig Fri Mar  7 22:22:56 2003
++++ doomlegacy-1.40/doomlegacy_src/linux_x/i_video_xshm.c      Fri Mar  7 22:51:25 2003
+@@ -1619,14 +1619,14 @@
+     if(rendermode==render_soft) {
+     // setup attributes for main window
+     if (vidmode_active) {
+-       attribmask = CWColormap | CWSaveUnder | CWBackingStore | 
++       attribmask = CWSaveUnder | CWBackingStore | 
+           CWEventMask | CWOverrideRedirect;
+        attribs.override_redirect = True;
+        attribs.backing_store = NotUseful;
+        attribs.save_under = False;
+     } else
+-       attribmask = CWBorderPixel | CWColormap | CWEventMask;
++       attribmask = CWBorderPixel | CWEventMask;
+     attribs.event_mask = KeyPressMask | KeyReleaseMask
+ #ifndef POLL_POINTER
+@@ -1634,7 +1634,10 @@
+ #endif
+        | ExposureMask | StructureNotifyMask;
+     
++    if( x_pseudo ) {
++    attribmask |= CWColormap;
+     attribs.colormap = X_cmap;
++    }
+     attribs.border_pixel = 0;
+     
+     // create the main window
index ca63af9067b04305219e8ba1cb17c90704cd85fd..ca0bdcaaa736fcb389b08407946c33b394329bd0 100644 (file)
@@ -17,6 +17,8 @@ Patch0:               %{name}-paths.patch
 Patch1:                %{name}-Makefile.patch
 Patch2:                %{name}-nosndstat.patch
 Patch3:                %{name}-sound.patch
+Patch4:                %{name}-errno.patch
+Patch5:                %{name}-nocmap.patch
 BuildRequires: OpenGL-devel
 BuildRequires: SDL_mixer-devel
 BuildRequires: XFree86-devel
@@ -77,6 +79,8 @@ To jest DOOM Legacy dla Linuksa - wersja SDL.
 %patch1 -p0
 %patch2 -p0
 %patch3 -p0
+%patch4 -p1
+%patch5 -p1
 
 %build
 mkdir bin
This page took 0.084298 seconds and 4 git commands to generate.