]> git.pld-linux.org Git - packages/doom3.git/blob - doom3.spec
- updated URL for 1.3
[packages/doom3.git] / doom3.spec
1 # NOTE: You could add to your 'mirrors', to get stuff downloaded:
2 #  ftp://dl.xs4all.nl/pub/mirror/idsoftware/idstuff/doom3/linux/
3 # TODO:
4 #  - package dedicated server - doomded.x86
5 #  - check if system libstdc++ and libgcc_s can be used
6 #    answered here: http://zerowing.idsoftware.com/linux/doom/#head-d15dfbca9b3ba90b9bacb7476ad2f0afe3bb0f72
7 #    so? we are not gentoo.
8 #  - check license?
9 #
10 # Conditional build:
11 %bcond_with     demo    # package demo data
12 %define         demo_version 1.1.1286
13 #
14 Summary:        Doom III - 3rd installment of the classic id 3D first-person shooter
15 Summary(de.UTF-8):      Doom III - der dritte Teil des FPP Klassikers von id Software
16 Summary(pl.UTF-8):      Doom III - trzecia część klasyki FPP z id Software
17 Name:           doom3
18 Version:        1.3.1302
19 Release:        0.8
20 Vendor:         id Software
21 License:        DOOM3
22 Group:          Applications/Games
23 Source0:        ftp://ftp.idsoftware.com/idstuff/doom3/linux/old/%{name}-linux-%{version}.x86.run
24 # NoSource0-md5:        b1d04da2d64bb8d54f64cbaa2fdb4490
25 Source1:        ftp://ftp.idsoftware.com/idstuff/doom3/linux/%{name}-linux-%{demo_version}-demo.x86.run
26 # NoSource1-md5:        81dcf8ead198f14844c554b25e07abbe
27 Source2:        %{name}.desktop
28 NoSource:       0
29 NoSource:       1
30 URL:            http://www.doom3.com/
31 ExclusiveArch:  %{ix86}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         no_install_post_strip   1
35
36 %define         _noautoprov             libgcc_s.so.1 libstdc++.so.5
37 %define         _noautoreq              libgcc_s.so.1 libstdc++.so.5
38 %define         _gamelibdir             %{_libdir}/games/doom3
39 %define         _gamedatadir            %{_datadir}/games/doom3
40
41 %description
42 Doom III for Linux.
43
44 To play the game you need to copy data files from your Doom III CD or
45 you could try playing demo by installing %{name}-demo package.
46
47 %description -l de.UTF-8
48 Doom III für Linux.
49
50 Um das Spiel zu spielen musst du die Dateien aus deiner Doom III CD
51 kopieren oder du kannst das Demo ausprobieren indem du %{name}-demo
52 installierst.
53
54 %description -l pl.UTF-8
55 Doom III dla Linuksa.
56
57 Do grania trzeba skopiować pliki danych z płyty Doom III, albo można
58 spróbować grać w wersji demo instalując pakiet %{name}-demo.
59
60 %package demo
61 Summary:        Doom III Demo data files
62 Summary(de.UTF-8):      Doom III Demo Dateien
63 Summary(pl.UTF-8):      Pliki danych Doom III Demo
64 Group:          Applications/Games
65 Version:        %{demo_version}
66 # main package version is mostly bigger than demo itself.
67 Requires:       %{name} >= %{demo_version}
68
69 %description demo
70 This package contains the data files for Doom III Demo.
71
72 %description demo -l de.UTF-8
73 Dieses Packet enthält Dateien für das Doom III Demo.
74
75 %description demo -l pl.UTF-8
76 Ten pakiet zawiera pliki danych dla gry Doom III Demo.
77
78 %prep
79 %setup -qcT
80 %if %{with demo}
81 sh %{SOURCE1} --tar xf
82 %endif
83 # here we overwrite files which are shared with demo package. that's intentional
84 sh %{SOURCE0} --tar xf
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{_gamelibdir},%{_gamedatadir}/{demo,base}} \
89         $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_bindir}}
90
91 install libgcc_s.so.1 libstdc++.so.5 $RPM_BUILD_ROOT%{_gamelibdir}
92 install bin/Linux/x86/doom.x86 $RPM_BUILD_ROOT%{_gamelibdir}
93
94 install %{name}.png $RPM_BUILD_ROOT%{_pixmapsdir}
95 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
96
97 cat << 'EOF' > $RPM_BUILD_ROOT%{_bindir}/%{name}
98 #!/bin/sh
99 # Needed to make symlinks/shortcuts work.
100 # the binaries must run with correct working directory
101 cd %{_gamelibdir}
102 export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
103 exec ./doom.x86 "$@"
104 EOF
105
106 %if %{with demo}
107 install gamex86.so $RPM_BUILD_ROOT%{_gamelibdir}
108 install demo/* $RPM_BUILD_ROOT%{_gamedatadir}/demo
109 ln -s %{_gamedatadir}/demo $RPM_BUILD_ROOT%{_gamelibdir}/demo
110 %endif
111
112 install base/* $RPM_BUILD_ROOT%{_gamedatadir}/base
113 ln -s %{_gamedatadir}/base $RPM_BUILD_ROOT%{_gamelibdir}/base
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc License.txt README version.info
121 %attr(755,root,root) %{_bindir}/%{name}
122 %dir %{_gamelibdir}
123 %attr(755,root,root) %{_gamelibdir}/doom.x86
124 %attr(755,root,root) %{_gamelibdir}/libgcc_s.so.1
125 %attr(755,root,root) %{_gamelibdir}/libstdc++.so.5
126 %{_desktopdir}/%{name}.desktop
127 %{_pixmapsdir}/%{name}.png
128 %dir %{_gamedatadir}
129 %dir %{_gamedatadir}/base
130 %{_gamedatadir}/base/*
131 %{_gamelibdir}/base
132
133 %if %{with demo}
134 %files demo
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_gamelibdir}/gamex86.so
137 %dir %{_gamedatadir}/demo
138 %{_gamedatadir}/demo/*
139 %{_gamelibdir}/demo
140 %endif
This page took 0.112021 seconds and 3 git commands to generate.