]> git.pld-linux.org Git - packages/domoticz.git/commitdiff
up to 2024.2 auto/th/domoticz-2024.2-1
authorJan Palus <atler@pld-linux.org>
Tue, 16 Jan 2024 11:23:16 +0000 (12:23 +0100)
committerJan Palus <atler@pld-linux.org>
Tue, 16 Jan 2024 11:23:16 +0000 (12:23 +0100)
- openzwave is back although with "no support" upstream annotation

domoticz-tinyxpath.patch
domoticz.spec

index f0e94976d93c6c2e146486397df9558af432ccb3..03a4d93c029366ace3d8fc5b96318260bc38998a 100644 (file)
@@ -88,9 +88,36 @@ index bc231d8f6..334f203a6 100644
 +  ENDIF(TinyXML_FOUND)
 +ENDIF(USE_BUILTIN_TINYXPATH)
 +
- IF(EXISTS /sys/class/gpio OR FORCE_WITH_GPIO)
-   message(STATUS "GPIO is available")
-   add_definitions(-DWITH_GPIO)
+ #
+ # OpenZWave
+ # try to find open-zwave, if found, include support
+--- a/hardware/openzwave/control_panel/ozwcp.cpp       2020-03-22 09:16:16.000000000 -0500
++++ b/hardware/openzwave/control_panel/ozwcp.cpp       2020-03-24 10:53:04.968630391 -0500
+@@ -49,7 +49,7 @@
+ #include <sys/stat.h>
+ #include <fstream>
+ #include <iostream>
+-#include "../../../tinyxpath/tinyxml.h"
++#include <tinyxml.h>
+ //#include "microhttpd.h"
+ #include "ozwcp.h"
+--- a/hardware/plugins/PluginManager.cpp       2020-03-22 09:16:16.000000000 -0500
++++ b/hardware/plugins/PluginManager.cpp       2020-03-24 13:53:05.305852598 -0500
+@@ -21,11 +21,12 @@
+ #include "../../main/Logger.h"
+ #include "../../main/SQLHelper.h"
+ #include "../../main/WebServer.h"
+-#include "../../tinyxpath/tinyxml.h"
+ #ifdef WIN32
++#       include "../../tinyxpath/tinyxml.h"
+ #     include <direct.h>
+ #else
+ #     include <sys/stat.h>
++#       include <tinyxml.h>
+ #endif
+ #include "DelayedLink.h"
 --- a/hardware/plugins/Plugins.cpp     2020-03-22 09:16:16.000000000 -0500
 +++ b/hardware/plugins/Plugins.cpp     2020-03-24 13:45:46.056965796 -0500
 @@ -16,10 +16,11 @@
@@ -201,19 +228,3 @@ index bc231d8f6..334f203a6 100644
  
  
  #ifdef _DEBUG
---- domoticz-2024.1/hardware/plugins/PluginManager.cpp.orig    2024-01-01 12:59:22.000000000 +0100
-+++ domoticz-2024.1/hardware/plugins/PluginManager.cpp 2024-01-01 15:17:05.057939388 +0100
-@@ -20,12 +20,12 @@
- #include "../../main/Logger.h"
- #include "../../main/SQLHelper.h"
- #include "../../main/WebServer.h"
--#include "../../tinyxpath/tinyxml.h"
- #ifdef WIN32
- #     include <direct.h>
- #else
- #     include <sys/stat.h>
- #endif
-+#include <tinyxml.h>
- #include "DelayedLink.h"
- #include "../../main/EventsPythonModule.h"
index 91f174864c4ec55d5ea6ef5936435f37e189df38..df36f778c6240a3aae53c48022694e15dbf382ec 100644 (file)
@@ -1,12 +1,12 @@
 Summary:       Open source Home Automation System
 Name:          domoticz
-Version:       2024.1
-Release:       2
+Version:       2024.2
+Release:       1
 License:       GPLv3+ and ASL 2.0 and Boost and BSD and MIT
 Group:         Base
 URL:           http://www.domoticz.com
 Source0:       https://github.com/domoticz/domoticz/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 35b60b24ab2e1cf6d721d6720ae8a670
+# Source0-md5: 0b7e289370e31e1349deffada9c11462
 Source1:       %{name}.service
 Source2:       %{name}.conf
 # Use system tinyxpath (https://github.com/domoticz/domoticz/pull/1759)
@@ -22,6 +22,7 @@ BuildRequires:        cmake >= 3.16.0
 BuildRequires: curl-devel
 BuildRequires: jsoncpp-devel
 BuildRequires: libmosquitto-devel
+BuildRequires: libopenzwave-devel >= 1.5.0
 BuildRequires: libstdc++-devel >= 6:4.9
 BuildRequires: libusb-compat-devel
 BuildRequires: linux-libc-headers
@@ -41,6 +42,7 @@ Requires(pre):        /usr/sbin/useradd
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      fonts-TTF-Google-Droid
 Requires:      fonts-TTF-OpenSans
+Requires:      libopenzwave >= 1.5.0
 Requires:      setup >= 2.10.1
 Suggests:      python3-libs
 Provides:      group(domoticz)
@@ -82,6 +84,7 @@ export CXXFLAGS="%{rpmcxxflags} -DPYTHON_LIBDIR=\\\"%{_libdir}\\\""
        -DUSE_OPENSSL_STATIC=NO \
        -DUSE_STATIC_BOOST=NO \
        -DUSE_STATIC_LIBSTDCXX=NO \
+       -DUSE_STATIC_OPENZWAVE=NO \
        -DFORCE_WITH_GPIO:BOOL=TRUE \
        -DCMAKE_INSTALL_PREFIX=%{_datadir}/%{name} \
        ..
@@ -121,6 +124,10 @@ ln -s %{_fontsdir}/TTF/DroidSans.ttf \
 ln -s %{_fontsdir}/TTF/OpenSans-Regular.ttf \
        $RPM_BUILD_ROOT%{_datadir}/%{name}/www/styles/element-dark/fonts/OpenSans.ttf
 
+# OpenZWave Control Panel temp file
+ln -s %{_sharedstatedir}/%{name}/ozwcp.poll.XXXXXX.xml \
+       $RPM_BUILD_ROOT%{_datadir}/%{name}/ozwcp.poll.XXXXXX.xml
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.327154 seconds and 4 git commands to generate.